Closed Bug 1486501 Opened 2 years ago Closed 2 years ago

Intermittent /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[R_PAGEDOWN-expected39] - setup error

Categories

(Testing :: geckodriver, defect, P5)

Version 3
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1482550

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Filed by: csabou [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=196108321&repo=autoland

https://queue.taskcluster.net/v1/task/VxEbEqxpQqu1AVC4u_m6pg/runs/0/artifacts/public/logs/live_backing.log

[task 2018-08-27T15:35:16.592Z] 15:35:16     INFO - TEST-UNEXPECTED-ERROR | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[R_PAGEDOWN-expected39] - setup error
[task 2018-08-27T15:35:16.593Z] 15:35:16     INFO - session = <Session 80a747bf-b8c6-4189-8aa1-f8f6ab76d14a>
[task 2018-08-27T15:35:16.593Z] 15:35:16     INFO - test_actions_page = None
[task 2018-08-27T15:35:16.594Z] 15:35:16     INFO - request = <SubRequest 'key_reporter' for <Function 'test_webdriver_special_key_sends_keydown[R_PAGEDOWN-expected39]'>>
[task 2018-08-27T15:35:16.595Z] 15:35:16     INFO - 
[task 2018-08-27T15:35:16.595Z] 15:35:16     INFO -     @pytest.fixture
[task 2018-08-27T15:35:16.596Z] 15:35:16     INFO -     def key_reporter(session, test_actions_page, request):
[task 2018-08-27T15:35:16.596Z] 15:35:16     INFO -         """Represents focused input element from `test_keys_page` fixture."""
[task 2018-08-27T15:35:16.596Z] 15:35:16     INFO - >       input_el = session.find.css("#keys", all=False)
[task 2018-08-27T15:35:16.597Z] 15:35:16     INFO - 
[task 2018-08-27T15:35:16.597Z] 15:35:16     INFO - request    = <SubRequest 'key_reporter' for <Function 'test_webdriver_special_key_sends_keydown[R_PAGEDOWN-expected39]'>>
[task 2018-08-27T15:35:16.597Z] 15:35:16     INFO - session    = <Session 80a747bf-b8c6-4189-8aa1-f8f6ab76d14a>
[task 2018-08-27T15:35:16.598Z] 15:35:16     INFO - test_actions_page = None
[task 2018-08-27T15:35:16.598Z] 15:35:16     INFO - 
[task 2018-08-27T15:35:16.598Z] 15:35:16     INFO - tests/web-platform/tests/webdriver/tests/actions/conftest.py:27: 
[task 2018-08-27T15:35:16.599Z] 15:35:16     INFO - _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
[task 2018-08-27T15:35:16.599Z] 15:35:16     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:20: in inner
[task 2018-08-27T15:35:16.599Z] 15:35:16     INFO -     return func(self, *args, **kwargs)
[task 2018-08-27T15:35:16.599Z] 15:35:16     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:312: in css
[task 2018-08-27T15:35:16.600Z] 15:35:16     INFO -     return self._find_element("css selector", selector, all)
[task 2018-08-27T15:35:16.600Z] 15:35:16     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:318: in _find_element
[task 2018-08-27T15:35:16.601Z] 15:35:16     INFO -     return self.session.send_session_command("POST", route, body)
[task 2018-08-27T15:35:16.601Z] 15:35:16     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:509: in send_session_command
[task 2018-08-27T15:35:16.602Z] 15:35:16     INFO -     return self.send_command(method, url, body)
[task 2018-08-27T15:35:16.602Z] 15:35:16     INFO - _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
[task 2018-08-27T15:35:16.602Z] 15:35:16     INFO - 
[task 2018-08-27T15:35:16.603Z] 15:35:16     INFO - self = <Session 80a747bf-b8c6-4189-8aa1-f8f6ab76d14a>, method = 'POST'
[task 2018-08-27T15:35:16.604Z] 15:35:16     INFO - url = 'session/80a747bf-b8c6-4189-8aa1-f8f6ab76d14a/element'
[task 2018-08-27T15:35:16.604Z] 15:35:16     INFO - body = {'using': 'css selector', 'value': '#keys'}
[task 2018-08-27T15:35:16.605Z] 15:35:16     INFO - 
[task 2018-08-27T15:35:16.605Z] 15:35:16     INFO -     def send_command(self, method, url, body=None):
[task 2018-08-27T15:35:16.605Z] 15:35:16     INFO -         """
[task 2018-08-27T15:35:16.605Z] 15:35:16     INFO -             Send a command to the remote end and validate its success.
[task 2018-08-27T15:35:16.606Z] 15:35:16     INFO -     
[task 2018-08-27T15:35:16.606Z] 15:35:16     INFO -             :param method: HTTP method to use in request.
[task 2018-08-27T15:35:16.607Z] 15:35:16     INFO -             :param uri: "Command part" of the HTTP request URL,
[task 2018-08-27T15:35:16.607Z] 15:35:16     INFO -                 e.g. `window/rect`.
[task 2018-08-27T15:35:16.607Z] 15:35:16     INFO -             :param body: Optional body of the HTTP request.
[task 2018-08-27T15:35:16.607Z] 15:35:16     INFO -     
[task 2018-08-27T15:35:16.608Z] 15:35:16     INFO -             :return: `None` if the HTTP response body was empty, otherwise
[task 2018-08-27T15:35:16.608Z] 15:35:16     INFO -                 the `value` field returned after parsing the response
[task 2018-08-27T15:35:16.608Z] 15:35:16     INFO -                 body as JSON.
[task 2018-08-27T15:35:16.609Z] 15:35:16     INFO -     
[task 2018-08-27T15:35:16.609Z] 15:35:16     INFO -             :raises error.WebDriverException: If the remote end returns
[task 2018-08-27T15:35:16.610Z] 15:35:16     INFO -                 an error.
[task 2018-08-27T15:35:16.611Z] 15:35:16     INFO -             :raises ValueError: If the response body does not contain a
[task 2018-08-27T15:35:16.611Z] 15:35:16     INFO -                 `value` key.
[task 2018-08-27T15:35:16.612Z] 15:35:16     INFO -             """
[task 2018-08-27T15:35:16.612Z] 15:35:16     INFO -         response = self.transport.send(
[task 2018-08-27T15:35:16.613Z] 15:35:16     INFO -             method, url, body,
[task 2018-08-27T15:35:16.613Z] 15:35:16     INFO -             encoder=protocol.Encoder, decoder=protocol.Decoder,
[task 2018-08-27T15:35:16.613Z] 15:35:16     INFO -             session=self)
[task 2018-08-27T15:35:16.613Z] 15:35:16     INFO -     
[task 2018-08-27T15:35:16.614Z] 15:35:16     INFO -         if response.status != 200:
[task 2018-08-27T15:35:16.614Z] 15:35:16     INFO -             err = error.from_response(response)
[task 2018-08-27T15:35:16.615Z] 15:35:16     INFO -     
[task 2018-08-27T15:35:16.616Z] 15:35:16     INFO -             if isinstance(err, error.InvalidSessionIdException):
[task 2018-08-27T15:35:16.616Z] 15:35:16     INFO -                 # The driver could have already been deleted the session.
[task 2018-08-27T15:35:16.617Z] 15:35:16     INFO -                 self.session_id = None
[task 2018-08-27T15:35:16.617Z] 15:35:16     INFO -     
[task 2018-08-27T15:35:16.617Z] 15:35:16     INFO - >           raise err
[task 2018-08-27T15:35:16.618Z] 15:35:16     INFO - E           UnknownErrorException: unknown error (500): Failed to convert data to an object
[task 2018-08-27T15:35:16.618Z] 15:35:16     INFO - 
[task 2018-08-27T15:35:16.618Z] 15:35:16     INFO - body       = {'using': 'css selector', 'value': '#keys'}
[task 2018-08-27T15:35:16.619Z] 15:35:16     INFO - err        = <UnknownErrorException http_status=500>
[task 2018-08-27T15:35:16.619Z] 15:35:16     INFO - method     = 'POST'
[task 2018-08-27T15:35:16.619Z] 15:35:16     INFO - response   = <Response status=500 error=<UnknownErrorException http_status=500>>
[task 2018-08-27T15:35:16.619Z] 15:35:16     INFO - self       = <Session 80a747bf-b8c6-4189-8aa1-f8f6ab76d14a>
[task 2018-08-27T15:35:16.620Z] 15:35:16     INFO - url        = 'session/80a747bf-b8c6-4189-8aa1-f8f6ab76d14a/element'
[task 2018-08-27T15:35:16.620Z] 15:35:16     INFO - 
[task 2018-08-27T15:35:16.620Z] 15:35:16     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:473: UnknownErrorException
Content process crash. Most likely due to bug 1482029.
Depends on: 1482029
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1482550
You need to log in before you can comment on or make changes to this bug.