Closed Bug 1486957 Opened Last year Closed Last year

tooltip does not pop up when mouse over Location Bar after browser width is enlarged

Categories

(Firefox :: Address Bar, defect)

63 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- verified

People

(Reporter: alice0775, Assigned: emilio)

References

Details

(Keywords: regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1486166 +++

Bug 1486166 did not fix the following situation.

Reproducible: always

Steps To Reproduce:
1. Shrink browser width so that Location bar will be overflowed
   e.g, width = 650px 
2. Load long URL page
   e.g, https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/What_are_WebExtensions
3. Mouse over the location bar
   --- OK, tooltip pops up as expected

4. Increase the width of the browser, but the location bar still overflows
   e.g, width = 900px
5. Mouse over the location bar
   --- Bug, tooltip does not pop up

Actual Results:
URL tooltip does not pop up

Expected Results:
URL tooltip should pop up
Blocks: 1486166
We're not setting the textoverflow attribute properly. This is not really a regression from bug 1440682. I have a patch that fixes it though.
No longer blocks: 1440682, 1486166
Depends on: 1486166
That attribute is set async, _inOverflow should work equally well, and work if
there's a mousemove before the next promiseDocumentFlush callback runs.
Assignee: nobody → emilio
Comment on attachment 9004802 [details]
Don't use the textoverflow attribute decide whether to set the tooltip text.

Dão Gottwald [::dao] has approved the revision.
Attachment #9004802 - Flags: review+
Oh, I just realized that this doesn't fix all cases still, but it's a pre-existing problem. In particular, we're firing overflow events for the placeholder, which means that when you overflow the NAC you may get confused and think that the value doesn't overflow (but it does!). I'll file another one for that.
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/446891c2f2fb
Don't use the textoverflow attribute decide whether to set the tooltip text. r=dao
Blocks: 1487027
https://hg.mozilla.org/mozilla-central/rev/446891c2f2fb
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Flags: qe-verify+
The issue is Verified - Fixed since it can no longer be reproduced on the latest Nightly 63.0a1 (2018-09-03) on all the above mentioned OS.

The tooltip will be displayed after increasing the width of the browser while the address bar is still overflowed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
QA Contact: mak77
You need to log in before you can comment on or make changes to this bug.