Closed Bug 1486975 Opened 2 years ago Closed 2 years ago

Windows 10 kills pdf Document word search (ctrl+F) forces Microsoft Edge

Categories

(Firefox :: Untriaged, defect)

61 Branch
defect
Not set

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: pauls583, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180807170231

Steps to reproduce:

2 PC's Both using a copy of the same FF profile so settings are the same.
PC 1 Windows 7 Home, Firefox 61.0.2 Old install never search problems using ctrl  + F
PC 2 Windows 10 PRO, Firefox 61.0.2 New install and updated W10 forces use of MS Edge.

1- PC1 W7 Open pdf document with FF eg: *.pdf motherboard manual 
2- Ctrl + F 
3 - Enter search word eg: 'reset', All good.
4- PC2 W10 Open same pdf document with FF and enter same search word 'reset'  search fails.
See screen shot
5 - Do the same with MS Edge and all is fine.


Actual results:

Microsoft is crippling FF, Unable to carry out search terms in documents forcing the use MS Edge. MS is also preventing the association and or permanent association of file types. 


Expected results:

All the word searchers in Windows 10 should have been successful as they where in Windows7 using the same document as all words searched are in the pdf document.
Attached file pdf-sample.pdf
Hi!

Thank you for the feedback and for taking the time to report this.  

I cannot reproduce the issue on Windows 10 x64 using the latest Nightly 63.0a1 (2018-09-02)(64-bit) Build ID: 20180902220539 and Release 61.0.2 (64-bit) Build Id: 20180807170231.
I've tried with the attached pdf-sample.pdf, but the search worked every time.

However, one time I've managed to reproduce an issue similar to yours, you can find more details here: https://bugzilla.mozilla.org/show_bug.cgi?id=1486984#c2 .
If this is not how it happened in your case, could you please retest using safe mode (https://goo.gl/AR5o9d), maybe even a new clean Firefox profile (https://goo.gl/AWo6h8), to eliminate add-ons or custom settings as a possible cause.
Flags: needinfo?(pauls583)
Hi, your suggested bug link is different, see below.

Notes: 
Search is using a pdf file on my HDD
Search as activated with 'Ctrl + F'
I have no installed PDF reader, Edge and FF is all I have, Newish install of W10 trying to lock down Microsoft Spyware.
Edge/W10 will not allow nor provide a way for me to make FF default PDF reader as I have in W7 for local files.

The following steps where conducted with FF on your suggestion 'Help' > 'Restart with add-ons disabled' I chose 'Safe Mode' Not refresh.

started with add-ons disabled 
Opened FF
From 'File' navigated to the manual on HDD as previously uploaded
searched word 'bios' good
searched word 'reset' good
Closed FF
Went to folder for manual and clicked on it
Edge opened it up 
closed edge
Context menu > Open with > Firefox
Manual opened
search word 'bios' failed
search word 'reset' failed
Firefox opened, drag and drop file failed
Closed Firefox, Drag and dropped file on FF Desktop icon (open with)
search word 'bios' good
search word 'reset' good.
Closed FF
Went back to folder and again did 'Open With' Context menu, and not left click which would load in Edge.
searched word 'bios' good
searched word 'reset' good
Previously failed as above. 
Still in pdf files directory selected file (left click) and it opened again with Edge
Did nothing closed edge within 2 seconds
right clicked on the file and selected open with FF
search word 'bios' failed
search word 'reset' failed
Tried a few times same results
Closed FF
Opened FF 
Select 'File' > 'Open'
Selected Manual 
searched word 'bios' good
searched word 'reset' good
It's hit and miss, But edge is the problem.
I 'Refreshed' FF 
Same/similar results.

I reinstated my profile and same results as above 'without add-ons' or 'refreshed' mode.
It seems that if Edge opens the file first it will not relinquish something that is temporarily affecting FF's search.

Conclusion
Just another W10 program from MS that will not relinquish control, I'm new to W10 from W7 and I feel dirty every time I use it. Time to go back to W7 I thingk.
Flags: needinfo?(pauls583)
Hi,

Thank you again for your feedback , I've tried with the detailed steps you provided us, but still couldn't reproduce the issue.
I've tried again on Windows 10 x64 using the latest Nightly 64.0a1 Build ID: 20180921100113 and Release 61.0.2 (64-bit) Build Id: 20180807170231, also latest Release 62.0 Build Id:20180830143136, this time with another larger pdf file, but the results were the same, even by following the exact steps you provided, the search worked every time. 

Please make sure you have the latest updated version of Firefox and try again, also please download Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem.
Flags: needinfo?(pauls583)
Based on the lack of information from the reporter this bug will have the Status: Resolved as incomplete.
If you want to add more info that can help to understand this bug please reopen it.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE

How do you reopen a bug and upload about 50MB that might help. This bug is now also on W7 using FF67.

How do I reopen.

Flags: needinfo?(pauls583)
You need to log in before you can comment on or make changes to this bug.