The new folder created doesn't have any title

VERIFIED FIXED in Firefox 68

Status

()

defect
P3
normal
VERIFIED FIXED
11 months ago
Last month

People

(Reporter: stefan.deiac, Assigned: diana.iacos)

Tracking

Trunk
Firefox 69
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox61 wontfix, firefox62 wontfix, firefox63 wontfix, firefox64 wontfix, firefox65 wontfix, firefox66 wontfix, firefox67 wontfix, firefox68 verified, firefox69 verified)

Details

Attachments

(1 attachment)

Environment: 
Device: OnePlus 5T (Android 8.1.0);

Steps to reproduce:
1. Open Bookmarks; 
2. Long tap on a link;
3. Choose edit;
4. Tap on Parent folder;
5. Tap on "folder+" sign from Toolbar - right);
6. Save the new folder without any name.


Expected result:
The new folder created has a predefined "(no title)" name.

Actual result:
The new folder created doesn't have any title.

Notes:
Desktop version of Firefox displays the folder with the predefined "(no title)" name. The mobile version of FF should follow the same implementation as Desktop.
Update: After creating the folder, if you long tap on it, space where should be the name it's empty.
During triage, we discussed this being a P3 issue. Having parity with desktop would be nice, but at this time this doesn't sound like a high priority item.
Priority: -- → P3
Assignee: nobody → diana.iacos
Status: NEW → ASSIGNED
Keywords: checkin-needed

Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/913933ff0e8e
The new folder created doesn't have any title; r=petru

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Diana, please request uplift to Fennec 68 Beta so we can ship your fix in Fennec 68 ESR.

Flags: needinfo?(diana.iacos)

Comment on attachment 9069952 [details]
Bug 1487013 - The new folder created doesn't have any title; r?petru

Beta/Release Uplift Approval Request

  • User impact if declined: The new folder will be without any title.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Open Bookmarks;
  1. Long tap on a link;
  2. Choose edit;
  3. Tap on Parent folder;
  4. Tap on "folder+" sign from Toolbar - right);
  5. Save the new folder without any name.

Expected result:
The new folder created has a predefined "(no title)" name.

Actual result:
The new folder created doesn't have any title.

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The changes are not risky because we added only a condition to check if the folder’s title added by the user it’s empty.
  • String changes made/needed: The string that was added : bookmark_default_folder_title
Flags: needinfo?(diana.iacos)
Attachment #9069952 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9069952 [details]
Bug 1487013 - The new folder created doesn't have any title; r?petru

fennec bookmark fix, approved for 68.0b9

Attachment #9069952 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified as fixed on Nightly 69.0a1 (2019-06-10), Beta 68.0b9 with Samsung Galaxy S8 (Android 9).
Due to my findings, I'll mark this issue as verified. Thanks.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.