Closed Bug 1487016 Opened 2 years ago Closed 2 years ago

Intermittent /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[NUMPAD0-expected26] - setup error

Categories

(Testing :: geckodriver, defect, P5)

Version 3
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1482550

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Filed by: toros [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=196375998&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/DYArtl-kR3eZO1ST0zbTMA/runs/0/artifacts/public/logs/live_backing.log

[task 2018-08-29T07:26:38.285Z] 07:26:38     INFO - TEST-PASS | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[SUBTRACT-expected16] 
[task 2018-08-29T07:26:38.285Z] 07:26:38     INFO - TEST-PASS | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[CONTROL-expected17] 
[task 2018-08-29T07:26:38.286Z] 07:26:38     INFO - TEST-PASS | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[INSERT-expected18] 
[task 2018-08-29T07:26:38.286Z] 07:26:38     INFO - TEST-PASS | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[R_META-expected19] 
[task 2018-08-29T07:26:38.287Z] 07:26:38     INFO - TEST-PASS | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[SEMICOLON-expected20] 
[task 2018-08-29T07:26:38.288Z] 07:26:38     INFO - TEST-PASS | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[SPACE-expected21] 
[task 2018-08-29T07:26:38.288Z] 07:26:38     INFO - TEST-PASS | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[NUMPAD4-expected22] 
[task 2018-08-29T07:26:38.289Z] 07:26:38     INFO - TEST-PASS | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[RIGHT-expected23] 
[task 2018-08-29T07:26:38.290Z] 07:26:38     INFO - TEST-PASS | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[TAB-expected24] 
[task 2018-08-29T07:26:38.291Z] 07:26:38     INFO - TEST-PASS | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[R_ALT-expected25] 
[task 2018-08-29T07:26:38.292Z] 07:26:38     INFO - TEST-UNEXPECTED-ERROR | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[NUMPAD0-expected26] - setup error
[task 2018-08-29T07:26:38.293Z] 07:26:38     INFO - session = <Session 3630bc19-920d-4d93-bbc6-8b68825088c4>
[task 2018-08-29T07:26:38.293Z] 07:26:38     INFO - test_actions_page = None
[task 2018-08-29T07:26:38.294Z] 07:26:38     INFO - request = <SubRequest 'key_reporter' for <Function 'test_webdriver_special_key_sends_keydown[NUMPAD0-expected26]'>>
[task 2018-08-29T07:26:38.294Z] 07:26:38     INFO - 
[task 2018-08-29T07:26:38.296Z] 07:26:38     INFO -     @pytest.fixture
[task 2018-08-29T07:26:38.296Z] 07:26:38     INFO -     def key_reporter(session, test_actions_page, request):
[task 2018-08-29T07:26:38.296Z] 07:26:38     INFO -         """Represents focused input element from `test_keys_page` fixture."""
[task 2018-08-29T07:26:38.296Z] 07:26:38     INFO - >       input_el = session.find.css("#keys", all=False)
[task 2018-08-29T07:26:38.296Z] 07:26:38     INFO - 
[task 2018-08-29T07:26:38.296Z] 07:26:38     INFO - request    = <SubRequest 'key_reporter' for <Function 'test_webdriver_special_key_sends_keydown[NUMPAD0-expected26]'>>
[task 2018-08-29T07:26:38.296Z] 07:26:38     INFO - session    = <Session 3630bc19-920d-4d93-bbc6-8b68825088c4>
[task 2018-08-29T07:26:38.296Z] 07:26:38     INFO - test_actions_page = None
[task 2018-08-29T07:26:38.297Z] 07:26:38     INFO - 
[task 2018-08-29T07:26:38.297Z] 07:26:38     INFO - tests/web-platform/tests/webdriver/tests/actions/conftest.py:27: 
[task 2018-08-29T07:26:38.297Z] 07:26:38     INFO - _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
[task 2018-08-29T07:26:38.297Z] 07:26:38     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:20: in inner
[task 2018-08-29T07:26:38.297Z] 07:26:38     INFO -     return func(self, *args, **kwargs)
[task 2018-08-29T07:26:38.297Z] 07:26:38     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:312: in css
[task 2018-08-29T07:26:38.297Z] 07:26:38     INFO -     return self._find_element("css selector", selector, all)
[task 2018-08-29T07:26:38.297Z] 07:26:38     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:318: in _find_element
[task 2018-08-29T07:26:38.297Z] 07:26:38     INFO -     return self.session.send_session_command("POST", route, body)
[task 2018-08-29T07:26:38.297Z] 07:26:38     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:509: in send_session_command
[task 2018-08-29T07:26:38.298Z] 07:26:38     INFO -     return self.send_command(method, url, body)
[task 2018-08-29T07:26:38.298Z] 07:26:38     INFO - _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
[task 2018-08-29T07:26:38.298Z] 07:26:38     INFO - 
[task 2018-08-29T07:26:38.298Z] 07:26:38     INFO - self = <Session 3630bc19-920d-4d93-bbc6-8b68825088c4>, method = 'POST'
[task 2018-08-29T07:26:38.298Z] 07:26:38     INFO - url = 'session/3630bc19-920d-4d93-bbc6-8b68825088c4/element'
[task 2018-08-29T07:26:38.298Z] 07:26:38     INFO - body = {'using': 'css selector', 'value': '#keys'}
[task 2018-08-29T07:26:38.298Z] 07:26:38     INFO - 
[task 2018-08-29T07:26:38.298Z] 07:26:38     INFO -     def send_command(self, method, url, body=None):
[task 2018-08-29T07:26:38.298Z] 07:26:38     INFO -         """
[task 2018-08-29T07:26:38.299Z] 07:26:38     INFO -             Send a command to the remote end and validate its success.
[task 2018-08-29T07:26:38.299Z] 07:26:38     INFO -     
[task 2018-08-29T07:26:38.299Z] 07:26:38     INFO -             :param method: HTTP method to use in request.
[task 2018-08-29T07:26:38.299Z] 07:26:38     INFO -             :param uri: "Command part" of the HTTP request URL,
[task 2018-08-29T07:26:38.299Z] 07:26:38     INFO -                 e.g. `window/rect`.
[task 2018-08-29T07:26:38.299Z] 07:26:38     INFO -             :param body: Optional body of the HTTP request.
[task 2018-08-29T07:26:38.299Z] 07:26:38     INFO -     
[task 2018-08-29T07:26:38.299Z] 07:26:38     INFO -             :return: `None` if the HTTP response body was empty, otherwise
[task 2018-08-29T07:26:38.299Z] 07:26:38     INFO -                 the `value` field returned after parsing the response
[task 2018-08-29T07:26:38.300Z] 07:26:38     INFO -                 body as JSON.
[task 2018-08-29T07:26:38.300Z] 07:26:38     INFO -     
[task 2018-08-29T07:26:38.300Z] 07:26:38     INFO -             :raises error.WebDriverException: If the remote end returns
[task 2018-08-29T07:26:38.300Z] 07:26:38     INFO -                 an error.
[task 2018-08-29T07:26:38.300Z] 07:26:38     INFO -             :raises ValueError: If the response body does not contain a
[task 2018-08-29T07:26:38.300Z] 07:26:38     INFO -                 `value` key.
[task 2018-08-29T07:26:38.300Z] 07:26:38     INFO -             """
[task 2018-08-29T07:26:38.300Z] 07:26:38     INFO -         response = self.transport.send(
[task 2018-08-29T07:26:38.300Z] 07:26:38     INFO -             method, url, body,
[task 2018-08-29T07:26:38.301Z] 07:26:38     INFO -             encoder=protocol.Encoder, decoder=protocol.Decoder,
[task 2018-08-29T07:26:38.301Z] 07:26:38     INFO -             session=self)
[task 2018-08-29T07:26:38.301Z] 07:26:38     INFO -     
[task 2018-08-29T07:26:38.301Z] 07:26:38     INFO -         if response.status != 200:
[task 2018-08-29T07:26:38.301Z] 07:26:38     INFO -             err = error.from_response(response)
[task 2018-08-29T07:26:38.301Z] 07:26:38     INFO -     
[task 2018-08-29T07:26:38.301Z] 07:26:38     INFO -             if isinstance(err, error.InvalidSessionIdException):
[task 2018-08-29T07:26:38.301Z] 07:26:38     INFO -                 # The driver could have already been deleted the session.
[task 2018-08-29T07:26:38.301Z] 07:26:38     INFO -                 self.session_id = None
[task 2018-08-29T07:26:38.302Z] 07:26:38     INFO -     
[task 2018-08-29T07:26:38.302Z] 07:26:38     INFO - >           raise err
[task 2018-08-29T07:26:38.302Z] 07:26:38     INFO - E           UnknownErrorException: unknown error (500): Failed to convert data to an object
[task 2018-08-29T07:26:38.302Z] 07:26:38     INFO - 
[task 2018-08-29T07:26:38.302Z] 07:26:38     INFO - body       = {'using': 'css selector', 'value': '#keys'}
[task 2018-08-29T07:26:38.302Z] 07:26:38     INFO - err        = <UnknownErrorException http_status=500>
[task 2018-08-29T07:26:38.302Z] 07:26:38     INFO - method     = 'POST'
[task 2018-08-29T07:26:38.302Z] 07:26:38     INFO - response   = <Response status=500 error=<UnknownErrorException http_status=500>>
[task 2018-08-29T07:26:38.302Z] 07:26:38     INFO - self       = <Session 3630bc19-920d-4d93-bbc6-8b68825088c4>
[task 2018-08-29T07:26:38.303Z] 07:26:38     INFO - url        = 'session/3630bc19-920d-4d93-bbc6-8b68825088c4/element'
[task 2018-08-29T07:26:38.303Z] 07:26:38     INFO - 
[task 2018-08-29T07:26:38.303Z] 07:26:38     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:473: UnknownErrorException
[task 2018-08-29T07:26:38.303Z] 07:26:38     INFO - 
[task 2018-08-29T07:26:38.303Z] 07:26:38     INFO - TEST-UNEXPECTED-ERROR | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[NUMPAD0-expected26] - teardown error
[task 2018-08-29T07:26:38.303Z] 07:26:38     INFO - self = <webdriver.client.Actions object at 0x7fc8ac6691d0>, args = ()
[task 2018-08-29T07:26:38.303Z] 07:26:38     INFO - kwargs = {}, session = <Session 470a5093-96b1-4c91-9038-de1591a99a1f>
[task 2018-08-29T07:26:38.305Z] 07:26:38     INFO - 
[task 2018-08-29T07:26:38.305Z] 07:26:38     INFO -     def inner(self, *args, **kwargs):
[task 2018-08-29T07:26:38.305Z] 07:26:38     INFO -         if hasattr(self, "session"):
[task 2018-08-29T07:26:38.305Z] 07:26:38     INFO -             session = self.session
[task 2018-08-29T07:26:38.305Z] 07:26:38     INFO -         else:
[task 2018-08-29T07:26:38.305Z] 07:26:38     INFO -             session = self
[task 2018-08-29T07:26:38.305Z] 07:26:38     INFO -     
[task 2018-08-29T07:26:38.309Z] 07:26:38     INFO -         if session.session_id is None:
[task 2018-08-29T07:26:38.309Z] 07:26:38     INFO -             session.start()
[task 2018-08-29T07:26:38.309Z] 07:26:38     INFO -     
[task 2018-08-29T07:26:38.309Z] 07:26:38     INFO - >       return func(self, *args, **kwargs)
Content process crash. Most likely caused by bug 1482029.
Depends on: 1482029
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1482550
You need to log in before you can comment on or make changes to this bug.