Closed Bug 1487045 Opened 3 years ago Closed 3 years ago

Facebook Login/Account registration is not working on www.meliuz.com.br while Tracking Protection Basic is enabled

Categories

(Web Compatibility :: Desktop, defect, P3)

Firefox 62
x86_64
Windows 10
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1226498

People

(Reporter: oanaarbuzov, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [webcompat][tp-social])

User Story

facebook.com

Attachments

(2 files)

Attached image Screenshot_2.png
[Environment:]
Browser / Version: Firefox Nightly 63.0a1 (2018-08-27)
Operating System: Windows 10 Pro

[Prerequisites:]
    1. Tracking Protection Basic enabled.
[Steps to Reproduce:]
    1. Navigate to https://www.meliuz.com.br/desconto/americanas 
    2. Click “Cadastre-se” button.
    3. Click “Preencha com Facebook” button.
    4. Observe behavior.
        
[Expected Behavior:]
Redirect to Facebook is performed and account creation can be made.
 
[Actual Behavior:]
Nothing happens. Redirect to Facebook is not performed.

[Notes:]
Also reproducible for login.
The issue is related to `Login` breakage.

Looking at the devtools console, here are the blocked resources:
The resource at “https://www.googletagservices.com/tag/js/gpt.js” was blocked because content blocking is enabled.
The resource at “https://www.googletagmanager.com/gtm.js?id=GTM-K73BGL” was blocked because content blocking is enabled.
The resource at “https://connect.facebook.net/pt_BR/sdk.js” was blocked because content blocking is enabled.

So below are the domains to test:
- www.googletagservices.com
- googletagmanager.com
- connect.facebook.net

I opened the URL in a fresh browser profile (Firefox Nightly 63, uMatrix installed, normal mode) and loaded the page. Clicked the "Cadastre-se” button and nothing happened.

I disabled the Spoof Referrer option in uMatrix and then WHITELISTED:
- reddit.com (including all related domains)
and the images in the slideshow ware not shown.

Since there was an error related to Ajax ("Failed ajax, Firefox try to disable tracking protection from the shield in the URL bar") I whitelisted:
- staticz.com.br
and the "Registration" popup is displayed, but the “Preencha com Facebook” button is not functional.

I than whitelisted:
- facebook.com (including all related domains)
- facebook.net (including all related domains)
and the redirect to Facebook page was performed in a popup.

The Facebook popup is without access to the toolbar (and uMatrix). So I went to about:config and set dom.disable_window_open_feature.toolbar to true. 
I closed the popup window, refreshed the "Registration" page and clicked again the “Cadastre-se” button and “Preencha com Facebook” button. Redirect to Facebook was performed and I was able to login to Facebook and after that create an account on the www.meliuz.com.br site.

So in conclusion:
- facebook.com is in Disconnect list = [tp-social]
Added uMatrix results.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1226498
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.