Closed Bug 1487049 Opened 3 years ago Closed 3 years ago

Update opus to revision v1.3-rc-15-g38fca4a2

Categories

(Core :: Audio/Video: Playback, enhancement, P2)

63 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox63 --- wontfix
firefox64 --- fixed

People

(Reporter: dminor, Assigned: dminor)

References

Details

Attachments

(3 files, 1 obsolete file)

The latest tag is v1.3-rc.

Jean-Marc, do you recommend using the release candidate, current master, or waiting for the v1.3 release? If the latter, do you have a timeline for that release? Thanks!
Flags: needinfo?(jmvalin)
I think the latest master (38fca4a203a6759f2c90b86c84c4db087982ca81) is probably best here. I'm about to release it as 1.3-rc2, and hopefully 1.3-final soon after.
Flags: needinfo?(jmvalin)
Thanks! I'll plan on updating to 1.3-rc2.
Rank: 15
Summary: Update opus to the 1.3 release → Update opus to 1.3-rc2
Status: NEW → ASSIGNED
Hi Jean-Marc, I was planning to ask you for review on this but you don't have a Phabricator account. I was wondering if you could create an account or let me know if there is someone else who would be a suitable reviewer? Thank you!
Flags: needinfo?(jmvalin)
See comment in Phabricator.
Flags: needinfo?(jmvalin)
Comment on attachment 9006233 [details]
Bug 1487049 - Set ENABLE_HARDENING for libopus; r=jmvalin

Jean-Marc Valin (:jmspeex) has approved the revision.
Attachment #9006233 - Flags: review+
I discussed this with drno and we're going to take v1.3-rc-15-g38fca4a2 rather than wait for a 1.3 release or the next release candidate.
Summary: Update opus to 1.3-rc2 → Update opus to revision v1.3-rc-15-g38fca4a2
OK, sounds reasonable and I'm fairly confident of that commit.
Attachment #9006233 - Attachment description: Bug 1487049 - Set ENABLE_HARDENING for libpus; r=jmvalin → Bug 1487049 - Set ENABLE_HARDENING for libopus; r=jmvalin
Comment on attachment 9005490 [details]
Bug 1487049 - Update libopus non-unified build files; r=jmspeex

Jean-Marc Valin (:jmspeex) has approved the revision.
Attachment #9005490 - Flags: review+
Comment on attachment 9005489 [details]
Bug 1487049 - Update libopus to 1.3-rc2; r=jmspeex

Jean-Marc Valin (:jmspeex) has approved the revision.
Attachment #9005489 - Flags: review+
Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5f2915028e3f
Update libopus to v1.3-rc-19-g5cbd7d5f; r=jmspeex
https://hg.mozilla.org/integration/mozilla-inbound/rev/87c44124c772
Update libopus non-unified build files; r=jmspeex
https://hg.mozilla.org/integration/mozilla-inbound/rev/309d6b502c71
Set ENABLE_HARDENING for libopus; r=jmspeex
https://hg.mozilla.org/mozilla-central/rev/5f2915028e3f
https://hg.mozilla.org/mozilla-central/rev/87c44124c772
https://hg.mozilla.org/mozilla-central/rev/309d6b502c71
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Attachment #9005488 - Attachment is obsolete: true
Duplicate of this bug: 1500217
You need to log in before you can comment on or make changes to this bug.