Closed Bug 1487292 Opened 4 years ago Closed 3 years ago

position should not accept 3 values

Categories

(Core :: CSS Parsing and Computation, defect, P3)

Unspecified
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1559276
Tracking Status
firefox61 --- affected
firefox62 --- affected
firefox63 --- affected

People

(Reporter: ericwilligers, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36

Steps to reproduce:

https://wpt.fyi/results/css/css-images/parsing/object-position-invalid.html
https://wpt.fyi/results/css/css-transforms/parsing/perspective-origin-parsing-invalid.html
https://wpt.fyi/results/css/css-images/parsing/gradient-position-invalid.html



Actual results:

Tests fail by accepting 3 values as <position>


Expected results:

Tests should pass by not accepting 3 values as <position>

https://drafts.csswg.org/css-values-4/#typedef-position
Discussed in https://github.com/w3c/csswg-drafts/issues/2140

Note background-position is excluded.
I managed to reproduce the issue on Windows 10, Ubuntu 16.04 and Mac OS, on Nightly 63.0a1 (2018-09-03), FF 61.0.2 and FF 62.0.

I am not entirely sure that this is the right component. Please feel free to change it if you find a better fitting one.
Status: UNCONFIRMED → NEW
Component: Untriaged → CSS Parsing and Computation
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Core
Version: unspecified → Trunk
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1559276
You need to log in before you can comment on or make changes to this bug.