pr/tests/abstract.c:(.text+0xe): undefined reference to `prinf'

RESOLVED FIXED in 4.21

Status

defect
RESOLVED FIXED
9 months ago
3 months ago

People

(Reporter: jbeich, Assigned: jbeich)

Tracking

({regression})

4.20
4.21
Unspecified
FreeBSD
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

541 bytes, patch
glandium
: review+
Details | Diff | Splinter Review
Assignee

Description

9 months ago
$ ./configure
$ gmake
$ gmake -C pr/tests
[...]
cc  abstract.o -pthread -Xlinker -R pr/tests/../../dist/lib -L../../dist/lib -lplc4 -L../../dist/lib -lnspr4  -o abstract
ld: error: undefined symbol: prinf
>>> referenced by abstract.c
>>>               abstract.o:(main)
cc: error: linker command failed with exit code 1 (use -v to see invocation)

build log: https://ptpb.pw/62Id
Assignee

Comment 1

9 months ago
Posted patch Typo (obsolete) — Splinter Review
Sorry, no Try link as I don't know how to test on automation.
Attachment #9005528 - Flags: review?(mh+mozilla)
Assignee

Comment 2

9 months ago
Posted patch TypoSplinter Review
Attachment #9005528 - Attachment is obsolete: true
Attachment #9005528 - Flags: review?(mh+mozilla)
Attachment #9005529 - Flags: review?(mh+mozilla)
Attachment #9005529 - Flags: review?(mh+mozilla) → review+
Kai, do you mind landing this?
Flags: needinfo?(kaie)
Thanks for the patch. I'll land tomorrow. This is the first change since 4.20 so it may take a while until we release. Keeping needinfo until I land.
Checked in.
https://hg.mozilla.org/projects/nspr/rev/90d2902aab61

Although the issue is a build regression, it's very small and can probably be easily patched by distributors. I suggest we don't do a patch release.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(kaie)
Resolution: --- → FIXED
Target Milestone: --- → 4.21
Assignee: nobody → jbeich

Updated

3 months ago
Blocks: 1526010
You need to log in before you can comment on or make changes to this bug.