Closed Bug 1487632 Opened Last year Closed Last year

AltGr+Enter does not open URL in new tab

Categories

(Firefox :: Address Bar, defect, P3)

63 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1389739
Tracking Status
firefox63 --- wontfix
firefox64 --- fix-optional

People

(Reporter: ezh, Unassigned)

References

Details

(Keywords: regression)

Updated to FF63 beta 1. 

In Estonian and Russian keyboard layout AltGr+Enter does not open a URL in a new tab anymore.

This is a one more regression, as bug 1389739 is.
It is a dataloss bug, since AltGr does open in the same tab. 
My example: 
1. edited an Adwords campaign
2. needed to open a new site
3. put it in URL bar
4. pressed AltGr+Enter to open it in a new tab

Acrual result: the URL was opened in same tab, where I had unfinished work.

Extected result: URL is opened in a new tab, unsaved work remain in a other tab.
In US English layout no problem. It seems only languages that uses AltGr for other symbols are affected.
Priority: -- → P3
See Also: → 1389739
This is not exactly a regression, the meaning of the AltGr button was recently changed in the platform code, and we must fix the frontend code to cope with it by handling AltGraph as Alt.

I fail to see how this differs from bug 1389739, why is it not just a duplicate? The underlying cause is exactly the same.
bug 1389739 is 1 year old (with no hope to fix) and this one is from version 63.
(In reply to Eugene Savitsky from comment #4)
> bug 1389739 is 1 year old (with no hope to fix)

It doesn't really matter, we have far older bugs, and there's hope to fix, indeed I suggested a fix multiple times there, someone should just try and make a patch with a testcase.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1389739
You need to log in before you can comment on or make changes to this bug.