Closed Bug 1487761 Opened 1 year ago Closed 1 month ago

Display try push message in PerfHerder

Categories

(Tree Management :: Perfherder, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: nchevobbe, Unassigned, Mentored)

References

Details

(Keywords: good-first-bug, Whiteboard: [lang=js])

Attachments

(1 file)

When dealing with multiple running TRY pushes, and thus multiple Perherder tabs, it can be a bit cumbersome to find the exact comparison you're looking for.

It would be nice if we could surface the try push message (provided with -m when doing `mach try`) in the UI.

It could be as a title of the revision numbers so we can get it by hovering it, or by displaying it directly near the revision number (see mockup in attachment).
Duplicate of this bug: 1489610
Blocks: 1520720
Keywords: good-first-bug
Priority: -- → P3
Mentor: igoldan
Whiteboard: [lang=js]

Hello Ionuț, I may have some time to look into this.
Would you have any pointer to start this?

I know that Perfherder's UI is fetching that message from the backend.
We need to tweak the RevisionInformation React component and its ListGroupItem children.

Firstly, RevisionInformation needs to be provided with the revision range push information, which includes the comment we need.
Then we need to share that down with the ListGroupItem and display the comment.

That component has been used in 2 places:

The Compare views seems to be used in conjunction (here) with the Validation component, which fetches the data we need.

No longer blocks: 1520720

Nicolas, thank you so much for helping us with this ticket!

Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.