Web Assistant - notification system of site content update

RESOLVED WONTFIX

Status

SeaMonkey
General
--
enhancement
RESOLVED WONTFIX
16 years ago
12 years ago

People

(Reporter: Mehmet D. AKIN, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

182.29 KB, application/pdf
Details
(Reporter)

Description

16 years ago
Adding functionality of a Web Assistant to Mozilla is a wonderful extra. Details
are in attachment (pdf, 7 pages).
(Reporter)

Comment 1

16 years ago
Created attachment 86043 [details]
Web Assistant details

Here is the details. Drop me an email if you wabt to discuss anything about it.
(Reporter)

Comment 2

16 years ago
Created attachment 86045 [details]
Web Assistant Details (pdf)

sorry, this is the correct one

Updated

16 years ago
Attachment #86043 - Attachment is obsolete: true

Comment 3

16 years ago
Can we have a brief summary of what this is about (as a comment, not as PDF),
please?
-> I can't fix this one
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
.
Assignee: Matti → nobody
(Reporter)

Comment 6

16 years ago
Actually the first part of the document is like a brief, you can start from there.
But I see, this is already assigned to "nobody". well, it is still a good idea
anyway, if you read and think about it.

Comment 7

16 years ago
What exactly are you proposing be added to Mozilla? Bookmarks already have the
capability to check for updates at some schedule. See the Schedule tab in a
bookmarks' properties.
(Reporter)

Comment 8

16 years ago
Well, did you read the document?
Yes, bookmarks can tell whether "a site is updated or not" But what I propose is
a mechanism not only checks a site for updates, but also retrieve the updated
content itself! and also gives user to define content based alerts. This is far
beyond the bookmarks update checking features. It checks for sites for you
without visiting it, if something new, or something of your interest (using
alerts) it retrieves some portion of the content and link to site, and gives you
full control, you dont continuously check the site, therefore not loose time, or
you dont miss something of your interest just because you didnt visited the site
in the right time, it browses sites for you in the background, analyses them and
gives the results to you.

Comment 9

16 years ago
Neil, bookmarks alone can not tell when a specific part of a page has updated. 
Consider the case of cnn.com.  It is continually updated.  If you just rely on
http to tell if the page has been modified, the notification will be meaningless.  

Comment 10

15 years ago
see bug 8648
Summary: Implement a Web Assistant for Mozilla → Web Assistant - notification system of site content update

Comment 11

14 years ago
(In reply to comment #9)
> Neil, bookmarks alone can not tell when a specific part of a page has updated. 
> Consider the case of cnn.com.  It is continually updated.  If you just rely on
> http to tell if the page has been modified, the notification will be
meaningless.  

Right. How about integration of update notifications with RSS-feeds? Assign the
bookmark URL a RSS-feed and there you go. One could then choose the action that
will happen when clicking on the bookmark button: either go to the URL or
subsequently go to the new links provided be the RSS-feed. Neat, not?

Comment 12

14 years ago
(In reply to comment #11)

Additionally, the context menu of that bookmark could open an internally
generated web page displaying the new headlines of the RSS-feed.

Comment 13

14 years ago
(In reply to comment #12)

Or a RSS-feed could be represented as a special implementation of a bookmarks
folder with dynamic content consisting of Headlines as bookmark names and
Tooltips containing the short descriptions... one could skip through news just
by moving the mouse pointer over the RSS-feed bookmark folder :)
Product: Browser → Seamonkey
(Reporter)

Comment 14

12 years ago
currently not suitable I guess.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.