sketchfab.com model textures are corrupted, webgl bug?

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
8 months ago
7 months ago

People

(Reporter: w0wkin, Unassigned)

Tracking

62 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 months ago
Posted image FF_broken.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180830143136

Steps to reproduce:

Download and install 62 version of firefox 64-bit
Visit sketchfab.com


Actual results:

 Preview is OK, but when you open model, textures are messed and broken. 


Expected results:

Expected to work as intended (like other browsers do, 61.0.2 is OK also)

Comment 1

8 months ago
Hi, I managed to reproduce this issue in Firefox Beta ID 20180830143136 but I can no longer reproduce this issue in Firefox Nightly 64.0a1 (2018-09-04).

Can you please try to reproduce this issue using the latest version of Firefox Nightly you can find it here: https://nightly.mozilla.org/
Flags: needinfo?(w0wkin)
(Reporter)

Comment 2

8 months ago
I can not reproduce this issue in Firefox Nightly 64.0a1 (2018-09-04), it looks absolutely OK.
Flags: needinfo?(w0wkin)

Comment 3

8 months ago
Here, I only managed to reproduce on https://www.jersied.com/design on firefox stable ()
Nightly (64.0a1) doesn't have the bug.

tested on win10, on a nvidia gpu, and on a intel gpu)

Telated thread on sketchfab forum 
https://forum.sketchfab.com/t/latest-firefox-quantum-version-62-0-64-bit-break-all-model/23213/8
(User having an AMD radeon GPU has the bug on all models it seems, much more than nvidia/intel GPU)

FYI just an indication looks like a bug Angle based webgl browsers had a long time ago related to the "restart" in triangle strip primitives

Comment 4

8 months ago
We are having similar issues with WebGL based games on FF 62: WebGL rendering is messed up just like on the sketchfab screenshot above.
The issue is gone on 63.0b4 (64-bit)
Can you please release a patch to the stable version, users are not happy.
(Reporter)

Comment 5

8 months ago
63.0b4 is OK for me also.

Comment 6

8 months ago
I confirm the bug on my browser. Actually came here to report it myself and found this.

Model (not just this but all models on sketchfab): https://sketchfab.com/models/239bb046857d4912b996a2789b4934ab

On firefox: https://i.gyazo.com/43b5b5cf29139cc05594fefa326a1fa4.jpg

On Egde: https://i.gyazo.com/4e2d018130e64770e70b540cefdb00d9.jpg

I think it could be an issue with Firefox's WebGL plugin? I'm not sure.

Comment 7

8 months ago
We fixed it on sketchfab, we confirm it's related to triangle strip, directx and the primitive restart

To repro the bug on sketchfab you need to add ?force_triangles=false to any sketchfab url model

Comment 8

7 months ago
(sketchfab dev)

The flag should be ?force_triangles=0, however I went too fast and the flag isn't respected at the moment. (see https://bugzilla.mozilla.org/show_bug.cgi?id=1489099#c10)

Comment 9

7 months ago
Duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1489099
( better follow the other one )

Comment 10

7 months ago
Hi, Since this issue cannot be reproduced anymore and there is already a different defect logged for the second issue, I will mark this as Resolved - WorksForMe
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.