If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mail and news crash when attempting to access ldap data

VERIFIED WORKSFORME

Status

MailNews Core
LDAP Integration
--
critical
VERIFIED WORKSFORME
16 years ago
9 years ago

People

(Reporter: peter.van.der.zanden, Assigned: Srilatha Moturi)

Tracking

({crash})

Trunk
Sun
Solaris
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0rc3) Gecko/20020524
BuildID:    2002052414

Mail and/or news crashes when the application attempts to verify the addresse
with an LDAP server. When crashing, no message is generated (not even a 'signal
11' message). When 'Address autocompletion' is enabled, Mozilla crashes after
the 1st character of a mail address is entered. If this feature is disabled,
Mozilla crashes after pressing the 'send' button.

Reproducible: Always
Steps to Reproduce:
1.Have Mozilla use an LDAP server and enable 'Address autocompletion in the
preferences
2.Compose a news or mail message (e.g. click 'Send Link' in the file menu)
3.Enter an e-mail address for a recipient.

Alternate reproduction steps:
1. Have Mozilla use an LDAP server
2. Compose an e-mail
3. Enter the address of the recipient
4. click 'Send'

Actual Results:  Mozilla crashes: All windows disappear and no Mozilla processes
are running anymore.

Expected Results:  Upon completion of the e-mail address one can send the mail
message or post the news article.

Alternate expected result (from alternate reproduction steps):
Upon pressing the 'Send' button, the mail message is sent, closing the Compose
window.

This bug reproduces 100% on Solaris 8 SU 7 without additional patches.

Updated

16 years ago
Keywords: crash
(Reporter)

Comment 1

16 years ago
I have discovered that the bug is also related to imported Netscape 4.7x settings.
If I create an account based on my Netscape 4.7 settings, the mailer crashes as
described. If I do not use the Netscape settings, the mailer does not crash.
does this still happen with 1.1beta?

Comment 3

15 years ago
20020910 trunk build on Win2k

The problem cannot be reproduced.

Comment 4

15 years ago
Reporter,
Please reopen it if you hit the problem again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 5

15 years ago
20020912 trunk build on Win2K.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.