Closed Bug 1487963 Opened 3 years ago Closed 3 years ago

PannerNode should throw when parameters are out of range

Categories

(Core :: Web Audio, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: manishearth, Assigned: manishearth)

References

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

refDistance, maxDistance, rolloffFactor, and coneOuterGain all have limits on their values. The spec asks us to throw errors when the values are out of the limits.

https://webaudio.github.io/web-audio-api/#dom-pannernode-refdistance
I have patches for this, just need to figure out arcanist.

One issue I'm getting is that testing/web-platform/tests/webaudio/the-audio-api/the-pannernode-interface/panner-distance-clamping.html is failing with

`FAIL X panner.maxDistance = -1 threw "RangeError" instead of EcmaScript error RangeError. - assert_true: expected true got false`

Not sure what's going on there, is this a bug with the test?
I'll also need to include https://github.com/servo/servo/pull/21555/commits/e1131b474c7d162ec791c10f0bc21ecca56100d7 to make this work, not sure if I should just wait for the sync to happen or copy over the test.
Comment on attachment 9005788 [details]
Bug 1487963 - Throw when setting PannerNode parameters out of limits; r?padenot

Andrea Marchesini [:baku] has approved the revision.
Attachment #9005788 - Flags: review+
Comment on attachment 9005788 [details]
Bug 1487963 - Throw when setting PannerNode parameters out of limits; r?padenot

Paul Adenot (:padenot) has approved the revision.
Attachment #9005788 - Flags: review+
Rank: 19
Priority: -- → P2
Pushed by manishearth@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/da0384fb1fbb
Throw when setting PannerNode parameters out of limits; r=padenot,baku
https://hg.mozilla.org/mozilla-central/rev/da0384fb1fbb
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
cover the exceptions and in range values in our docs.
Keywords: dev-doc-needed
looks good
Flags: needinfo?(manishearth)
Duplicate of this bug: 1435893
You need to log in before you can comment on or make changes to this bug.