Closed Bug 1488021 Opened 4 years ago Closed 4 years ago

Intermittent devtools/client/debugger/test/mochitest/browser_dbg_sources-iframe-reload.js | A promise chain failed to handle a rejection: No such actor for ID: server1.conn0.child1/source28

Categories

(DevTools :: Debugger, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1455225

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure)

Filed by: shindli [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=197057453&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/E5aioY_EQhiWMWtAD4KvmA/runs/0/artifacts/public/logs/live_backing.log

12:19:32     INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/test/mochitest/browser_dbg_sources-iframe-reload.js | A promise chain failed to handle a rejection: No such actor for ID: server1.conn0.child1/source28 - stack: promiseMiddleware/</</</</<@resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/redux/middleware/promise.js:45:11
12:19:32     INFO - DevToolsUtils.executeSoon*exports.executeSoon@resource://devtools/shared/base-loader.js -> resource://devtools/shared/DevToolsUtils.js:57:21
12:19:32     INFO - promiseMiddleware/</</</<@resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/redux/middleware/promise.js:40:9
12:19:32     INFO - process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:931:21
12:19:32     INFO - walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:812:29
12:19:32     INFO - Promise*scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:745:11
12:19:32     INFO - schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:776:7
12:19:32     INFO - completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:713:7
12:19:32     INFO - _handleException@resource://devtools/shared/base-loader.js -> resource://devtools/shared/task.js:441:5
12:19:32     INFO - _run@resource://devtools/shared/base-loader.js -> resource://devtools/shared/task.js:322:11
12:19:32     INFO - reject@resource://devtools/shared/base-loader.js -> resource://devtools/shared/deprecated-sync-thenables.js:46:41
12:19:32     INFO - then@resource://devtools/shared/base-loader.js -> resource://devtools/shared/deprecated-sync-thenables.js:22:51
12:19:32     INFO - resolve@resource://devtools/shared/base-loader.js -> resource://devtools/shared/deprecated-sync-thenables.js:73:11
12:19:32     INFO - reject@resource://devtools/shared/base-loader.js -> resource://devtools/shared/deprecated-sync-thenables.js:47:16
12:19:32     INFO - then@resource://devtools/shared/base-loader.js -> resource://devtools/shared/deprecated-sync-thenables.js:22:51
12:19:32     INFO - resolve@resource://devtools/shared/base-loader.js -> resource://devtools/shared/deprecated-sync-thenables.js:73:11
12:19:32     INFO - reject@resource://devtools/shared/base-loader.js -> resource://devtools/shared/deprecated-sync-thenables.js:79:7
12:19:32     INFO - listenerJson@resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/debugger-client.js:555:9
12:19:32     INFO - emit@resource://devtools/shared/base-loader.js -> resource://devtools/shared/event-emitter.js:178:15
12:19:32     INFO - emit@resource://devtools/shared/base-loader.js -> resource://devtools/shared/event-emitter.js:255:5
12:19:32     INFO - emitReply@resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/debugger-client.js:838:31
12:19:32     INFO - DevTools RDP*request@resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/debugger-client.js:547:21
12:19:32     INFO - source@resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/source-client.js:105:12
12:19:32     INFO - loadSourceText/</<@resource://devtools/shared/base-loader.js -> resource://devtools/client/debugger/content/actions/sources.js:189:32
12:19:32     INFO - _run@resource://devtools/shared/base-loader.js -> resource://devtools/shared/task.js:310:41
12:19:32     INFO - Rejection date: Sat Sep 01 2018 12:19:30 GMT-0700 (Pacific Daylight Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
12:19:32     INFO - Stack trace:
12:19:32     INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
12:19:32     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1127
12:19:32     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1093
12:19:32     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:995
12:19:32     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
12:19:32     INFO - Leaving test bound
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1455225
You need to log in before you can comment on or make changes to this bug.