Closed Bug 1488033 Opened Last year Closed Last year

Contents of "about:preferences#privacy" are overflowed and buttons are not visible at first sight when window size is small.

Categories

(Firefox :: Preferences, defect, P1)

63 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- verified

People

(Reporter: suishouen, Assigned: ehsan)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180901220104

Steps to reproduce:

1. Set browser window size to small (e.g. 1000px)
2. Open about:preferences#privacy


Actual results:

Contents are overflowed and buttons (e.g. "Restore Defaults", "Exceptions…") are not visible at first sight.


Expected results:

Contents shhoud not be overflowed and shoud be visible at first sight as other parts of preferences.
regressed by: Bug 1480900
Attached image Screenshot
Attaching screenshot.
Blocks: 1480900
Has STR: --- → yes
Component: Untriaged → Preferences
Flags: needinfo?(ehsan)
Keywords: regression
I don't know why, but clicking "Restore Defaults" button of "Content Blocking" section fixes the issue.
Setting "Block cookies and site data" to "All cookies (will cause website to break)" causes the issue again.
OK, after a lot of trial and error, I finally figured out what causes this weirdness.

Normally I would have expected that adding a flex="1" here <https://searchfox.org/mozilla-central/rev/721842eed881c7fcdccb9ec0fe79e4e6d4e46604/browser/components/preferences/in-content/privacy.xul#396> and a pack="end" here <https://searchfox.org/mozilla-central/rev/721842eed881c7fcdccb9ec0fe79e4e6d4e46604/browser/components/preferences/in-content/privacy.xul#416> should have fixed this issue, but it turns out that only works if the <description> elements on lines 406 and 411 are *not* wrapped in warningAllCookiesBlocked and warningFromVisitedCookiesBlocked hbox'es.  The existence of those hbox'es seems to be the root cause of all of the weirdness I have been seeing with the XUL layout here.
Assignee: nobody → ehsan
Flags: needinfo?(ehsan)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P1
Comment on attachment 9005924 [details]
Bug 1488033 - Fix the layout of the Preferences window when one of the advanced cookie blocking options under Cookies and Site Data section are selected; r=johannh

Johann Hofmann [:johannh] has approved the revision.
Attachment #9005924 - Flags: review+
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3d8df5a41dc5
Fix the layout of the Preferences window when one of the advanced cookie blocking options under Cookies and Site Data section are selected; r=johannh
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/00859e3fa59a
follow-up: Fix the name of the CSS property
https://hg.mozilla.org/mozilla-central/rev/3d8df5a41dc5
https://hg.mozilla.org/mozilla-central/rev/00859e3fa59a
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
I have reproduced the issue mentioned in Description using an affected Nightly 63.0a1 build from 2018-09-01.

This issue is verified fixed using Firefox 63.0a1 from 2018-09-24 on macOS 10.13.6
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.