Closed Bug 1488070 Opened Last year Closed Last year

No response from general-owner@lists.mozilla.org (mozilla.general)

Categories

(mozilla.org :: Discussion Forums, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: markr-mozilla, Assigned: justdave)

Details

I'm a member of general@lists.mozilla.org/mozilla.general which I receive by email.

I've been receiving direct emails from a (seemingly genuine) company called Avas Flowers (cs@avasflowers.com) who, it would seem, cannot remove themselves from the general@lists.mozilla.org list. I don't know why they decided to email me, other than that they've seen my posts to the list.

I told them how to unsubscribe themselves but they told me that they were unable to do so successfully. I then told them to contact general-owner@lists.mozilla.org but (a) they continue to repeatedly email me, and (b) I've sent messages myself to general-owner and not got a response.

The list/group doesn't need moderating (it works fine as a low level anarchy) but someone does need to be keeping an eye on the general-owner mailbox.


Requests:
(1) Can someone please take action on this particular issue.
(2) Who is supposed to be tending the general-owner mailbox?


And an offer:
If no one is tending the general-owner@lists.mozilla.org mailbox then I volunteer do so. I don't know if you have non-employee volunteers for this sort of thing but I'm willing.
For the avoidance of doubt and confusion, I'm subscribed to general@lists.mozilla.org as mark.rousell@signal100.com.
The fact that it's set to general-owner means it doesn't have one. That's an alias used my mailman to send mail to whoever is listed at the bottom of the info page, and the target of that alias being set to itself means it would be creating a mail loop and should be bouncing if you tried to mail it. Not sure how that ever worked. I'm not the person that can solve this, just making an observation.
That's interesting. Just to confirm, I've never received a bounce from it.

> That's an alias used my mailman to send mail to whoever is listed at the bottom of the info page,
> and the target of that alias being set to itself means it would be creating a mail loop and should
> be bouncing if you tried to mail it.

Hang on, I'm not sure if that's quite right, is it. :-)

It's not uncommon for the list owner address linked on a MM list info page to be of the form <list>-owner@example.org. As you say, it's an alias or distribution list.

For comparison, a specific example I just found is http://lists.dmarc.org/mailman/listinfo/arc-discuss where it shows "arc-discuss list run by smj at dmarc.org" but the actual mailto link target for "smj at dmarc.org" is "arc-discuss-owner@dmarc.org". Many other MM lists are similar.

This is effectively the same as at https://lists.mozilla.org/listinfo/general where the text is "general-owner at lists.mozilla.org" and the mailto target is "general-owner@lists.mozilla.org".

As you say, general-owner@ should be a distribution list or alias but, as such, it's surely correct that it appears on the info page. I.e. People email the general-owner@ list owner distribution list/alias address and it forwards to the personal mailboxes of whoever is on the list owner list, whether that be one person or many.

So surely the fact that it shows general-owner@ there is not a sign that it's forwarding to itself (although I can well believe that the alias has no recipients currently set).
Ah, you're right, Mailman changed it so it just lists the owner alias there now, okay, so you can ignore all I said.  It used to list the addresses of the people that alias actually went to there, even though the mailto links all did {list}-owner.  I just looked at one of the lists I own and it actually says dev-apps-bugzilla-owner instead of my address at the bottom now (it actually used to list my address along with a couple others there).  The admin panel for that list still shows the three of us as owners.
The general list appears to have list-admin@mozilla.org set as the list owner, though, which does indeed mean it has no actual owner.  Ed will have to tell us where that actually points, since that's an actual mail alias on mozilla.org outside of mailman. It used to go to me several years ago, but I haven't been involved in that stuff in a while.
> Ah, you're right, Mailman changed it so it just lists the owner alias there now

Ah I see, okie doke.

> The general list appears to have list-admin@mozilla.org set as the list owner, though, which does indeed
> mean it has no actual owner.

Where do you see that? I don't think I can see it.
In the admin interface for the list. I don't typically use it anymore outside of my own list but I still have access to it.

There is no cs@avasflowers.com subscribed to the list, that's probably why they're having trouble unsubscribing.  They're probably subscribed under a different email address which is forwarded there.  It should say in the email they're getting what address is actually subscribed (they may have to examine the headers to find it).
I sent them an email explaining what I figured out (CCed you).
(In reply to Dave Miller [:justdave] (justdave@bugzilla.org) from comment #7)
> In the admin interface for the list. I don't typically use it anymore
> outside of my own list but I still have access to it.

Ah, understood. I've no access to that of course.

> There is no cs@avasflowers.com subscribed to the list, that's probably why
> they're having trouble unsubscribing.  They're probably subscribed under a
> different email address which is forwarded there.  It should say in the
> email they're getting what address is actually subscribed (they may have to
> examine the headers to find it).

Thank you for that information. It's very helpful.

I had a suspicion that this might be the case, i.e. that they are subscribed under a different address, possibly by someone who is intentionally hoaxing/disrupting them.

The customer service people I've spoken with so far at Avas don't show any signs of being technical (they are florists!) and so I doubt they will be able to figure out how to see the headers. They send and receive everything through a CRM system.

I had considered asking them if I could speak to their IT support people but I was unwilling to do this if I could not do what needed to be done at this end. However, if you are willing and able to remove their subscribed address (if I can find it) then I will ask to speak to their IT people and see if I can obtain sight of a full email header.
(In reply to Dave Miller [:justdave] (justdave@bugzilla.org) from comment #8)
> I sent them an email explaining what I figured out (CCed you).

Wow, thank you! I just got your CC. I'll email you directly with some additional information.

For future reference, their CRM tracking code for this issue is "#M10434786" (to appear in the Subject).
According to https://groups.google.com/d/msg/mozilla.general/dHGkMsXkhq4/f--z0mpBBAAJ it would seem that they are receiving wishlist@lists.mozilla.org too.
If the address <cs@avasflowers.com> is not subscribed to the mailing list does indeed mean messages are being sent with a spoofed E-mail address, then shutting down this spamming requires viewing the header section of such a message.  Use Thunderbird's [View > Message Source], save the entire result -- including the message body -- to a plain-text file, and attach that file to this bug report.  

In the meantime, <cs@avasflowers.com> has the IP address 173.193.217.35.  That is in the range 173.192.0.0-173.193.255.255, which is controlled by SoftLayer Technologies Inc.  That firm's E-mail address for abuse is <abuse@softlayer.com>.  While SoftLayer Technologies allocated the subrange 173.193.217.32-173.193.217.39 (which includes 173.193.217.35) to an individual named Matthhew Neuenhaus, the abuse address remains <abuse@softlayer.com>.
(In reply to David E. Ross from comment #12)
> If the address <cs@avasflowers.com> is not subscribed to the mailing list
> does indeed mean messages are being sent with a spoofed E-mail address, then
> shutting down this spamming requires viewing the header section of such a
> message.  Use Thunderbird's [View > Message Source], save the entire result
> -- including the message body -- to a plain-text file, and attach that file
> to this bug report.

There's no point saying that here. Avas Flowers are not present here so no one here can *directly* see the emails they are receiving.

Dave Miller has very kindly contacted them and asked them to send an email header (and he has the privs to remove whatever address(es) it turns out they are subscribed with). Hopefully he will be able to sort them out.

We'll see if they can work out how to get an email header out of their CRM system.

> In the meantime, <cs@avasflowers.com> has the IP address 173.193.217.35. 
> That is in the range 173.192.0.0-173.193.255.255, which is controlled by
> SoftLayer Technologies Inc.  That firm's E-mail address for abuse is
> <abuse@softlayer.com>.  While SoftLayer Technologies allocated the subrange
> 173.193.217.32-173.193.217.39 (which includes 173.193.217.35) to an
> individual named Matthhew Neuenhaus, the abuse address remains
> <abuse@softlayer.com>.

As I said to you in mozilla.general ( https://groups.google.com/d/msg/mozilla.general/dHGkMsXkhq4/R5Huu_U4BAAJ ), Avas Flowers are not spamming (or committing any other kind of abuse). It is possible that they may be the victims of abuse but there is no reason whatsoever to report them to their hosting provider. It won't help.
Looks like the problem is still ongoing. Just got another email from Avas Flowers.

Here it is for reference.

-------- Forwarded Message --------
Received: 	from crm.avasflowers.com ([169.54.49.88]) by mail.signal100.net with MailEnable ESMTP; Fri, 7 Sep 2018 01:10:37 +0100
Received: 	by crm.avasflowers.com (Postfix, from userid 48) id D2ABE1403205; Thu, 6 Sep 2018 19:10:36 -0500 (CDT)
To: 	Mark Rousell <mark.rousell@signal100.com>
Subject: 	Re: Re: What's up with all the spam posts in this newsgroup? #M10434786
X-PHP-Originating-Script: 	0:email.container.php
MIME-Version: 	1.0
Content-type: 	text/html; charset=utf-8; format=flowed
Content-Transfer-Encoding: 	7bit
X-Mailer: 	Avas Flowers Email System
From: 	Alejandro T <cs@avasflowers.com>
Reply-To: 	Alejandro T <cs@avasflowers.com>
Message-Id: 	<20180907001036.D2ABE1403205@crm.avasflowers.com>
Date: 	Thu, 6 Sep 2018 19:10:36 -0500 (CDT)
Return-Path: 	<apache@crm.avasflowers.com>


Good day

This is a customer service email for Avas Flowers, we do not have a resolution for this matter, please redirect your email.

Can we please be removed from the mailing list? since we tried the link and it does not work.

Have a great day.


Sincerely,

Alejandro T

Message #M10434786. Please do not modify the subject when replying to this mail so we can assign your communication to the correct person.

To modify your order click here
To check the status of your order click here
To contact us click here
For Our Terms of Service and Policies click here
For Our Customer Service Policies click h ere


Avas Flowers
http://www.AvasFlowers.Com
877-638-3303
(In reply to Dave Miller [:justdave] (justdave@bugzilla.org) from comment #8)
> I sent them an email explaining what I figured out (CCed you).

Dave, not sure if you're getting my emails. Just sent you one with the above. Also sent you one on 3rd September with a copy of a post from them to m.general which showed that they subscribed to m.general with "contact@avasflowers.com" in January 2018.
I had not... I just went and looked and found it in my Spam folder.

Indeed, there is a contact@avasflowers.com subscribed.  They've been removed. :-)
Assignee: mhoye → justdave
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
(In reply to Dave Miller [:justdave] (justdave@bugzilla.org) from comment #16)
> I had not... I just went and looked and found it in my Spam folder.
> 
> Indeed, there is a contact@avasflowers.com subscribed.  They've been
> removed. :-)

Ahah! Thank you very much for your help. :-)
You need to log in before you can comment on or make changes to this bug.