Closed Bug 1488114 Opened Last year Closed Last year

Refactor the reducers in RDM

Categories

(DevTools :: Responsive Design Mode, defect, P3)

defect

Tracking

(firefox63 verified, firefox64 verified)

VERIFIED FIXED
Firefox 64
Tracking Status
firefox63 --- verified
firefox64 --- verified

People

(Reporter: gl, Assigned: gl)

References

Details

Attachments

(2 files)

No description provided.
Attached patch 1488114.patchSplinter Review
Attachment #9006078 - Flags: review?(rcaliman)
Attachment #9006078 - Flags: review?(rcaliman) → review+
Backed out for xpcshell failures on test_change_pixel_ratio.js.

Log link: https://treeherder.mozilla.org/logviewer.html#?job_id=197401509&repo=mozilla-inbound&lineNumber=2110
Flags: needinfo?(gl)
Backout by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/64c4f4204676
Backed out changeset 7ffb06278c4c for xpcshell failures on test_change_pixel_ratio.js. CLOSED TREE
Flags: needinfo?(gl)
https://hg.mozilla.org/mozilla-central/rev/aba81999ef71
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Target Milestone: Firefox 64 → Firefox 63
Target Milestone: Firefox 63 → Firefox 64
Duplicate of this bug: 1488566
I originally intended to fix it in dedicated Bug 1488566, but the patch here landed the fix already. This patch is just a subset of the patch that landed on central, which is actually not related to the rest of the refactor done in this patch.

Forwarding r+ received on Bug 1488566 already. This patch is rebased on top of latest Beta.

Approval Request Comment
[Feature/Bug causing the regression]:1467572
[User impact if declined]:Users might be unable to stop Responsive Design Mode
[Is this code covered by automated tests?]:no
[Has the fix been verified in Nightly?]:no 
[Needs manual test from QE? If yes, steps to reproduce]: yes, STRs are:
STRs:
- clean profile
- open any website
- enable Responsive Design Mode
- check "Reload when user agent is changed"
- change the user agent
- try to stop Responsive Design Mode
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]:no
[Why is the change risky/not risky?]: simple JS fix
[String changes made/needed]:One new string responsive.reloadNotification.description2 (replaces responsive.reloadNotification.description)
Attachment #9006778 - Flags: review+
Attachment #9006778 - Flags: approval-mozilla-beta?
Flags: qe-verify?
Comment on attachment 9006778 [details] [diff] [review]
fix_localization_error_beta.patch

Simple l10n js fix, flod is OK with it, uplift accepted for 63 beta 4
Attachment #9006778 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify? → qe-verify+
Verified, that the issue is no longer reproducible with STR from Comment 8 on Nightly 64.0a1(20180907100116) and Beta 63.0b4(20180906162647). RDM is closed successfully, also the error mentioned in Bug 1488566 is not displayed in browser console.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.