attempt to start mail for a second time after exiting it stalls

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
major
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: ted goldblatt, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    2002052306

if I run mail from a browser window, then exit mail (but not the browser), a
second attempt to start mail fails to bring up a mail window.

FWIW, this problem seemed to exist under (at least) RC2 also, but RC3 came out
before I had a chance to report it there.

Reproducible: Always
Steps to Reproduce:
1.Bring up browser (note - quickstart enabled)
2.From browser window, start mail (mail window comes up normally)
3.Exit mail window
4.From browser window, start mail again

Actual Results:  Menubar "window" display shows an ordinal for the new window,
but no title.  (Implies a thread was created, which created new window but
stalled before it displayed it?)

Browser window(s) continue to behave normally, and new tabs and windows can be
created.

CPU usage does _not_ peg, but (when otherwise idle) remains ~0 (i.e., mail
thread appears to have stalled rather than hung).

Additional attempts to start mail have no effect.

Exiting all browser windows does not exit mozilla process.  Starting it again
(desktop or quickstart icons) brings up (normally behaving) browser window, but
without a splash screen.  

Expected Results:  mail screen comes up successfully

I am not familiar with Windoze debugging, so don't know if WinMe has any
mechanism to find threads and display their state.  However, the problem is
consistently reproducible for me, so if there is additional info I can provide,
just let me know.

Mail server is POP3; leave messages on server is set, empty trash on exit is not.

Comment 1

16 years ago
Possibly caused by other themes installed. Reporter: check Bug 138239 and Bug
136874.

Comment 2

16 years ago
I'm experiencing something similar with nightlies after Mozilla 1.1,
but the mail client is able to start only once after the installation,
then it hangs during startup. No mail window, just a mozilla process
that stays in the background with 12 MB memory consumption...
BTW, I'm using the Lo-Fi theme, don't know if that's relevant.
Mozilla 1.1 seems to be working fine.

Comment 3

15 years ago
Ted Goldblatt, Andrea Aime: is this bug still an issue for you?
(Reporter)

Comment 4

15 years ago
Cannot reproduce on recent Mozilla releases.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 5

15 years ago
Verifying resolution.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.