Closed Bug 1488293 Opened 2 years ago Closed 2 years ago

Enhancement: want to be able to have a toolbar button to switch font settings on the fly

Categories

(WebExtensions :: Untriaged, enhancement)

61 Branch
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1400805

People

(Reporter: erwinm, Unassigned)

Details

(Keywords: access)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180807170231

Steps to reproduce:

Users may need to increase minimum font sizes, change font selections, or both, to read web pages.

Page zoom is not a viable option because it increases all font sizes, doesn't change fonts themselves, and breaks scrolling.

Whether we use Firefox settings, add-ons, or user css, this can hide text, break links, or cause flashing tooltips. For example, I can't reach the Feedback link here, because of the overlap with the search link:

https://encyclopedia.1914-1918-online.net/search/?_advanced=1
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
20180902101255

Unchecking "Allow web pages to choose their own fonts…" is already applied without having to reload the page. The same happened when I changed the serif default font size and the monospace font. So I don't see what enhancement the summary asks for.
The description is a duplicate of bug 912159.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Component: Untriaged → Disability Access
Keywords: access
OS: Unspecified → All
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 912159
"Unchecking "Allow web pages to choose their own fonts…" is already applied without having to reload the page."

Even if the preferences worked properly, having to go into the preferences wouldn't be "on the fly."
The other bug is about how, if readers want to read webpages, this breaks some webpages. This bug is about how to work around that, so related but not a duplicate.
(In reply to MarjaE from comment #2)
> Even if the preferences worked properly, having to go into the preferences
> wouldn't be "on the fly."

What do you consider "on the fly" if not settings that are applied the instant you change them?

(In reply to MarjaE from comment #3)
> The other bug is about how, if readers want to read webpages, this breaks
> some webpages. This bug is about how to work around that, so related but not
> a duplicate.

Comment 0 is just about the problems caused by the minimum font size, and why some users need to change that setting. There's no request for enhancement.
Being able to change minimum font size in the toolbar, like full-page zoom, instead of having to open preferences, open another page in preferences, go into another page in preferences, change settings, go back to the webpage, read it-- or repeat if you need to further change settings--, go back to the preferences, go into another page in preferences, change settings back, and then close preferences.

Zoom Page WE provides similar functionality, but doesn't apply in Mozilla's own pages, and because Web Extensions load after the pages they modify, causes a flash between the 1st rendering and 2nd rendering.
(In reply to MarjaE from comment #5)
> Zoom Page WE provides similar functionality, but doesn't apply in Mozilla's
> own pages

If you want to remove that security restriction,
1. Paste the following into the address bar:
about:config?filter=extensions.webextensions.restrictedDomains
2. Click the big button to bypass the warning.
3. Double-click extensions.webextensions.restrictedDomains to edit its value.
4. Delete the unwanted domains and their adjacent comma. Click the OK button when done.
Severity: normal → enhancement
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Enhancement: allow users to switch font settings on the fly → Enhancement: add a toolbar button to switch font settings on the fly
I don't think the use of the font settings justify us implementing this ourselves - it seems like something that an add-on should take care of.
Component: Disability Access → Untriaged
Product: Firefox → WebExtensions
Summary: Enhancement: add a toolbar button to switch font settings on the fly → Enhancement: want to be able to have a toolbar button to switch font settings on the fly (font settings should be webextension-configurable)
Extensions can already do this:
https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/API/browserSettings/useDocumentFonts
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1400805
(In reply to Gingerbread Man from comment #6)
> (In reply to MarjaE from comment #5)
> > Zoom Page WE provides similar functionality, but doesn't apply in Mozilla's
> > own pages
> 
> If you want to remove that security restriction,
> 1. Paste the following into the address bar:
> about:config?filter=extensions.webextensions.restrictedDomains
> 2. Click the big button to bypass the warning.
> 3. Double-click extensions.webextensions.restrictedDomains to edit its value.
> 4. Delete the unwanted domains and their adjacent comma. Click the OK button
> when done.

The default value of this preference was carefully chosen.  Suggesting changing its value without understanding and explaining the consequences is irresponsible, please don't do that.
Web extensions aren't an adequate solution. Firefox doesn't apply web extensions until *after* loading the pages, so relying on web extensions means Firefox renders with unreadably small  fonts, and then flashes before re-rendering with readably-sized fonts.
Summary: Enhancement: want to be able to have a toolbar button to switch font settings on the fly (font settings should be webextension-configurable) → Enhancement: want to be able to have a toolbar button to switch font settings on the fly
You need to log in before you can comment on or make changes to this bug.