Closed Bug 1488307 Opened Last year Closed Last year

Build the LLVM gold plugin

Categories

(Firefox Build System :: Toolchains, enhancement)

enhancement
Not set

Tracking

(firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

No description provided.
As must as it's tempting to use LLD for LTO, it still causes some
subtle problems with the build, and it's still better to keep using
BFD ld for the time being. Doing so requires the gold plugin, which
only requires to pass cmake the directory where the binutils headers
are, and they are part of the gcc toolchain headers.
Comment on attachment 9006126 [details]
Bug 1488307 - Build the LLVM gold plugin. r?build

Michael Shal [:mshal] has approved the revision.
Attachment #9006126 - Flags: review+
Backout by mh@glandium.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/faba20592c04
Backout changeset c2b5cf7bde83 to give time to toolchains to build without blocking other landings.
https://hg.mozilla.org/mozilla-central/rev/e2a02b08089b
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
No longer depends on: 1489105
Duplicate of this bug: 1286788
You need to log in before you can comment on or make changes to this bug.