Can't get email, "When I'm added to or removed from the Bug Owner capacity" ONLY

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Email Notifications
RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: Michael, Assigned: Frédéric Buclin)

Tracking

2.14.1
Bugzilla 3.0
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Under [User preferences]|[Email settings]| "When I'm the Bug Owner, email me:"
The COMPONENT'S OWNER is signed ONLY the checkbox "When I'm added to or removed from this capacity" all 
others checkboxes are empty, I.E.
After entering a new bug, the email is sent to Version Manager, after that the Version Manager 
Reassign bug to [COMPONENT'S OWNER email] and no e-mail is sent to a COMPONENT'S OWNER.

Thank you
(Reporter)

Comment 1

16 years ago
Hi,
I would like try another explanation:

I have signed the checkbox
“When I'm the Bug Owner, email me:”
	[x] “When I'm added to or removed from this capacity”
other checkboxes under this section are empty
Under [User preferences]|[Email settings] 

Since I did this change I stop get emails, when the bug was reassign to me.

Any help!?!

Thank you
Michael

Comment 2

16 years ago
-> email notifications & its default owner
Assignee: justdave → preed
Component: Bugzilla-General → Email Notifications

Comment 3

15 years ago
With Bugzilla version 2.12 I encountered the same problem as #1 Michael when 
manually reassigning a bug to a user who is neither reporter nor comp owner.
All users have [x] “When I'm added to or removed from this capacity” for Owners.
---
Activity log     Bug 182  
Who           What        Old value     New value    When 
...
T.Zang@asc.de bug_status  RESOLVED      REOPENED     2002-10-01 15:09:13 
T.Zang@asc.de resolution  WONTFIX                    2002-10-01 15:09:13 
T.Zang@asc.de assigned_to Hans@asc.de   Mike@asc.de  2002-10-01 15:11:38 
T.Zang@asc.de bug_status  REOPENED      NEW          2002-10-01 15:11:38 
---
Hans@asc.de ist comp owner - he gots mail, Mike@asc.de is the developer - he 
didn't get any mail.

Comment 4

14 years ago
I've noticed this too, when changing a bug's owner or QA contact, the person 
that it is changed to does not get email if their "Any field not mentioned 
above changes" checkboxes are unchecked even though their "I'm added to or 
removed from this capacity" checkboxes are checked.  I think that this also 
happens when adding someone to the CC list.

Comment 5

13 years ago
Does anyone have any suggestions on how to fix this?

Comment 6

12 years ago
Kick all my Bugzilla bugs back to the component default owner.
Assignee: preed → email-notifications
(Assignee)

Updated

12 years ago
Severity: major → normal
Keywords: qawanted

Comment 7

12 years ago
This appears to be still a problem in 2.20.  We have an email account which sends email to all our developers, and a corresponding bugzilla account.  Some bugs are assigned to that account when created.  If that account has just "I'm added to or removed from this capacity" and "The bug is resolved or reopened" checked under "Assignee", the email isn't sent (bugzilla lists the account as skipped in the message after the bug is entered).

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa

Comment 8

12 years ago
Seeing this or very similar behavior in current CVS trunk (well, about a week or two old) that users are not receiving the email always when they're assigned to a bug.
(Assignee)

Comment 9

12 years ago
Created attachment 233868 [details] [diff] [review]
patch for tip, v1
Assignee: email-notifications → LpSolit
Status: NEW → ASSIGNED
Attachment #233868 - Flags: review?(bugzilla-mozilla)
(Assignee)

Comment 10

12 years ago
For tip, this is a regression due to bug 139309. I'm checking now if 2.22 is affected too.
Keywords: qawanted
OS: Linux → All
Hardware: PC → All

Comment 11

12 years ago
Comment on attachment 233868 [details] [diff] [review]
patch for tip, v1

r=bkor

Tested behavior before and after. This fixes the bug. Also matches with conclusions from the debug session on IRC. :-)
Attachment #233868 - Flags: review?(bugzilla-mozilla) → review+

Updated

12 years ago
Flags: approval?
Target Milestone: --- → Bugzilla 3.0
(Assignee)

Comment 12

12 years ago
OK, I confirm that 2.22 is not affected. What I think is that this was an old bug in 2.14, then this problem has probably been fixed in bug 73665 for 2.20, and then we introduced it again lately when changing some code.
Flags: approval? → approval+
(Assignee)

Comment 13

12 years ago
Checking in Bugzilla/BugMail.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/BugMail.pm,v  <--  BugMail.pm
new revision: 1.89; previous revision: 1.88
done
Checking in Bugzilla/User.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/User.pm,v  <--  User.pm
new revision: 1.126; previous revision: 1.125
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.