Large image goes white when scrolling

RESOLVED DUPLICATE of bug 132571

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 132571
16 years ago
10 years ago

People

(Reporter: arjand666, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0+) Gecko/20020525
BuildID:    2002052508

After having completed loading the image specified in the URL, scrolling around
in the image will cause whatever portion of the picture that happens to be
scrolled onto the screen to become white - it remains white if you scroll back
as well. (This behavior can be reproduced with a local copy of the image as well.)

Reproducible: Always
Steps to Reproduce:
1. Load picture (wait until fully loaded)
2. Scroll around
3. Image goes white

Actual Results:  Image with large white areas.

Expected Results:  Show me whatever part of the picture I try to scroll to, like
GIMP does.

Comment 1

16 years ago
WFM win XP trunk build 2002060308
WFM: Win2k/2002060108.

Win98, huh? What's your video card?

Comment 3

16 years ago
WFM 1.0.0 branch build 2002053012 WinME.

However, I can see exactly the same problem with this image:

http://www.caida.org/outreach/resources/learn/ipv4space/images/map.gif

See comments in bug 101018, of which this is probably a duplicate.

Comment 4

16 years ago
http://www.theinquirer.net/dscf0034.jpg WFM Win98 Build RC2 and Build RC3
(2002052308)

Comment 5

16 years ago
I want to confim the BUG. 
Found the same on:

http://republika.pl/machonus/images/Gesi.jpg

Under MOzilla 1.0PL (2002053012) Win 98SE

Large image (very large) after scrolling down and up i have large white page. 
Please take a new build and test on Win98 tomorrow. There has been a fix issued
for bug 101018, which appears to be the same bug. I'm quite sure actually.
Reopen if not fixed.

*** This bug has been marked as a duplicate of 101018 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
Hmmm, no, this is NOT a dupe.

http://www.theinquirer.net/dscf0034.jpg: This JPEG file doesn't show up for me
at all in Mozilla, though external viewers process it correctly.

http://republika.pl/machonus/images/Gesi.jpg : WORKSFORME

BuildID 2002062404 / win2000
Gotcha.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
I see both images on Win2K, and this bug and bug 101018 refer to scrolling in
Win98 only. Please clarify Wesha.

Comment 10

16 years ago
I'm using Mozilla v1.1a (2002061104) on Win98SE.
I can see http://www.theinquirer.net/dscf0034.jpg with no problem.
Maybe because the image is not too large. When I try to open
http://www.fabiolrs.hpg.ig.com.br/spamdemicmap.gif mozilla starts rendering the
image at the time it is being downloaded. After the image is fully downloaded,
the scrolled-out areas are not redrawn.

Comment 11

16 years ago

*** This bug has been marked as a duplicate of 132571 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.