Closed Bug 1488674 Opened Last year Closed Last year

Massive Mozmill failure on 20180-09-05: 98 failing tests: TEST-UNEXPECTED-FAIL | [snip]/mozmill/attachment/test-attachment.js and many more

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 64.0

People

(Reporter: jorgk, Assigned: darktrojan)

References

Details

Attachments

(3 files, 2 obsolete files)

TEST-UNEXPECTED-FAIL | [snip]/mozmill/attachment/test-attachment.js
TEST-UNEXPECTED-FAIL | [snip]/mozmill/cloudfile/test-cloudfile-attachment-urls.js
TEST-UNEXPECTED-FAIL | [snip]/mozmill/cloudfile/test-cloudfile-notifications.js
TEST-UNEXPECTED-FAIL | [snip]/mozmill/composition/test-attachment-reminder.js
TEST-UNEXPECTED-FAIL | [snip]/mozmill/composition/test-attachment.js
TEST-UNEXPECTED-FAIL | [snip]/mozmill/composition/test-blocked-content.js
TEST-UNEXPECTED-FAIL | [snip]/mozmill/composition/test-charset-edit.js
TEST-UNEXPECTED-FAIL | [snip]/mozmill/composition/test-charset-upgrade.js
TEST-UNEXPECTED-FAIL | [snip]/mozmill/composition/test-drafts.js 
TEST-UNEXPECTED-FAIL | [snip]/mozmill/composition/test-eml-actions.js
TEST-UNEXPECTED-FAIL | [snip]/mozmill/composition/test-focus.js
TEST-UNEXPECTED-FAIL | [snip]/mozmill/composition/test-forward-headers.js
and many more, 98 subtests in total.

M-C last good: c3734e0f634e10ad994112e49d1849817c (on try)
M-C first bad: bb0febbdbb250756bbaab3ebf525874fda
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c3734e0f634e10ad994112e49d1849817c&tochange=bb0febbdbb250756bbaab3ebf525874fda

Log
https://taskcluster-artifacts.net/f4k5141ySU2ENLhoNcx4QQ/0/public/logs/live_backing.log
says:

EXCEPTION: Only 1 attachment is selected!: 'Remove Attachment' != 'Remove Attachments'.
EXCEPTION: Timed out waiting for a target for selector: body > #cloudAttachmentListRoot
EXCEPTION: editor is null, can't access property "beginningOfDocument" of it
EXCEPTION: Expected the notification with value bigAttachment to be shown
EXCEPTION: Expected the notification with value bigAttachmentUploading to be shown
EXCEPTION: Expected the notification with value bigAttachment to be shown
EXCEPTION: Timed out waiting for notification with value attachmentReminder to show.
EXCEPTION: Timed out waiting for window open!
EXCEPTION: Timeout waiting for modal dialog to open.
EXCEPTION: Timed out waiting for notification with value attachmentReminder to show.
EXCEPTION: node is undefined, can't access property "attachment" of it
EXCEPTION: Timeout waiting for pasted tmp image to be loaded ok
EXCEPTION: Thought we would find row 1 at 95,27 but we found -1
EXCEPTION: a != b: 'x-mac-croatian' != 'utf-7'.
EXCEPTION: Thought we would find row 0 at 95,9 but we found -1
EXCEPTION: gMsgCompose.editor is null, can't access property "flags" of it
EXCEPTION: a != b: '1' != '2'.
EXCEPTION: gMsgCompose.editor is null, can't access property "flags" of it
EXCEPTION: Timeout waiting for modal dialog to open.
EXCEPTION: element is null, can't access property "QueryInterface" of it
EXCEPTION: Thought we would find row 2 at 95,45 but we found -1
EXCEPTION: Unable to find "Application Basics" in compose window
EXCEPTION: Timeout waiting for window to close!
EXCEPTION: The From address is not correctly selected! Expected: lenny@springfield.invalid; Actual: carl@example.com

So a very mixed bag that makes it hard to pin down to a bug.

Aceman, here's work for you.
Flags: needinfo?(acelists)
OK, poking around the M-C changelog:
b37012fc286d Ehsan Akhgari - Bug 1488112 - Remove the XPCOM component registration for nsBaseCommandController; r=qdot
We use that https://searchfox.org/comm-central/search?q=base-command-controller&case=false&regexp=false&path=
but that appears to be for SM editor code only.

These don't affect us:
0d854c7e08bd Ehsan Akhgari - Bug 1488111 - Remove the XPCOM component registration for nsCommandManager; r=qdot
3cf15cc00ee5 Ehsan Akhgari - Bug 1488306 - Remove the XPCOM component registration for nsUnknwonDecoder; r=valentin
I've got this.

Now that I understand a little better, I think we could've done the same with TransactionManager. Maybe we still should.
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Flags: needinfo?(acelists)
Attachment #9006460 - Flags: review?(jorgk)
Duplicate of this bug: 1488650
Looking at bug 1488650 now, I was wrong in my comment #1. base-command-controller *is* used in ComposerCommands.js :-(

Quoting from bug 1488650 for completeness:

chrome://messenger/content/messengercompose/MsgComposeCommands.js, line 3132: NS_ERROR_UNEXPECTED: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsICommandManager.removeCommandObserver]
It looks like it's one or both of bug 1488111 and bug 1488112.

Here's a stack of the error that triggers the message about nsIPromptService.
GetComposerCommandTable@chrome://editor/content/ComposerCommands.js:195:5
SetupHTMLEditorCommands@chrome://editor/content/ComposerCommands.js:14:22
EditorSharedStartup@chrome://editor/content/editor.js:429:5
ComposeStartup@chrome://messenger/content/messengercompose/MsgComposeCommands.js:2951:3
ComposeLoad@chrome://messenger/content/messengercompose/MsgComposeCommands.js:3100:7
onload@chrome://messenger/content/messengercompose/messengercompose.xul:1:1
Comment on attachment 9006460 [details] [diff] [review]
1488674-command-controller-1.diff

Thanks. What else will we need to fork in the future :-(
Attachment #9006460 - Flags: review?(jorgk) → review+
See Also: → 1488677
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/4270401f6347
Replace the XPCOM component registration for nsBaseCommandController removed in bug 1488112. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 64.0
Attached patch 1488674-tidy-1.diff (obsolete) — Splinter Review
Tidies up the mess that I made by forgetting header files exist.
Attachment #9006475 - Flags: review?(jorgk)
Comment on attachment 9006475 [details] [diff] [review]
1488674-tidy-1.diff

OK, you need to rebase bug 1488677 now?
Attachment #9006475 - Flags: review?(jorgk) → review+
Oops, that appears to be based on bug 1488677, so the patch doesn't apply.
Attached patch 1488674-tidy-2.diff (obsolete) — Splinter Review
Attachment #9006475 - Attachment is obsolete: true
Attachment #9006484 - Flags: review+
Might as well finish the job.
Attachment #9006484 - Attachment is obsolete: true
Attachment #9006487 - Flags: review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/02dad197889f
Follow-up: Tidy nsCommonBaseCID.h and nsCommonModule.cpp. r=jorgk
You need to log in before you can comment on or make changes to this bug.