Closed Bug 1488679 Opened Last year Closed 7 months ago

Command Line --version number is not full number

Categories

(Toolkit :: Startup and Profile System, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla67
Tracking Status
firefox-esr60 --- verified
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- verified

People

(Reporter: paully.littlefield, Assigned: Sylvestre)

References

Details

Attachments

(3 files, 2 obsolete files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180823143155

Steps to reproduce:

/usr/bin/firefox --version


Actual results:

Mozilla Firefox 62.0


Expected results:

/usr/bin/firefox --version
Mozilla Firefox 62.0b20 (64-bit)

This should be the same output as the GUI window showing this from Help > About Firefox
(It's the same for Mozilla Thunderbird as well)
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
20180902101255

firefox -v | more
results in the following:

Release: Mozilla Firefox 61.0.2
Beta: Mozilla Firefox 62.0
Nightly: Mozilla Firefox 63.0a1
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Component: Untriaged → Startup and Profile System
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
This is probably because it is the RC build. As it is an RC, it is the exact same binary as the release. Therefor, we don't show the beta number.
I will mark this bug as invalid as I don't think we will do something about that.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → INVALID
Oh, OK.
Actually, thinking about it... what's the point of putting the full version in the GUI then?!

https://imgur.com/a/HMAgOW4

...seems a bit odd, and that window op-up must be pulling it from somewhere!

:-)

Paul
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
20180910132416

(In reply to Sylvestre Ledru [:sylvestre] from comment #3)
> This is probably because it is the RC build.

Beta channel is now 63.0b5 and it still doesn't show the full version number.

firefox -v | more
Mozilla Firefox 63.0
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
This is indeed bug, thanks!
Indeed, surely there must be some consitency here and it's a tiny job?!

It would be really nice to have this, because then us BETA testers can use command line scripts to check if there is a new release and download it.

FIREFOX_VERSION=$( firefox --version | awk '{ print $3 }' )

;-)

Paully
Please don't reset the flags ;)
Duplicate of this bug: 1493873
Was this working before with some older beta builds of Firefox? Could someone please check?
Should be easy to find out.
on win32 build, I got followings. So, regression is between 4 and 5.

4.0b12: Mozilla Firefox 4.0b12
5.0b1 : Mozilla Firefox 5.0
Thank you Alice! It's quite a while then, and started when we switched to the rapid release cycle. 

Alice, do you have the build numbers or changeset ids of those builds? That might help to find it.
(In reply to Henrik Skupin (:whimboo) from comment #15)
> Thank you Alice! It's quite a while then, and started when we switched to
> the rapid release cycle. 
> 
> Alice, do you have the build numbers or changeset ids of those builds? That
> might help to find it.

It's a huge range, It will be almost one version of push log.
I know but it would still be good to have. We may find it, and maybe the reasoning behind. If it was intentional or not.
https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?startdate=2011-02-22+21%3A02%3A21&tochange=9df9078bc469

application.ini shows as follow

[App]
Vendor=Mozilla
Name=Firefox
Version=4.0b12
BuildID=20110222210221
SourceRepository=http://hg.mozilla.org/mozilla-central
SourceStamp=d322a1c8537e
ID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}

[Gecko]
MinVersion=2.0b12
MaxVersion=2.0b12



[App]
Vendor=Mozilla
Name=Firefox
Version=5.0
BuildID=20110427143820
SourceRepository=http://hg.mozilla.org/mozilla-beta
SourceStamp=9df9078bc469
ID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}

[Gecko]
MinVersion=5.0b1
MaxVersion=5.0b1
So the application.ini file is built via the following make file and the version comes from `@MOZ_APP_VERSION@`
https://searchfox.org/mozilla-central/rev/ffe6eaf2f032e58ec3b0650a87df2c62ae4ca441/build/application.ini.in#25

This seems to get set in:
https://searchfox.org/mozilla-central/rev/ffe6eaf2f032e58ec3b0650a87df2c62ae4ca441/browser/confvars.sh#40
https://searchfox.org/mozilla-central/rev/ffe6eaf2f032e58ec3b0650a87df2c62ae4ca441/old-configure.in#719

Which means it actually comes from:
https://dxr.mozilla.org/mozilla-beta/source/browser/config/version.txt

Given that there is not `bX` suffix specified, we don't add it to the version in application.ini.

Interestingly there is also the following file which I think we might want to use instead?

https://dxr.mozilla.org/mozilla-beta/source/browser/config/version_display.txt

Mike and Sylvestre, would that be possible?
Flags: needinfo?(sledru)
Flags: needinfo?(mh+mozilla)
Try using MOZ_APP_VERSION_DISPLAY instead of MOZ_APP_VERSION, and see what happens?
Flags: needinfo?(mh+mozilla)
Sure, but my question was more if we want to see the beta version exposed in the version property.

Also if that works, would we still need all the code paths for MOZ_APP_VERSION_DISPLAY? Or could those be removed?
(In reply to Henrik Skupin (:whimboo) from comment #22)
> Sure, but my question was more if we want to see the beta version exposed in
> the version property.

I don't have an answer to that question.

> Also if that works, would we still need all the code paths for
> MOZ_APP_VERSION_DISPLAY? Or could those be removed?

I don't understand the question.
(In reply to Mike Hommey [:glandium] from comment #23)
> (In reply to Henrik Skupin (:whimboo) from comment #22)
> > Sure, but my question was more if we want to see the beta version exposed in
> > the version property.
> 
> I don't have an answer to that question.
I would like to see that too
I can try to implement that.
Flags: needinfo?(sledru)
Sylvestre, are you still interested in doing this?
I am but no time yet. Maybe in a plane :)
Flags: needinfo?(sledru)

Old regression and not known to impact usage outside of beta testing scripts.

Sylvestre, I know this is your favorite bug, still interested?

Flags: needinfo?(sledru)

Depends on D19023

Attachment #9042216 - Attachment is obsolete: true

Sure, I took a plane a few days ago and that kept me busy :)

Assignee: nobody → sledru
Flags: needinfo?(sledru)
Version: 62 Branch → unspecified
https://hg.mozilla.org/integration/mozilla-inbound/rev/c7f5753a2c71e0d93f19fce8711852c6fbe53f95
Bug 1488679 - nsAppRunner.cpp: Ride along - Move to the correct style r=glandium
https://hg.mozilla.org/integration/mozilla-inbound/rev/1f7d1d6bf61de6fd419cd83933012a377838dfcb
Bug 1488679 - Use MOZ_APP_VERSION_DISPLAY for --version to show the full version r=glandium
Status: REOPENED → RESOLVED
Closed: Last year7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Not all the commits landed here, so the bug needs to be reopened.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla67 → ---
Keywords: leave-open
Attachment #9043583 - Attachment is obsolete: true
Attachment #9042218 - Attachment description: Bug 1488679 - Use MOZ_APP_VERSION_DISPLAY for --version to show the full version r?glandium → Bug 1488679 - Use MOZ_APP_VERSION_DISPLAY for --version to show the full version r=glandium
Pushed by sledru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/56575ed63592
Use MOZ_APP_VERSION_DISPLAY for --version to show the full version r=glandium

It has been so long that I don't think we can call that a regression anymore...

Severity: normal → enhancement
Flags: needinfo?(sledru)
Status: REOPENED → RESOLVED
Closed: 7 months ago7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

This should be verified when 67 reaches beta.

Flags: qe-verify+

Tips to verify for each OS:
Windows: C:\Program Files\Firefox\LATESTbeta>firefox -v | more
Ubuntu: svuser@Laptop595:/Desktop/Nightly 66/firefox$ ./firefox --v
MacOS: SL123-14:
svuser$ /Applications/Firefoxbeta.app/Contents/MacOS/firefox -v |more

NI myself to check when firefox67 reaches beta channel.

Flags: needinfo?(daniel.bodea)

Hi, I have retested this issue On WIndows 10, Mac and Ubuntu using the latest version of Firefox Beta 67.0b3 as well as Firefox ESR 60.6.0 and now the full version is shown on all systems. I will mark this issue accordingly.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(daniel.bodea)
You need to log in before you can comment on or make changes to this bug.