Closed Bug 1488681 Opened Last year Closed Last year

[wdspec] Modifier key not correctly set due to differnce of platform name between sys.platform and capabilities

Categories

(Testing :: geckodriver, defect, P1)

Version 3
defect

Tracking

(firefox62 unaffected, firefox63 fixed, firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
firefox62 --- unaffected
firefox63 --- fixed
firefox64 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: whimboo)

References

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: hskupin [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=197555929&repo=try

https://queue.taskcluster.net/v1/task/L_iEsYWSR_mjkk_n3FCvdQ/runs/0/artifacts/public/logs/live_backing.log

All three tests are failing now because the modifier key doesn't seem to be used correctly.
This is a regression from bug 1470646:

https://hg.mozilla.org/mozilla-central/rev/16ba5f9ae84e#l3.45

`sys.platform` doesn't return `mac` but `darwin`.

What I wonder is why I haven't seen those failures in the last weeks when running the tests locally. But now I can easily reproduce.
Assignee: nobody → hskupin
Blocks: 1470646
Status: NEW → ASSIGNED
Priority: P5 → P1
Note that I will do the manifest update right before landing the patch on inbound.
Attachment #9006469 - Flags: review?(james) → review+
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/afecebb972d5
[wdspec] Fix detection of modifier key on MacOS. r=jgraham
Summary: [wdspec] Modifier key not correctly used in webdriver/tests/actions/key_shortcuts.py | test_mod_* - AssertionError: assert 'abc d' == '' → [wdspec] Modifier key not correctly set due to differnce of platform name between sys.platform and capabilities
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/12845 for changes under testing/web-platform/tests
https://hg.mozilla.org/mozilla-central/rev/afecebb972d5
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.