If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Opening first link in new tab causes base window to reload

RESOLVED INVALID

Status

SeaMonkey
Tabbed Browser
RESOLVED INVALID
16 years ago
8 years ago

People

(Reporter: NightStorm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
RMB a link, select "Open in new window".  New window opens while base window
remains static.

Do the same but now select "Open in link new tab"  Link loads in new tab, but
base window does a full reload

This occurs only for the firs tabbed window opened.

Closing the last tab will also cause the base window to reload.

Comment 1

16 years ago
WFM (1.0 Branch, 20020529) Linux RH7.1

I'm not sure what you mean by the first link in the URL?
I tried the "Mandrake Linux" link at the top, as well
as the German and "Home" link in the "Main Menu" on the left.
What build are you using?
(Reporter)

Comment 2

16 years ago
I am using RC3

Try this ...
   Note: you will need to be a registered used of the MandrakeForum
   for this to work.  And in the interest of complete disclosure
   (and more importantly because this may be somehow relevent :)
   I've my theme set to "Ethereal").  Get logged into the forum
   so that the cookies get setup so that when you go to the URL
   below you will be logged in.

With no other Mozilla windows open, start a new RC3 browser window.
Go to:
 <http://www.mandrakeforum.com/article.php?sid=2190&lang=en>

Scroll down to the discussion about KDE3.01. RMB on a thread's link
and select open-in-new-tab.

Notice that the base window (the one you just left) is reloading simultaneous
to the new one loading.  I don't believe that the base window should be
reloading at this point.  It sure does not do that if you opened in a new
window.

Wait for everything to load.
Close the new tab (I RMB on the new tab and select close).

Notice that the base window reloads again.

Were you to open more than one new tabbed window then this does not occur.

Comment 3

16 years ago
Yes, I can now replicate this with the new URL using the same build as in
comment #1. Maybe we should change the URL listed in the bug?
(Reporter)

Comment 4

16 years ago
Changed the URL.  Sorry for that, part of my continuing mission to prove out the
breakdown of "assume"  ...  I Ass-u-me'd that this problem occurred with all of
the Mandrake Forum links!  :(

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: sairuh → pmac

Comment 5

15 years ago
Confirm that this happens for me on several pages (including the Mandrake link
cited).
Try: http://sports.espn.go.com/nfl/scoreboard
It seems to happen only if the tab bar is coming on or off (that is, when the
screen is resizing).
(Assignee)

Updated

9 years ago
Product: Core → SeaMonkey
Assignee: jag → nobody
QA Contact: pmac → tabbed-browser

Comment 6

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
(Reporter)

Comment 7

8 years ago
No longer valid with current SeaMonkey.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.