Closed Bug 1488721 Opened 1 year ago Closed 1 year ago

Clicking the separator lines closes the meatball menu

Categories

(DevTools :: General, defect, P5, minor)

defect

Tracking

(firefox-esr60 unaffected, firefox62 unaffected, firefox63 wontfix, firefox64 verified)

VERIFIED FIXED
Firefox 64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- wontfix
firefox64 --- verified

People

(Reporter: emilghitta, Assigned: mantaroh)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Separator.gif
[Affected versions]:
64.0a1 (BuildId:20180904220134)
63.0b3 (BuildId:20180904170936)

[Unaffected versions]: 
62.0 (BuildId:20180830143136)
60.2.0esr (BuildId:20180903060751)

[Affected platforms]:
Windows 10 64bit.
Ubuntu 16.04 64bit.
macOS 10.13.4

[Steps to reproduce]:
1. Launch Firefox.
2. Open the developer tools.
3. Click on the "meatball" menu.
4. Click on the separator line.

[Expected result]:
The meatball menu remains open.		

[Actual result]:
The meatball menu closes.

[Regression range]:
This seems to be a regression.

Last good revision: ea72ff9a6e23abf3aa52aaaf06a9ba8b18ca39c7
First bad revision: cc6ec2789c9d50a686f4df5a70bf0f1173d1d32e

Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ea72ff9a6e23abf3aa52aaaf06a9ba8b18ca39c7&tochange=cc6ec2789c9d50a686f4df5a70bf0f1173d1d32e

[Note]
For further information regarding this issue please observe the attached screencast.
Priority: -- → P5
Blocks: 1468999
I think that we should prevent click event in the event handler of MeatballMenu.js since MenuButton and HTMLTooltip don't know whether we should skip click event.[1]

[1] https://searchfox.org/mozilla-central/rev/3d989d097fa35afe19e814c6d5bc2f2bf10867e1/devtools/client/framework/components/MeatballMenu.js#149,201
We can click the MenuList div element. So we need to prevent click event in MenuList.js as well.

Try:
https://hg.mozilla.org/try/rev/9fee8bc9ee224e599494e086c4d84cd996a1872c
Pushed by mantaroh@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/7e125b229e29
Prevent closing the popup menu by clicking the space of tooltip popup menu. r=birtles
https://hg.mozilla.org/mozilla-central/rev/7e125b229e29
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Assignee: nobody → mantaroh
Reproduced this bug using the STR from comment 0, on an affected Nightly build (2018-09-05).

I can no longer reproduce this on Beta 64.0b3 (20181022150107) across platforms Windows 10 x64, macOS 10.11.6 and Ubuntu 16.04 x64. Also, I did exploratory testing around this fix (e.g. clicked on the separator lines when Devtools was docked to right, left and in a separate window). None of this scenario introduced any new regression.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.