Closed Bug 1488758 Opened Last year Closed Last year

Remove dependency on asrouterExperiment pref and consolidate messageProvider pref access

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 64
Iteration:
64.2 - Sep 28
Tracking Status
firefox63 + verified
firefox64 --- verified

People

(Reporter: k88hudson, Assigned: k88hudson)

References

(Blocks 1 open bug)

Details

Attachments

(2 files, 4 obsolete files)

No description provided.
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/8033ab78b7ec55ca9d1d3a4a3e9ec799183ddc22
Bug 1488758 - Part 1. Consolidate ASR prefs into ASRouterPreferences (#4415)

* Bug 1488758 - Consolidate ASR prefs into ASRouterPreferences
Iteration: 64.1 (Sep 14) → 64.2 (Sep 28)
* Bug 1488758 - Consolidate ASR prefs into ASRouterPreferences (#4415)
* (nobug) Check for presence of currentNotification before removal (#4402)
Comment on attachment 9010431 [details]
Bug 1488758 - Part 1. Consolidate ASR prefs into ASRouterPreferences

Kate Hudson :k88hudson has approved the revision.
Attachment #9010431 - Flags: review+
Attachment #9010432 - Attachment is obsolete: true
Comment on attachment 9010431 [details]
Bug 1488758 - Part 1. Consolidate ASR prefs into ASRouterPreferences

Approval Request Comment
[Feature/Bug causing the regression]: ASRouter not on by default
[User impact if declined]: ASRouter needs to be on by default so that CFR can run as a shield experiment
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: Bug 1492174 - Update CFR Messages to reflect planned cohorts
[Is the change risky?]: no
[Why is the change risky/not risky?]: feature doesn't have content on by default, requires shield settings to actually show messages
[String changes made/needed]: no
Attachment #9010431 - Flags: approval-mozilla-beta?
Kate, your uplift requests says that this has been verified on Firefox Nightly but I don't see any landing on mozilla-central in this bug.
Flags: needinfo?(khudson)
Apologies, I thought the the bug in which this was exported (https://bugzilla.mozilla.org/show_bug.cgi?id=1489962) had landed, but it was backed out. 

We really need on beta in order to release the shield study, will that be a blocker?
Flags: needinfo?(khudson)
Blocks: 1491379
Attachment #9010432 - Attachment filename: file_1488758.txt → phabricator-D6310-url.txt
Attachment #9010053 - Attachment is obsolete: true
I am adding some clarifications for this uplift request:

[Feature/Bug causing the regression]: The contextual feature recommendation experiment must be able to be turned on with one pref only, 
[User impact if declined]: Users will not be able to see any recommendations; we will not be able to understand how add-on recommendations affect retention without running the study.
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: as of Sept. 21, yes
[Needs manual test from QE? If yes, steps to reproduce]: yes, see "Testing instructions for verification" attachment
[List of other uplifts needed for the feature/fix]: This MUST be uplifted in conjuction with the two patches from Bug 1492174 - Update CFR Messages to reflect planned cohorts
[Is the change risky?]: no
[Why is the change risky/not risky?]: this feature is behind a pref and does not affect users in release (outside a shield study)
[String changes made/needed]: no
Comment on attachment 9010431 [details]
Bug 1488758 - Part 1. Consolidate ASR prefs into ASRouterPreferences

Thanks, uplift approved for 63 beta 9.
Attachment #9010431 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
Attachment #9009981 - Attachment is obsolete: true
I have verified this on Windows 10 x64, Arch Linux and Mac 10.13.3 with the latest version of "Firefox Beta" (63.0b9 - Build ID 20180924202103) installed and "Firefox Nightly" (64.0a1 - Build ID 20180924220042) and I can confirm that on the "about:newtab#asrouter" page the "cfr" string is listed under the "Message Providers" heading and several messages are displayed under the "Messages" heading (including the "AMAZON_ASSISTANT" one).

@Kate, considering the above, do we plan to close this issue?
Flags: qe-verify+ → needinfo?(khudson)
Yes, thank you!
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(khudson)
Resolution: --- → FIXED
Duplicate of this bug: 1477630
Blocks: 1493794
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → Messaging System
Attachment #9010431 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.