Enable ExtensionStorageIDB backend on all channels

VERIFIED FIXED in Firefox 66

Status

enhancement
P1
normal
VERIFIED FIXED
9 months ago
2 months ago

People

(Reporter: rpl, Assigned: rpl)

Tracking

(Regressed 1 bug)

unspecified
mozilla66
Dependency tree / graph

Firefox Tracking Flags

(firefox66+ verified)

Details

Attachments

(2 attachments)

Assignee

Description

9 months ago
This is a follow up issue for Bug 1474562 which enabled the storage.local IDB backend on the Nightly channel during the 63 cycle.

We didn't enabled it yet on all channels, so that we can investigate the reasons behind some data migration failures that we have been able to identify using the related telemetry (Bug 1470213) once the data migration to the new backend has been enabled on Nightly.

This issue goal is to keep track of issues that are blocking it from being enabled on all channels (if any).
Assignee

Updated

9 months ago
Assignee: nobody → lgreco
Status: NEW → ASSIGNED
Priority: -- → P1
Assignee

Updated

8 months ago
Depends on: 1496801
QA Contact: ddurst
QA Contact: ddurst

Tracking to keep an eye on this for 66 release.

Assignee

Comment 2

4 months ago

Based on the results from the shield experiment we did run during December, the general QuotaManagerService/IndexedDB initialization issues tracked by the meta Bug 1482662 (which may make some users to fall back to the current storage.local JSONFile backend, if their profile is affected by this issue) should have a pretty low incidence on Beta (and not higher than the incidence we saw in Nightly) and so we are going to proceed on turning on the "storage.local IDB backend" (enabled by default on Nightly since Firefox 63) also on the other channels.

The patch that I'll attach is not going to change anything on Nightly, as it is already enabled and QA verified, but once it reaches Beta all the extensions will start to be migrated from the JSONFile backend to the IndexedDB backend on every profile on which the new beta builds are going to run, and so it seems worth to explicitly run a QA verification on Beta as we did on Nightly (once the patch reaches a Beta build).

Assignee

Comment 3

4 months ago
This patch enables the WebExtensions "browser.storage.local" IndexedDB backend
on non-Nightly channels.

Comment 4

4 months ago
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/e68122d62279
Enable ExtensionStorageIDB backend on all channels. r=aswan

Comment 5

4 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66

Comment 6

4 months ago
Posted image Bug1488825.png

This issue is verified as fixed on Firefox 66.0b3(20190128143734) under Win 7 64-bit and Mac OS X 10.14.1

The preference extensions.webextensions.ExtensionStorageIDB.enabled is set to true by default.

Please see the attached screenshot.

Updated

4 months ago
Status: RESOLVED → VERIFIED

Updated

2 months ago
Regressions: 1542181
You need to log in before you can comment on or make changes to this bug.