Closed Bug 1488927 Opened Last year Closed Last year

Clicking remove on a study in about:studies doesn't work

Categories

(Firefox :: Normandy Client, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- verified
firefox64 --- verified

People

(Reporter: mythmon, Assigned: mythmon)

References

Details

(Keywords: regression)

Attachments

(1 file)

When clicking on remove in about:studies, the study is not removed. Instead the an error is thrown: TypeError: AddonStudies.stop is not a function AboutPages.jsm:186:13

I believe this is a regression introduced in bug 1440780, which is in beta 63 now.
Assignee: nobody → mcooper
Status: NEW → ASSIGNED
Flags: qe-verify+
Comment on attachment 9006715 [details]
Bug 1488927 - Make about:studies "remove" button work again

Andrew Swan [:aswan] has approved the revision.
Attachment #9006715 - Flags: review+
Pushed by mcooper@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/94a9c739e329
Make about:studies "remove" button work again r=aswan
https://hg.mozilla.org/mozilla-central/rev/94a9c739e329
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
(In reply to Michael Cooper [:mythmon] from comment #0) 
> I believe this is a regression introduced in bug 1440780, which is in beta
> 63 now.

Michael, could you backport your patch to the 63 branch?  Thanks
Flags: needinfo?(mcooper)
Comment on attachment 9006715 [details]
Bug 1488927 - Make about:studies "remove" button work again

Approval Request Comment
[Feature/Bug causing the regression]: 1440780
[User impact if declined]: Users are unable to unenroll from studies in about:studies
[Is this code covered by automated tests?]: No (see bug 1442712)
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: Yes

1. Enroll in an add-on study (Using the Normandy Devtools [0] is recommend)
2. Open about:studies
3. Click "Remove"

Expected: the study is removed, the button changes state
Actual: The button does not change state and the study is not removed.

[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: A simple change that is easy to test.
[String changes made/needed]: None
Flags: needinfo?(mcooper)
Attachment #9006715 - Flags: approval-mozilla-beta?
Comment on attachment 9006715 [details]
Bug 1488927 - Make about:studies "remove" button work again

Fix for a functional regression on the about:studies page on 63 while we have several upcoming Shield studies, uplift approved for 63 beta 6
Attachment #9006715 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Adrian, would your team have the cycles to test the fix first on Nighty and then on Beta this week? Thanks
Flags: needinfo?(adrian.florinescu)
(In reply to Pascal Chevrel:pascalc from comment #8)
> Adrian, would your team have the cycles to test the fix first on Nighty and
> then on Beta this week? Thanks

For this fix alone, there is no problem verifying it this week. 
I'm concerned though if this regression isn't part of a bigger issue. I'll ping :mythmon to follow up on that.
The larger issue here was that the tests for about:studies were disabled, so automated tests didn't catch this. Tests have now been fixed and re-enabled, so there isn't a larger issue related to this for Adrian or his team to investigate.
Flags: needinfo?(adrian.florinescu)
Reproduced the issue on 63 Beta5; 

Verified as fixed on Windows 10, Windows 8.1:
64.0a1 	20180913100107
63.0b6 	20180913141435

Although due to comment 10, the manual verification wasn't necesary, I've verified this fix for good practice, removing qe verify flags.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.