Closed Bug 14890 Opened 21 years ago Closed 21 years ago

crash while resizing table-heavy pages while they are loading

Categories

(Core :: Layout: Tables, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 13881

People

(Reporter: cbegle, Assigned: karnaze)

References

()

Details

hey, i just clobbered and re-built last night, and didn't see this in your
bug queue.  if you resize a table-heavy page like my.netscape.com while the page
is loading, mozilla crashes.
- go to my.netscape.com
- while page is loading, grab the window handle and make the window smaller,
  then grab the handle and make the window bigger

i was able to reproduce this a few times.

stack trace:
NTDLL! 77f76148()
nsDebug::Assertion(const char * 0x0151b040, const char * 0x0151b034, const char
* 0x0151afec, int 90) line 181 + 13 bytes
FixedTableLayoutStrategy::AssignPreliminaryColumnWidths(int 3000) line 90 + 32
bytes
BasicTableLayoutStrategy::Initialize(nsSize * 0x00000000, int 1, int 3000) line
79
nsTableFrame::BalanceColumnWidths(nsIPresContext & {...}, const
nsHTMLReflowState & {...}, const nsSize & {...}, nsSize * 0x00000000) line 3842
nsTableFrame::Reflow(nsTableFrame * const 0x02a01754, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 2260
nsTreeFrame::Reflow(nsTreeFrame * const 0x02a01754, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 325 + 25 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x02a01750, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 372 + 28 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x02a01874, nsIPresContext &
{...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0) line 906 + 37 bytes
nsBoxFrame::FlowChildAt(nsIFrame * 0x02a01870, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {...}) line 1051
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}) line 682
nsBoxFrame::Reflow(nsBoxFrame * const 0x01ed4004, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 517
nsContainerFrame::ReflowChild(nsIFrame * 0x01ed4000, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 372 + 28 bytes
RootFrame::Reflow(RootFrame * const 0x029fe554, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 330
nsContainerFrame::ReflowChild(nsIFrame * 0x029fe550, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 372 + 28 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x029f8b54, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 516
PresShell::ResizeReflow(PresShell * const 0x027ca760, int 3000, int 1875) line
949
PresShell::ResizeReflow(PresShell * const 0x027ca764, nsIView * 0x027cab80, int
3000, int 1875) line 2132
nsViewManager::SetWindowDimensions(nsViewManager * const 0x027c9080, int 3000,
int 1875) line 365
nsViewManager::DispatchEvent(nsViewManager * const 0x027c9080, nsGUIEvent *
0x0012d390, nsEventStatus & nsEventStatus_eIgnore) line 1525
HandleEvent(nsGUIEvent * 0x0012d390) line 63
nsWindow::DispatchEvent(nsWindow * const 0x027caa44, nsGUIEvent * 0x0012d390,
nsEventStatus & nsEventStatus_eIgnore) line 338 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012d390) line 359
nsWindow::OnResize(nsRect & {...}) line 3131 + 15 bytes
nsWindow::ProcessMessage(unsigned int 71, unsigned int 0, long 1234464, long *
0x0012d594) line 2579 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x0040083e, unsigned int 71, unsigned int 0, long
1234464) line 447 + 27 bytes
USER32! 77e7145b()
USER32! 77e73475()
NTDLL! 77f7624f()
DocumentViewerImpl::SetBounds(DocumentViewerImpl * const 0x0279e8a0, const
nsRect & {...}) line 476
nsWebShell::SetBounds(nsWebShell * const 0x0244a220, int 0, int 0, int 200, int
125) line 1210
nsHTMLFrameInnerFrame::Reflow(nsHTMLFrameInnerFrame * const 0x0244a4c4,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState &
{...}, unsigned int & 0) line 976
nsContainerFrame::ReflowChild(nsIFrame * 0x0244a4c0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 372 + 28 bytes
nsHTMLFrameOuterFrame::Reflow(nsHTMLFrameOuterFrame * const 0x0244a904,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState &
{...}, unsigned int & 0) line 394
nsBoxFrame::FlowChildAt(nsIFrame * 0x0244a900, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 1, nsString & {...}) line 1051
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}) line 682
nsBoxFrame::Reflow(nsBoxFrame * const 0x01e37254, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 517
nsContainerFrame::ReflowChild(nsIFrame * 0x01e37250, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 372 + 28 bytes
nsScrollFrame::Reflow(nsScrollFrame * const 0x0239f724, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 670
nsBoxFrame::FlowChildAt(nsIFrame * 0x0239f720, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {...}) line 1051
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}) line 682
nsBoxFrame::Reflow(nsBoxFrame * const 0x01e33c24, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 517
nsBoxFrame::FlowChildAt(nsIFrame * 0x01e33c20, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {...}) line 1051
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}) line 682
nsBoxFrame::Reflow(nsBoxFrame * const 0x01e3210c, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 517
nsBoxFrame::FlowChildAt(nsIFrame * 0x01e32108, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {...}) line 1051
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}) line 682
nsBoxFrame::Reflow(nsBoxFrame * const 0x01e11f54, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 517
nsContainerFrame::ReflowChild(nsIFrame * 0x01e11f50, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 372 + 28 bytes
RootFrame::Reflow(RootFrame * const 0x0238eb34, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 330
nsContainerFrame::ReflowChild(nsIFrame * 0x0238eb30, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 372 + 28 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x02385044, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 516
PresShell::ResizeReflow(PresShell * const 0x01b95030, int 14580, int 11925) line
949
PresShell::ResizeReflow(PresShell * const 0x01b95034, nsIView * 0x01b957b0, int
14580, int 11925) line 2132
nsViewManager::SetWindowDimensions(nsViewManager * const 0x01b95980, int 14580,
int 11925) line 365
nsViewManager::DispatchEvent(nsViewManager * const 0x01b95980, nsGUIEvent *
0x0012f4e0, nsEventStatus & nsEventStatus_eIgnore) line 1525
HandleEvent(nsGUIEvent * 0x0012f4e0) line 63
nsWindow::DispatchEvent(nsWindow * const 0x01b95674, nsGUIEvent * 0x0012f4e0,
nsEventStatus & nsEventStatus_eIgnore) line 338 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f4e0) line 359
nsWindow::OnResize(nsRect & {...}) line 3131 + 15 bytes
nsWindow::ProcessMessage(unsigned int 71, unsigned int 0, long 1242992, long *
0x0012f6e4) line 2579 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x006b08dc, unsigned int 71, unsigned int 0, long
1242992) line 447 + 27 bytes
USER32! 77e7145b()
USER32! 77e73475()
NTDLL! 77f7624f()
DocumentViewerImpl::SetBounds(DocumentViewerImpl * const 0x01b6a650, const
nsRect & {...}) line 476
nsWebShell::SetBounds(nsWebShell * const 0x016c9af0, int 0, int 0, int 972, int
795) line 1210
nsWebShellWindow::HandleEvent(nsGUIEvent * 0x0012f904) line 506
nsWindow::DispatchEvent(nsWindow * const 0x016c9ee4, nsGUIEvent * 0x0012f904,
nsEventStatus & nsEventStatus_eIgnore) line 338 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f904) line 359
nsWindow::OnResize(nsRect & {...}) line 3131 + 15 bytes
nsWindow::ProcessMessage(unsigned int 71, unsigned int 0, long 1244052, long *
0x0012fb08) line 2579 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x00350908, unsigned int 71, unsigned int 0, long
1244052) line 447 + 27 bytes
USER32! 77e7145b()
USER32! 77e73475()
NTDLL! 77f7624f()
USER32! 77e714a7()
USER32! 77e72cc4()
USER32! 77e72ce2()
nsWindow::WindowProc(HWND__ * 0x00350908, unsigned int 274, unsigned int 61443,
long 17302231) line 454 + 31 bytes
USER32! 77e7145b()
USER32! 77e71d91()
NTDLL! 77f7624f()
USER32! 77e714a7()
USER32! 77e72cc4()
USER32! 77e72ce2()
nsWindow::WindowProc(HWND__ * 0x00350908, unsigned int 161, unsigned int 12,
long 17302231) line 454 + 31 bytes
USER32! 77e713ed()
010802d7()
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 13881 ***
Status: RESOLVED → VERIFIED
Marking bug verified as dup of #13881
You need to log in before you can comment on or make changes to this bug.