Closed Bug 1489012 Opened 3 years ago Closed 3 years ago

Print preview only shows and prints one page in a multiple-page document

Categories

(Core :: Print Preview, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1622935
Tracking Status
firefox64 --- affected

People

(Reporter: annyG, Unassigned)

Details

[steps to reproduce] 
1. Firefox Menu -> Print -> Save as PDF

[expected]
To see a PDF document with 13 pages

[actual]
PDF document with only the first page

[behaviour of other browsers]
Safari Technology Preview and Chrome Canary show 13 pages available for printing.


Tested on mozilla-central tip on macOS High Sierra 10.13.5
Sorry, I forgot to include the website where this error is happening

https://go.googlesource.com/proposal/+/master/design/go2draft-error-handling.md
When I disable the display:flex rule in the document, then the print preview shows multiple pages.

Daniel, do we have existing issues with flex containers and pagination?
Flags: needinfo?(dholbert)
Priority: -- → P3
Yeah, this is bug 939897.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(dholbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 939897

Firefox Nightly (2020-05-13) can now print the website without any data loss. Fixed by bug 1622935.

Duplicate of bug: 1622935
You need to log in before you can comment on or make changes to this bug.