Closed Bug 1489023 Opened Last year Closed Last year

[wpt-sync] Sync PR 12865 - Fire XHR abort event from a task

Categories

(Core :: DOM: Core & HTML, enhancement, P4)

enhancement

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: wptsync, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 12865 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/12865
Details from upstream follow.

Timothy Gu <timothygu@chromium.org> wrote:
>  Fire XHR abort event from a task
>  
>  A test for this new behavior is included as
>  external/wpt/xhr/abort-after-stop.htm.
>  
>  This also means that XHR abort and readystatechange events from
>  navigation is no longer fired. Because of that,
>  external/wpt/xhr/open-url-multi-window-4.htm now times out rather than
>  fails on an assertion, aligning with Firefox. A TestExpectations entry
>  has been added with a bug that tracks fixing this test in spec or
>  upstream in WPT. A few other test expectations were updated as well to
>  account for this.
>  
>  http/tests/navigation/reentrant-xhr-onabort-crash-during-commit.html no
>  longer works as intended, as abort event is no longer fired
>  synchronously (and thus does not expose the same crash surface). It is
>  replaced with an EventSource-based test that functions the same way as
>  XHR before this CL. Note, currently EventSource's error event suffers
>  from the same problem as XHR's abort event, and the class might undergo
>  the same change as this in the future. We will look into an alternative
>  for this test when that change is done.
>  
>  Bug: 879620, 881180
>  Change-Id: I5a91047086d06347794656f92511a53c22401b5e
>  
>  Reviewed-on: https://chromium-review.googlesource.com/1208672
>  WPT-Export-Revision: 9c5eb3299eca4c4237130d09af1ed9a80b32a7b5
Component: web-platform-tests → DOM
Product: Testing → Core
Ran 1 tests and 1 subtests
OK     : 1
PASS   : 1
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6cc4109ffbd1
[wpt PR 12865] - Fire XHR abort event from a task, a=testonly
https://hg.mozilla.org/mozilla-central/rev/6cc4109ffbd1
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.