add support for TLS hooks needed for certificate monitoring and alternate trust models

RESOLVED DUPLICATE of bug 1435951

Status

enhancement
RESOLVED DUPLICATE of bug 1435951
8 months ago
8 months ago

People

(Reporter: pabs3, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 months ago
The Certificate Patrol authors claim that their XUL extension cannot be ported to newer versions of Firefox because WebExtensions are not given APIs that can report TLS certificate information to extensions and provide alternate trust models to the X.509 single-CA-per-certificate model.

http://patrol.psyced.org/

Another related project is Perspectives, which augmented the X.509 CA signatures with a series of notary servers monitoring various sites from various networks and reporting results to browser users. This could be characterised as a more distributed version of Certificate Transparency.

https://perspectives-project.org/firefox/

Another related project is Monkeysphere, which aims to bring the OpenPGP trust model to SSH, the web and other protocols.

http://web.monkeysphere.info/why/#index1h2

All of these experiments were broken by the transition from XUL to WebExtensions but it would be nice if they did not have to fork Firefox in order to implement their functionality.

Updated

8 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1435951
You need to log in before you can comment on or make changes to this bug.