Middle-clicking a link from the address bar dropdown that is overflowing it will apply the fading effect on the URL's host name

VERIFIED FIXED in Firefox 63

Status

()

defect
P1
normal
VERIFIED FIXED
10 months ago
9 months ago

People

(Reporter: itiel_yn8, Assigned: mak)

Tracking

({regression})

unspecified
Firefox 64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox62 unaffected, firefox63+ verified, firefox64 verified)

Details

(Whiteboard: [fxsearch])

Attachments

(2 attachments)

Reporter

Description

10 months ago
Posted image Screencast
Using latest Nightly, Windows 10 x86.

STR:
Open any URL (long enough that it'll overflow the address bar) from the URL bar dropdown by middle-clicking it)

AR:
The host name will have the fading effect on it.

ER:
The fading effect should be applied on the last visible characters of the URL.

See attached screencast.

2018-09-07T09:47:48: DEBUG : Starting merge handling...
2018-09-07T09:47:48: DEBUG : Using url: https://hg.mozilla.org/integration/autoland/json-pushes?changeset=621979b26f697513f06f4c5f2db1d5ee580c4363&full=1
2018-09-07T09:47:49: DEBUG : Found commit message:
Bug 1485746 - Cursor gets reset to start of address bar on window switch. r=adw

This restores the previous behavior where we set the selection only when setting a new different value

Differential Revision: https://phabricator.services.mozilla.com/D4528

2018-09-07T09:47:49: DEBUG : Did not find a branch, checking all integration branches
2018-09-07T09:47:49: INFO : The bisection is done.
Reporter

Updated

10 months ago
Flags: needinfo?(mak77)
Assignee

Comment 1

10 months ago
looks like another unmanaged edge case to be investigated
Flags: needinfo?(mak77)
Priority: -- → P1
Whiteboard: [fxsearch]

Comment 2

10 months ago
[Tracking Requested - why for this release]:
Primary UI regression.
Reporter

Updated

10 months ago
Summary: Middle-clicking a link from the address bar dropdown that is overflowing the it will apply a fading effect on the URL's host name → Middle-clicking a link from the address bar dropdown that is overflowing it will apply the fading effect on the URL's host name
Assignee

Updated

10 months ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Assignee

Comment 3

10 months ago
Apparently the problem is that we set the selection only on "current", I just restored the old code, but the "current" check doesn't seem to be necessary...

Comment 5

10 months ago
Comment on attachment 9007825 [details]
Bug 1489402 - Middle-clicking a link from the address bar dropdown may apply the wrong overflow effect on the URL. r=adw

Drew Willcoxon :adw has approved the revision.
Attachment #9007825 - Flags: review+

Comment 6

10 months ago
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/031578506842
Middle-clicking a link from the address bar dropdown may apply the wrong overflow effect on the URL. r=adw

Comment 7

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/031578506842
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Please request Beta approval on this when you get a chance.
Flags: qe-verify+
Flags: needinfo?(mak77)
Reporter

Comment 9

10 months ago
LGTM on latest Nightly.
I can confirm that the issue does not occur on the latest Nightly v64.0a1 (2018-09-12).
Assignee

Comment 11

9 months ago
Comment on attachment 9007825 [details]
Bug 1489402 - Middle-clicking a link from the address bar dropdown may apply the wrong overflow effect on the URL. r=adw

Approval Request Comment
[Feature/Bug causing the regression]: bug 1485746
[User impact if declined]: wrong overflow when middle clicking results in the address bar popup, important parts of the url may not be visible
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: yes, str are in omment 0
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: trivial and contained patch
[String changes made/needed]: none
Flags: needinfo?(mak77)
Attachment #9007825 - Flags: approval-mozilla-beta?
Comment on attachment 9007825 [details]
Bug 1489402 - Middle-clicking a link from the address bar dropdown may apply the wrong overflow effect on the URL. r=adw

Contained patch fixing a 63 regression, uplift approved for 63 beta 7, thanks.
Attachment #9007825 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I have reproduced the issue in Beta 5 v63.0b5 and verified the fix in beta 7 v63.0b7 on Windows 10.
Uplift successful.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.