"A:active, A:hover" used for non-<a> elements

RESOLVED INVALID

Status

()

RESOLVED INVALID
17 years ago
17 years ago

People

(Reporter: sb, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    2002052306

In the page http://www.sebastian-bergmann.de/stuff/preface.html text
elements like "Preface" are highlighted, as defined in "A:active, A:hover"
(http://www.sebastian-bergmann.de/stuff/docbook.css) when the
mouse cursor is over them.

Reproducible: Always
Steps to Reproduce:
1. Open http://www.sebastian-bergmann.de/stuff/preface.html
2. Move mouse cursor over "Preface".
3. "Preface" is not a link, but the "A:active, A:hover"
   entry from http://www.sebastian-bergmann.de/stuff/docbook.css
   is used and the text is highlighted.

Actual Results:  http://www.sebastian-bergmann.de/stuff/preface.jpg


Expected Results:  "Preface" should not be highlighted. This is also the way MSIE6
renders the page.
Futher information: The page validates. I guess the following is responsible:

<h2 class="title"><a id="preface" /> Preface</h2>

Looks like we are waiting for the end tag.

Over to Styles.

pi
Assignee: Matti → dbaron
Status: UNCONFIRMED → NEW
Component: Browser-General → Style System
Ever confirmed: true
QA Contact: imajes-qa → ian
The page is sent as text/html, but it contains XHTML, not HTML.

Therefore this page is invalid.

Note that even if that was not the case, a:active and a:hover should apply to
all elements. Well, :hover definitely should. :active is covered by bug 65917.
The correct MIME type for XHTML documents is text/xml.

Marking bug INVALID.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.