Awesome bar does not delete suggestion from history

RESOLVED DUPLICATE of bug 1402555

Status

()

defect
RESOLVED DUPLICATE of bug 1402555
10 months ago
10 months ago

People

(Reporter: shchvova, Unassigned)

Tracking

({regressionwindow-wanted})

64 Branch
Points:
---

Firefox Tracking Flags

(firefox62 affected, firefox63 affected, firefox64 affected)

Details

Attachments

(1 attachment)

1.57 MB, video/quicktime
Details
Reporter

Description

10 months ago
Posted video firefox.mov
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:64.0) Gecko/20100101 Firefox/64.0
Build ID: 20180907100116

Steps to reproduce:

I'm trying to "Clearing all items in the address bar history" [1]
On macOS, doesn't work in Firefox Nightly or Firefox 64

1. Focus address/search bar (⌘L)
2. Type single letter "g"
3. Get suggestion "google.ca"
4. Press Shift Delete as per documentation
5. Clear address bar (or open new tab and focus address bar)
6. Type "g"
7. Get same suggestion of "google.ca" as before


[1] https://support.mozilla.org/en-US/kb/remove-websites-awesome-bar-suggestions#w_clearing-a-single-item-from-the-address-bar-history


Actual results:

I'm getting same suggestion as before, even if I clearly tried to delete it


Expected results:

Suggestion should go away as documented!
Reporter

Comment 1

10 months ago
You can see on attached video that I'm trying to Shift+Delete a suggestion, but it keeps coming back :(
Component: Untriaged → Address Bar
Hello,

I am trying to confirm this bug, but I think I understand the actual problem here:
Mac OS X does not have a "Delete" button on their keyboard and this may be related to the reptroduction.

I can confirm that "Clearing a single item from the address bar history" works in the case of Windows and Ubuntu OSes, but when trying to perform the same action on a MacBook, I can see that the "Delete" button is not present on it's keyboard. If I connect a normal keyboard (with "delete" key") and try to clear a single item from the address bar history, it does not work., however, it seems like the workaround for the Mac OS is to press SHIFT + BACKSPACE, not SHIFT + DELETE.

@Vlad Svoka, can you confirm that this works for you?

Thank you for your contribution!
Flags: needinfo?(shchvova)
Reporter

Comment 3

10 months ago
First of all, mac keyboard doens't have "backspace" key. It has only "delete" key see photo: https://www.apple.com/ca/shop/product/MLA22LL/A/magic-keyboard-us-english
It does work as backspace though: deletes symbol before the cursor, Fn+Delete deletes one after the cursor.
JS Event's keycode for Delete is 8, for Fn+Delete is 46

But regardless, even with external keyboard, it doesn't work.

May be I didn't articulate what exactly doesn't work.

When I type "g" in the bar, I get "google.com" as first suggestion. I want it to be "gmail.com". So I wanted to delete entries until it would become "gmail.com". But it doesn't work, whatever combination of buttons I press, it still gives me "google.com" suggestion.

It does delete it from current suggestion list, but next time I type "g" it completes it to "google.com", which I explicitly asked not to do.

To reproduce it, try typing "g" in address bar. Then try to delete entry which it autocompletes to, so it will autocomplete to another when you try it again. I don't think it's mac specific bug: it seem to delete entries from the list, but it doesn't seem to influence anything.
Flags: needinfo?(shchvova)
I see the same behavior. I am trying to delete a specific suggestion so that it would not appear as a suggestion anymore, but I am unable to delete it for good. It keeps appearing after several deletes and browser restarts, all the same.
This occurs the same on the MAC and Windows OSes and the 3 main browser versions (Nightly, Beta, Release).

I do not know whether this is an intended behavior, but I can confirm what the reporter claims. I hope developers can have a technical opinion about it.

I tried performing a manual regression (mozregression), but I seem to be missing some clear steps to reproduce. I appeal to someone who knows the functionality of this suggestion feature in hope of a clear reproduction of the issue.
@Marco Bonardo @Sylvestre Ledru: Can you make a clear and easy tutorial to reach the unwanted behavior so I could perform a mozregression?

I have set this issue as a duplicate of bug 1402555, but we can continue investigations there.

Thank you!
Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Flags: needinfo?(sledru)
Flags: needinfo?(mak77)
OS: Unspecified → All
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
See Also: → 1404429, 1391293
Duplicate of bug: 1402555
Sorry? i don't know much about this bug. I was just doing triage.
Flags: needinfo?(sledru) → needinfo?(shchvova)
Reporter

Comment 6

10 months ago
I'm not sure either... I just want it to work in a specific way, but I'm not sure if it supposed to do so. From what I understood from documentation, it does, but it didn't seem to work. It does look like bug you mentioned.
Flags: needinfo?(shchvova)
So, we have this functionality to delete entries from the Address Bar, but it's not supported on all the match types.
Unfortunately whether it's supported or not is undiscoverable, for which from quite a while we have bug 1041761 about adding a contextual menu, and there is also (cut can't find it atm) another alternative about adding a visible X button instead. But we'd likely go with a contextual menu.
This bug in specific is probably a duplicate of bug 1104141.
There are other entries that can't be actually removed: search suggestions, bookmarks, Visit xyz, keywords...
The only really removable things are history matches... Unfortunately this is all invisible and complex for the user, hopefully we'll have time after the next refactoring to look into the problem as a whole.
Flags: needinfo?(mak77)
Reporter

Comment 8

10 months ago
Thank you for detailed explanation! I was expecting it to work like a search bar blacklist, suggestion would filter through, rather than deleting actual history entries. It seems weird to delete history entries from a bar.
You need to log in before you can comment on or make changes to this bug.