Closed Bug 1489690 Opened Last year Closed Last year

de-COM XULSortServiceImpl

Categories

(Core :: XUL, enhancement, P5)

enhancement

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: mccr8, Assigned: mccr8)

References

(Blocks 1 open bug)

Details

Attachments

(4 files, 3 obsolete files)

This method is implemented as an XPCOM component, but it is only used in a single place, and has no data.
Priority: -- → P5
This is only used in a single place, so having a service for it is overkill.
There's no state on the object, so all of the methods can be turned
into static methods in the CPP files. I leave the one public method,
Sort, alone for simplicity. The internal data structure definitions
also don't need to be publicly exposed.

This patch is a bit messy because I had to rearrange methods so they
were defined before they were used. This makes the resulting code a
little nicer (as compared to forward declaring methods), but makes the
VCS history worse.

Also, I removed the unused Traverse method.

Depends on D5588
This is only used in a single place, so having a service for it is overkill.
This is only used in a single place, so having a service for it is overkill.
There's no state on the object, so all of the methods can be turned
into static methods in the CPP files. I leave the one public method,
Sort, alone for simplicity. The internal data structure definitions
also don't need to be publicly exposed.

This patch is a bit messy because I had to rearrange methods so they
were defined before they were used. This makes the resulting code a
little nicer (as compared to forward declaring methods), but makes the
VCS history worse.

Also, I removed the unused Traverse method.

Depends on 5591
There's only one method that is used, and we never need to create any
instances of the object, so turn it into a single method.

Depends on 5592
Attachment #9008197 - Attachment is obsolete: true
Attachment #9008196 - Attachment is obsolete: true
Attachment #9008195 - Attachment is obsolete: true
Comment on attachment 9008198 [details]
Bug 1489690, part 1 - Remove the registration for the sort service

Boris Zbarsky [:bzbarsky, bz on IRC] (PTO until Sept 10 end of day) has approved the revision.
Attachment #9008198 - Flags: review+
Comment on attachment 9008199 [details]
Bug 1489690, part 2 - Move everything not in the nsI interface into the cpp file

Boris Zbarsky [:bzbarsky, bz on IRC] (PTO until Sept 10 end of day) has approved the revision.
Attachment #9008199 - Flags: review+
Comment on attachment 9008200 [details]
Bug 1489690, part 3 - De-COM the XUL sort service

Boris Zbarsky [:bzbarsky, bz on IRC] (PTO until Sept 10 end of day) has approved the revision.
Attachment #9008200 - Flags: review+
Comment on attachment 9008249 [details]
Bug 1489690, part 4 - Fix some misc. issues with the XUL sort service

Boris Zbarsky [:bzbarsky, bz on IRC] has approved the revision.
Attachment #9008249 - Flags: review+
Duplicate of this bug: 1491005
Pushed by amccreight@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/32ddff737afb
part 1 - Remove the registration for the sort service r=bzbarsky
https://hg.mozilla.org/integration/autoland/rev/4b13e6ee961b
part 2 - Move everything not in the nsI interface into the cpp file r=bzbarsky
https://hg.mozilla.org/integration/autoland/rev/8a90c88beefe
part 3 - De-COM the XUL sort service r=bzbarsky
https://hg.mozilla.org/integration/autoland/rev/186a9c869beb
part 4 - Fix some misc. issues with the XUL sort service r=bzbarsky
You need to log in before you can comment on or make changes to this bug.