Amazon one-click search engine reappears on new browser session after being deleted

VERIFIED FIXED in Firefox 62

Status

()

P1
normal
VERIFIED FIXED
7 months ago
6 months ago

People

(Reporter: krinkodot22, Assigned: mkaply)

Tracking

({regression})

62 Branch
Firefox 64
regression
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox62+ verified, firefox63+ verified, firefox64+ verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20100101

Steps to reproduce:

After updating to Firefox 62, Amazon was automatically added as a one-click search engine for me. I remove it by going to Preferences->Search->One-Click Search Engines, clicking Amazon, then clicking "Remove".


Actual results:

Amazon reappeared as a search engine the next time I opened Firefox. Removing it and closing & reopening Firefox has it come back every time. This happens even in a fresh profile.


Expected results:

After being removed, Amazon should persistently remain absent from the search engine list after closing & reopening Firefox.
(Reporter)

Comment 1

7 months ago
(Note: my user agent was reported as FF60 instead of FF62 because I have privacy.resistFingerprinting turned on.)
Mike, rings a bell?
status-firefox62: --- → affected
Component: Untriaged → Search
Flags: needinfo?(mozilla)
(Assignee)

Comment 3

7 months ago
Yes, we've had this reported as bug 1489820 as well.

Are you using one of our Linux builds or a vendor packaged build?

Could you set the preference browser.search.log to true and then restart the browser.

I then need the contents of the Javascript console.
Flags: needinfo?(mozilla)
(Assignee)

Comment 4

7 months ago
bug 1305705. Sorry.
(Assignee)

Comment 5

7 months ago
I can reproduce. I'm going to track this in bug 1305705.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1305705
(Assignee)

Comment 6

7 months ago
I should have tracked this here as a new bug. 1305705 is too old of a bug to be a regression.

Bug is asyncReinit is being called because the langpack is being removed.
Status: RESOLVED → REOPENED
Ever confirmed: true
Keywords: regression
Resolution: DUPLICATE → ---
(Assignee)

Updated

7 months ago
Duplicate of this bug: 1489878
(Assignee)

Updated

7 months ago
Assignee: nobody → mozilla
Status: REOPENED → ASSIGNED
Priority: -- → P1
(Assignee)

Updated

7 months ago
Duplicate of this bug: 1489866
Comment on attachment 9007894 [details]
Bug 1489820 - Don't handle locale changes on shutdown.

Zibi Braniecki [:gandalf][:zibi] has approved the revision.
Attachment #9007894 - Flags: review+

Comment 11

7 months ago
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/7b0d4ede690a
Don't handle locale changes on shutdown. r=zbraniecki
(Assignee)

Comment 12

7 months ago
Comment on attachment 9007894 [details]
Bug 1489820 - Don't handle locale changes on shutdown.

Approval Request Comment
[Feature/Bug causing the regression]: 1437942
[User impact if declined]: When using langpacks, search engine changes don't stick
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: Yes.
Install langpack.
Switch to langpack.
Hide an engine.
Restart.
Engine should stay hidden.
[List of other uplifts needed for the feature/fix]: Non
[Is the change risky?]: No
[Why is the change risky/not risky?]: Only adds an extra check for when to reinit search.
[String changes made/needed]:
Attachment #9007894 - Flags: approval-mozilla-release?
Attachment #9007894 - Flags: approval-mozilla-beta?
Duplicate of this bug: 1490214

Comment 14

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7b0d4ede690a
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago7 months ago
status-firefox64: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
(Assignee)

Comment 15

7 months ago
[Tracking Requested - why for this release]: Regression.
tracking-firefox62: --- → ?
status-firefox63: --- → affected
tracking-firefox62: ? → +
status-firefox-esr60: --- → unaffected
tracking-firefox63: --- → +
tracking-firefox64: --- → +
Flags: qe-verify+
Comment on attachment 9007894 [details]
Bug 1489820 - Don't handle locale changes on shutdown.

Approved for 63.0b6.
Attachment #9007894 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 17

6 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/992b31153c1f
status-firefox63: affected → fixed
This issue needs verification in nightly and uplift to beta. In order to verify it, I need to reproduce it first.

I see this issue is related to the languagepack and I am not sure how to install/add it. I have attempted to add a language pack from here [https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&revision=554953db0c6120f7c67794dfb1bd5b493f15749d&searchStr=langpack]
to the Beta v63.0b4 (affected build) using the "Install Add-on From File" feature from the Plugins section of the "about:addons" page, but an error has blocked my attempts to reproduce the issue.

Mike, can you tell me how I can reproduce it (step-by-step) so I can verify it?
Also, will I be able to install language packs on Nightly builds so I can verify there as well?

Thank you!
Flags: needinfo?(mozilla)
This is a bit finicky, but here's how you get a language pack for Nightly:

Find out your build revision, go to the corresponding rev on treeherder, filter by `night L10n`, pick an Nx for your platform like on https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&searchStr=night,L10n&revision=1169e8a4ca2b7f3cbffdaf70f6d18a5142ed32d7&selectedJob=198777063, download a target.langpack.xpi.

You'll need to disable extension signing in your test profile to install that.

A similar procedure also works for dev-edition. On beta, I don't think you can disable signing, and I don't know where, if at all, we store the signed xpis. Callek would know.
(Assignee)

Comment 20

6 months ago
Moving needinfo to Callek who hopefully can help here.
Flags: needinfo?(mozilla) → needinfo?(bugspam.Callek)

Updated

6 months ago
Duplicate of this bug: 1490721
(In reply to Axel Hecht [:Pike] from comment #19)
> This is a bit finicky, but here's how you get a language pack for Nightly:
> 
> Find out your build revision, go to the corresponding rev on treeherder,
> filter by `night L10n`, pick an Nx for your platform like on
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&searchStr=night,
> L10n&revision=1169e8a4ca2b7f3cbffdaf70f6d18a5142ed32d7&selectedJob=198777063,
> download a target.langpack.xpi.
> 
> You'll need to disable extension signing in your test profile to install
> that.

All accurate...

> A similar procedure also works for dev-edition. On beta, I don't think you
> can disable signing, and I don't know where, if at all, we store the signed
> xpis. Callek would know.

On Beta, we have signed extensions uploaded to our infra (signed via AMO but not exposed to users on AMO).

For 63.0b4 in particular this is any of the language packs in https://archive.mozilla.org/pub/firefox/releases/63.0b4/linux-x86_64/xpi/
(Note that all* language packs are actually platform independent so should be fine to take from this folder for any platform)

Devedition is almost the same but has slight differences, so those go to 

https://archive.mozilla.org/pub/devedition/releases/63.0b4/linux-x86_64/xpi/

Again for beta/deved you do not need to fiddle with require-signing prefs for language packs, unless you are altering them (if altering please delete the META_INF root folder, I'm not sure how that interacts with the in product addon mechanics)

If you need further assistance, like finding a specific nightlies corresponding language pack, feel free to reach out here, IRC or Slack.

* (the one exception to "all language packs" is ja-JP which has an explicit ja-JP-mac variant for OSX)
Flags: needinfo?(bugspam.Callek)
I can't seem to reproduce it in several different attempts. 
I have attempted to reproduce the issue with the following steps:

A. On Nightly, Ubuntu16:
1. Installed a Nightly build v64.0a1 from 2018-09-08 / 2018-09-09;
2. Set the "extensions.langpack.signatures.required" pref as false (and prevented unwanted update).
3. Went to "about:buildconfig" and followed the Source link to get the revision.
4. Followed the "[default view]" link from the treeherder section.
5. Took a random Nx language pack from the Linux opt section, L10n subsection (target.langpack.spi).
6. Went to "about:addons", Plugins section.
7. Clicked on the settings icon (cog and down arrow) and chose "Install Add-on From File..." option.
8. With the file explorer, I loaded the downloaded language pack file.
9. Install language pack.
10. Make sure the language pack is in use.
11. Went to "about:preferences", Search section, One-Click Search Engines subsection.
12. Removed the Amazon entry from the "One-Click Search Engines" list.
13. Closed browser and reopened.
14. The issue did not reproduce; The Amazon search engine did not reappear.

B. On Beta, Ubuntu16:
1. Installed the latest Beta, v63.0b5.
2. Went to: https://archive.mozilla.org/pub/firefox/releases/63.0b4/linux-x86_64/xpi/
3. Downloaded a random language pack.
4. Manually added the language pack (like above).
5. Removed the Amazon One-Click Search Engine from the list (in Preferences).
6. Closed and reopened the browser.
7. The issue did not reproduce; The Amazon search engine did not reappear.

Is there something wrong with my process to install, find the language pack, apply the language pack?
Is there something wrong with how I attempt to reproduce the issue?

Can any of you guys help me reproduce it OR, if possible, reproduce it on your systems and verify it on fx64 and fx63?
Flags: needinfo?(mozilla)
Flags: needinfo?(l10n)
Flags: needinfo?(krinkodot22)
From https://firefox-source-docs.mozilla.org/intl/locale.html#testing-locale-switching, you want to switch to the language pack by going to the browser console, and enter

Services.locale.setRequestedLocales(["ro"]);

Use the correct locale code of the langpack you installed. That the langpack installed correctly can be verified by the "Languages" pane in about:addons showing up, and that setRequestedLocales does affect your UI locale.
Flags: needinfo?(l10n)
This issue could not be reproduced on an affected build. 

The following steps were used:
1. Installed a Nightly build v64.0a1 from 2018-09-08 / 2018-09-09;
2. Set the "extensions.langpack.signatures.required" pref as false (and prevented unwanted update).
3. Went to "about:buildconfig" and followed the Source link to get the revision.
4. Followed the "[default view]" link from the treeherder section.
5. Took a random Nx language pack from the Linux opt section, L10n subsection (target.langpack.spi).
(N5 is English - South Africa and has the Amazon one-click search engine) 
6. Went to "about:addons", Plugins section.
7. Clicked on the settings icon (cog and down arrow) and chose "Install Add-on From File..." option.
8. With the file explorer, I loaded the downloaded language pack file.
9. Installed language pack.
10. Made sure the language pack is in use and get the language pack's code (ex: "en-ZA" or "bd-BR"); 
11. Went to "about:preferences", Search section, One-Click Search Engines subsection.
12. Removed the Amazon entry from the "One-Click Search Engines" list.
13. Opened the Browser Console and input "Services.locale.setRequestedLocales(["en-ZA"]);" command;
14. Closed browser and reopened.
15. Open browser settings, Search tab;
15. The issue did not reproduce; The Amazon search engine did not reappear.
16. We also tried removing other one-click search engines in this language pack, switch to the other language pack and check whether the changes stuck or not.

This issue does not reproduce with different language packs installed and different changes made to the one-click search engine preferences.

@Krinkodot: What language are you using the browser on?

Comment 26

6 months ago
Hi, I’m the reporter of the duplicate https://bugzilla.mozilla.org/show_bug.cgi?id=1489878 and since the day before yesterday I can no longer reproduce my bug. I have FF 62.0, Build-ID 20180913170346. As far as I remember, there was an update the day before yesterday but I can’t find out what exactly was updated – the Browser itself, my Deutsch (DE) Language Pack (62.0buildid20180830143136), something else? In any case now the search preferences are kept on browser restart and the dictionary of my Ubuntu 16.04 system are available again in text fields.
(Assignee)

Comment 27

6 months ago
Here are exact steps to reproduce the problem and to show the fix:

Install Firefox beta 5
https://ftp.mozilla.org/pub/firefox/releases/63.0b5/win64/
Install the German langpack
https://ftp.mozilla.org/pub/firefox/releases/63.0b5/win64/xpi/de.xpi
Go to about:config
Create a string pref called intl.locale.requested
Set the value to de
Restart the browser
Verify you have German search engines
Go to preferences->Search (Suche)
Click on Ecosia and select Hide (Entfernen)
Verify the engine is gone in the awesome bar one off engines.
Restart the browser.
Notice that the engine has come back in the awesome bar.

Install Firefox beta 7:

Install Firefox beta 5
https://ftp.mozilla.org/pub/firefox/releases/63.0b7/win64/
Start with the same profile.
Verify engine is still there.
Go to preferences->Search (Suche)
Click on Ecosia and select Hide (Entfernen)
Verify the engine is gone in the awesome bar one off engines.
Restart the browser.
Notice that the engine is still hidden.

I have verified this myself on Windows.
Flags: needinfo?(mozilla)
(Reporter)

Comment 28

6 months ago
@danibodea: I have the "English (CA) Language Pack" installed & in use. I'm also still using FF62.

I've also confirmed that disabling the language pack allows the Amazon search engine to not reappear on new browser sessions after being removed.
Flags: needinfo?(krinkodot22)
(Reporter)

Comment 29

6 months ago
Also, re-enabling the language pack immediately re-applies the Amazon search engine, which is in line with what has been discussed here and in bug 1305705.
I could properly reproduce the issue with the STR provided in comment 27 on Beta 5 v63.0b5 and Nightly v64.0a1 from 2018-09-05 on Ubuntu 16.04. 
I could also verify the fix on Beta 7 v63.0b7 and Nightly from 2018-09-18.

Based on the above, the issue is verified and the uplift is successful.
Thank you.
Status: RESOLVED → VERIFIED
status-firefox63: fixed → verified
status-firefox64: fixed → verified
Flags: qe-verify+
Comment on attachment 9007894 [details]
Bug 1489820 - Don't handle locale changes on shutdown.

fix a regression related to langpack changes in 62; approved for 62.0.2
Attachment #9007894 - Flags: approval-mozilla-release? → approval-mozilla-release+
In case this approval is granted and fixed, will I be able to verify it on Release?
Flags: needinfo?(mozilla)
(Assignee)

Comment 33

6 months ago
> In case this approval is granted and fixed, will I be able to verify it on Release?

Yes. Same process as above should work, except you can download the language pack from AMO.
Flags: needinfo?(mozilla)

Comment 34

6 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-release/rev/f6d4c25645ce
status-firefox62: affected → fixed
Putting the qe-verify+ flag back for verification process.
Flags: qe-verify+
I have reproduced this issue in Firefox Release v62.0 and I have verified the fix in Firefox Release Candidate v62.0.2.
I have used the STR from comment 27 and the following language pack: https://addons.mozilla.org/ro/firefox/addon/deutsch-de-language-pack/

Uplift successful.
Thank you!
status-firefox62: fixed → verified
Flags: qe-verify+

Updated

6 months ago
Duplicate of this bug: 1495193
You need to log in before you can comment on or make changes to this bug.