Closed Bug 1489964 Opened 4 years ago Closed 3 years ago

Unable to view parts diagram on searspartsdirect.com while Tracking Protection Basic is enabled

Categories

(Web Compatibility :: Desktop, defect, P3)

Firefox 64
x86_64
Windows 10
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: oanaarbuzov, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [webcompat][tp-analytics])

User Story

adobedtm.com

Attachments

(2 files)

Attached image PartDiagramBroken.png
[Environment:]
Browser / Version: Firefox Nightly 64.0a1 (2018-09-09)
Operating System: Windows 10 Pro

[Prerequisites:]
    1. Tracking Protection Basic enabled.
[Steps to Reproduce:]
    1. Navigate to https://www.searspartsdirect.com/model-number/11087568810/0582/0151200.html?searchType=modelSearch 
    2. Click a parts diagram.
    3. Observe behavior.
        
[Expected Behavior:]
Parts diagram loads.
 
[Actual Behavior:]
A loading spinner is displayed and the parts diagram never loads.
The issue is related to `trackingprotection` breakage.

Looking at the devtools console, here are the blocked resources:
The resource at “https://assets.adobedtm.com/20a0f049b923ddf4f63dda0f67e44ce874adb8f3/satelliteLib-0da5ec6e531a75fc08cddaba79e898007950e5ee.js” was blocked because content blocking is enabled.[Learn More]
The resource at “https://www.google-analytics.com/analytics.js” was blocked because content blocking is enabled.
The resource at “https://www.googleadservices.com/pagead/conversion_async.js” was blocked because content blocking is enabled.
The resource at “https://s.go-mpulse.net/boomerang/EF6XC-LQFEX-53SHX-A5YVT-AFN3E” was blocked because content blocking is enabled.
The resource at “https://static.criteo.net/js/ld/ld.js” was blocked because content blocking is enabled.
The resource at “https://px.owneriq.net/stas/s/ipmvdt.js” was blocked because content blocking is enabled.
The resource at “https://secure.quantserve.com/aquant.js?a=p-W9J6SsLdhTvLa” was blocked because content blocking is enabled.
The resource at “https://connect.facebook.net/en_US/fbevents.js” was blocked because content blocking is enabled.
The resource at “https://acdn.adnxs.com/prebid/templates/postbid.js” was blocked because content blocking is enabled.

So below are the domains to test:
- ​assets.adobedtm.com
- ​www.google-analytics.com
- ​www.googleadservices.com
- ​s.go-mpulse.net
- ​static.criteo.net
- ​px.owneriq.net
- ​secure.quantserve.com
- ​connect.facebook.net
- ​acdn.adnxs.com

I opened the URL in a fresh browser profile (Firefox Nightly 64, uMatrix installed, normal mode) and loaded the page. The parts diagram does not load.

I disabled the Spoof Referrer option in uMatrix and then WHITELISTED:
- assets.adobedtm.com
- searspartsdirectapis.com
and the parts diagram is loaded.

The other resources didn't help. 

So in conclusion:
- adobedtm.com is in Analytics category = [tp-anaytics]
- searspartsdirectapis.com is not listed
Attached image uMatrxiResults.png
Added uMatrix results.
Product: Tech Evangelism → Web Compatibility

Migrating Webcompat whiteboard priorities to project flags. See bug 1547409.

Webcompat Priority: --- → ?

See bug 1547409. Migrating whiteboard priority tags to program flags.

Webcompat Priority: ? → ---

The part diagrams are working for me now in basic and strict mode, so this seems to have been fixed.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.