Site navigation bar doesn't track tabbed browsing

VERIFIED DUPLICATE of bug 102905

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 102905
16 years ago
13 years ago

People

(Reporter: david.hagood, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020530
BuildID:    2002053008

If Mozilla is set for "View->Site Navigation bar->As needed", and tabbed
browsing is enabled, and if one tab contains site nav data and one does not,
then as you change tabs the bar won't be updated correctly.

Reproducible: Always
Steps to Reproduce:
1. Open 2 tabs in one browser window.
2. set the browser view prefs to show the site nav bar as needed.
3. Open "about:blank" in the first tab.
4. Switch to the second tab. Load slashdot.org. Wait for it to complete.
5. Switch to the about:blank tab.

Actual Results:  Slashdot's site nav bar is shown.

Expected Results:  No nav bar is shown.

Perhaps the nav bar should be moved "below" the tabs - making it a child of the
tab, not the main window?

Comment 1

16 years ago
This is a duplicate of bug 102905 - Site navigation (links) toolbar doesn't
update when tabs are switched

The other issue you mentioned(site nav bar below tabs) is covered by:
bug 102990 - Site navigation toolbar should be inside content frame

*** This bug has been marked as a duplicate of 102905 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.