Closed Bug 1490015 Opened 2 years ago Closed 1 year ago

taskbar preview's favicon appears blank on fx 63 b4

Categories

(Core :: Widget: Win32, defect)

63 Branch
x86
Windows 10
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 + verified
firefox64 + verified

People

(Reporter: ershiwo, Assigned: mossop)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180906162647

Steps to reproduce:

Enable "Show tab previews in the Windows taskbar" feature, and move your cursor to taskbar.


Actual results:

All favicons of multitabs appear blank, not only built-in pages.
Component: Untriaged → Widget: Win32
OS: Unspecified → Windows 10
Product: Firefox → Core
Hardware: Unspecified → x86
mozregression says
Last good revision: 52baefdfbeca055fccb7518db3fd51ceea0649dc
First bad revision: 40ed437da7ae4407ece2ad47cd8fe3c7943f9eb9
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=52baefdfbeca055fccb7518db3fd51ceea0649dc&tochange=40ed437da7ae4407ece2ad47cd8fe3c7943f9eb9

due to bug 1453751
Blocks: 1453751
Flags: needinfo?(dtownsend)
Keywords: regression
Not sure if related, but someone reported that the taskbar only supports icons smaller than a certain size, and if you try to set a larger icon it just doesn't show one. Just reporting in case it's useful.
Comment on attachment 9012364 [details]
Bug 1490015: Allow tab previews to direct load data uris. r=Gijs

:Gijs (out Thu 27 - Sun 30 / 9;  he/him) has approved the revision.
Attachment #9012364 - Flags: review+
Pushed by dtownsend@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6f4606935025
Allow tab previews to direct load data uris. r=Gijs
https://hg.mozilla.org/mozilla-central/rev/6f4606935025
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Assignee: nobody → dtownsend
Flags: qe-verify+
Comment on attachment 9012364 [details]
Bug 1490015: Allow tab previews to direct load data uris. r=Gijs

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1453751
[User impact if declined]: Users will see a blank favicon for all their tabs in the windows taskbar
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Simply adds an additional protocol supported for direct loading rather than going through the moz-anno protocol.
[String changes made/needed]: None
Flags: needinfo?(dtownsend)
Attachment #9012364 - Flags: approval-mozilla-beta?
Comment on attachment 9012364 [details]
Bug 1490015: Allow tab previews to direct load data uris. r=Gijs

Regression fix in 63, uplift accepted for 63 beta 11, thanks.
Attachment #9012364 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Hello all,

I have reproduced the issue mentioned in Description using the affected 64.0a1(20180910220142) build.

This issue is verified fixed using Nightly 64.0a1(20180928100051) on Windows 10x32.

Although this issue has been verified and it is fixed for pages such as Reddit, Youtube, Instagram etc, it is worth mentioning that for internal pages such as "about:support, about:addons, about:policies etc" the favicon is not displayed, the nightly icon being displayed instead. 

Keeping this in mind, would you prefer we raise a different ticket for this issue?
(In reply to Vlad Lucaci (:vlucaci) from comment #11)
> Hello all,
> 
> I have reproduced the issue mentioned in Description using the affected
> 64.0a1(20180910220142) build.
> 
> This issue is verified fixed using Nightly 64.0a1(20180928100051) on Windows
> 10x32.
> 
> Although this issue has been verified and it is fixed for pages such as
> Reddit, Youtube, Instagram etc, it is worth mentioning that for internal
> pages such as "about:support, about:addons, about:policies etc" the favicon
> is not displayed, the nightly icon being displayed instead. 
> 
> Keeping this in mind, would you prefer we raise a different ticket for this
> issue?

Yeah probably best to raise a different ticket there.
(In reply to Vlad Lucaci (:vlucaci) from comment #11)
> Hello all,
> 
> I have reproduced the issue mentioned in Description using the affected
> 64.0a1(20180910220142) build.
> 
> This issue is verified fixed using Nightly 64.0a1(20180928100051) on Windows
> 10x32.
> 
> Although this issue has been verified and it is fixed for pages such as
> Reddit, Youtube, Instagram etc, it is worth mentioning that for internal
> pages such as "about:support, about:addons, about:policies etc" the favicon
> is not displayed, the nightly icon being displayed instead. 
> 
> Keeping this in mind, would you prefer we raise a different ticket for this
> issue?

Hi, there was a same issue: Bug 1403620

Maybe it is caused by svg icons.
Hello,

This issue has been verified fixed in 63.0b12 (20181004174654)on Windows 10x64 and Windows 10x32.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.