Closed Bug 1490039 Opened Last year Closed 9 months ago

Crash in ExpandedPrincipal::SubsumesInternal

Categories

(Firefox for Android :: General, defect, P3, critical)

Unspecified
Android
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox62 --- wontfix
firefox63 --- unaffected
firefox64 --- fix-optional
firefox65 --- wontfix

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression, topcrash, Whiteboard: [priority:medium])

Crash Data

This bug was filed from the Socorro interface and is
report bp-51bdf869-b7c2-4553-8670-f01cf0180910.
=============================================================

Crashes started using 20180909100231 - not sure where to file this. Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=da268c77ac7630925921792ffc32111ae3faf7a9&tochange=4df1ba9c741f1cb6661d9f205ad0fedf91d31925

11 crashes/5 installs so far. 

Top 10 frames of crashing thread:

0 libxul.so ExpandedPrincipal::SubsumesInternal xpcom/ds/nsTArray.h:372
1 libxul.so mozilla::BasePrincipal::Subsumes caps/BasePrincipal.cpp:112
2 libxul.so mozilla::BasePrincipal::Subsumes caps/BasePrincipal.cpp:112
3 libxul.so nsIPrincipal::Subsumes dist/include/nsIPrincipal.h:92
4 libxul.so js::SavedStacks::saveCurrentStack js/src/vm/SavedStacks.cpp:1328
5 libxul.so <name omitted> js/src/jsapi.cpp:7639
6 libxul.so mozilla::dom::ChromeUtils::GetCallerLocation dom/base/ChromeUtils.cpp:692
7 libxul.so mozilla::dom::ChromeUtils_Binding::getCallerLocation dom/bindings/ChromeUtilsBinding.cpp:3270
8 libxul.so js::InternalCallOrConstruct js/src/vm/Interpreter.cpp:449
9 libxul.so Interpret js/src/vm/Interpreter.cpp:594

=============================================================
Crash Signature: [@ ExpandedPrincipal::SubsumesInternal] → [@ ExpandedPrincipal::SubsumesInternal] [@ nsIPrincipal::Subsumes]
Crash Signature: [@ ExpandedPrincipal::SubsumesInternal] [@ nsIPrincipal::Subsumes] → [@ ExpandedPrincipal::SubsumesInternal] [@ nsIPrincipal::Subsumes] [@ mozilla::ContentPrincipal::SubsumesInternal]
ni on :sdaswani in case he has any ideas here. This is currently the top crash on nightly 64.
Flags: needinfo?(sdaswani)
Keywords: topcrash
since it's 64 putting it in our medium queue.
Flags: needinfo?(sdaswani)
Whiteboard: [priority:medium]
This seems to have had a 2 day spike on builds from Sept. 9th and 10th. I don't see any crashes yet in the build from Sept 11th.
One crash in the build from the 15th, so I will leave this open for now.
New spike on Oct 7-8 nightlies with a few dozen crashes.
Only a few URLs in the reports - https://www.foxnews.com/ and facebook.com. After the spike in Comment 5, it appears there are no reports on nightly since then.
On Fennec there are no further crashes since Comment 6. I added another desktop signature, but the count there is trivial.
Crash Signature: [@ ExpandedPrincipal::SubsumesInternal] [@ nsIPrincipal::Subsumes] [@ mozilla::ContentPrincipal::SubsumesInternal] → [@ ExpandedPrincipal::SubsumesInternal] [@ nsIPrincipal::Subsumes] [@ mozilla::ContentPrincipal::SubsumesInternal] [@ <name omitted> | ExpandedPrincipal::SubsumesInternal]
Continues to be sporadic, 3 crashes in the 65 build from October 23rd.
Priority: -- → P1
Current Priority on this? With low crash volume, do you still think it's a P1?
Flags: needinfo?(sdaswani)
Moved to P3.
Flags: needinfo?(sdaswani)
Priority: P1 → P3
Volume is so trivial now on both 62 and 63 we can probably just close this one out.
(In reply to Marcia Knous [:marcia - needinfo? me] from comment #11)
> Volume is so trivial now on both 62 and 63 we can probably just close this
> one out.

Closing because, one month later, the crash volume is still extremely low. There were only 3 crashes in the last week, all from 65.0a1.
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.