Intermittent reftest | load failed: timed out waiting for pending paint count to reach zero (after reftest-wait removed and switch to print mode) (waiting for MozAfterPaint)

RESOLVED FIXED in Firefox 65

Status

()

P2
normal
RESOLVED FIXED
6 months ago
2 months ago

People

(Reporter: tiberius_oros, Assigned: tnikkel)

Tracking

({intermittent-failure})

unspecified
mozilla65
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox65 fixed)

Details

Attachments

(2 attachments, 9 obsolete attachments)

9.40 KB, patch
sotaro
: review+
Details | Diff | Splinter Review
9.26 KB, patch
Details | Diff | Splinter Review
(Reporter)

Description

6 months ago
Recent log file:
https://treeherder.mozilla.org/logviewer.html#?job_id=198484878&repo=mozilla-inbound&lineNumber=4843

Snippet with the failure:
18:53:57     INFO - REFTEST TEST-START | http://localhost:49866/1536605585261/14/size-6x6.png == http://localhost:49866/1536605585261/14/encoder.html?img=size-6x6.png&mime=image/png
18:53:57     INFO - REFTEST TEST-LOAD | http://localhost:49961/1536605633990/6/size-6x6.png | 5 / 124 (4%)
18:53:57     INFO - ++DOMWINDOW == 11 (000001A93CA71400) [pid = 4928] [serial = 21] [outer = 000001A93CA48400]
18:53:57     INFO - REFTEST TEST-LOAD | http://localhost:49961/1536605633990/6/encoder.html?img=size-6x6.png&mime=image/png | 5 / 124 (4%)
18:53:57     INFO - --DOMWINDOW == 10 (000001A93CA73000) [pid = 4928] [serial = 14] [outer = 0000000000000000] [url = data:text/html;charset=UTF-8,%3C%21%2D%2DCLEAR%2D%2D%3E]
18:53:57     INFO - --DOMWINDOW == 9 (000001A93CA6F400) [pid = 4928] [serial = 13] [outer = 0000000000000000] [url = http://localhost:49961/1536605633987/3/encoder.html?img=size-3x3.png&mime=image/png]
18:53:57     INFO - --DOMWINDOW == 8 (000001A932680400) [pid = 4928] [serial = 12] [outer = 0000000000000000] [url = http://localhost:49961/1536605633987/3/size-3x3.png]
18:53:57     INFO - ++DOMWINDOW == 9 (000001A93C86B800) [pid = 4928] [serial = 22] [outer = 000001A93CA48400]
18:53:57     INFO - [Child 4928, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file z:/build/build/src/dom/base/nsContentUtils.cpp, line 4015
18:54:01     INFO - --DOMWINDOW == 8 (000001A93C86D400) [pid = 4928] [serial = 15] [outer = 0000000000000000] [url = http://localhost:49961/1536605633988/4/size-4x4.png]
18:54:01     INFO - --DOMWINDOW == 7 (000001A93CA76000) [pid = 4928] [serial = 16] [outer = 0000000000000000] [url = http://localhost:49961/1536605633988/4/encoder.html?img=size-4x4.png&mime=image/png]
18:54:08     INFO - --DOMWINDOW == 6 (000001A93C86BC00) [pid = 4928] [serial = 17] [outer = 0000000000000000] [url = data:text/html;charset=UTF-8,%3C%21%2D%2DCLEAR%2D%2D%3E]
18:54:08     INFO - --DOMWINDOW == 5 (000001A93C86C000) [pid = 4928] [serial = 18] [outer = 0000000000000000] [url = http://localhost:49961/1536605633989/5/size-5x5.png]
18:54:11     INFO - --DOMWINDOW == 8 (0000023A95C70400) [pid = 7160] [serial = 8] [outer = 0000000000000000] [url = about:blank]
18:54:11     INFO - --DOMWINDOW == 7 (0000023A8B881800) [pid = 7160] [serial = 3] [outer = 0000000000000000] [url = about:blank]
18:54:11     INFO - --DOMWINDOW == 6 (0000023A95A6C000) [pid = 7160] [serial = 4] [outer = 0000000000000000] [url = about:blank]
18:54:14     INFO - [Parent 5412, StreamTrans #32] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/modules/libjar/nsJARChannel.cpp, line 417
18:54:14     INFO - [Parent 5412, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file z:/build/build/src/modules/libjar/nsJARChannel.cpp, line 1125
18:56:54     INFO - [Parent 5412, Main Thread] WARNING: Suboptimal indexes for the SQL statement 0x252df949120 (http://mzl.la/1FuID0j).: file z:/build/build/src/storage/mozStoragePrivateHelpers.cpp, line 114
18:58:57     INFO - REFTEST TEST-UNEXPECTED-FAIL | http://localhost:49866/1536605585261/14/size-6x6.png == http://localhost:49866/1536605585261/14/encoder.html?img=size-6x6.png&mime=image/png | load failed: timed out waiting for pending paint count to reach zero (after reftest-wait removed and switch to print mode) (waiting for MozAfterPaint)
18:58:57     INFO - REFTEST INFO | Saved log: START http://localhost:49961/1536605633990/6/size-6x6.png
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
18:58:57     INFO - REFTEST INFO | Saved log: Initializing canvas snapshot
18:58:57     INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] RecordResult fired
18:58:57     INFO - REFTEST INFO | Saved log: RecordResult fired
18:58:57     INFO - REFTEST INFO | Saved log: START http://localhost:49961/1536605633990/6/encoder.html?img=size-6x6.png&mime=image/png
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering WaitForTestEnd
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] WaitForTestEnd: Adding listeners
18:58:57     INFO - REFTEST INFO | Saved log: Initializing canvas snapshot
18:58:57     INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for MozAfterPaint
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://localhost:49961/1536605633990/6/encoder.html?img=size-6x6.png&mime=image/png
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] Rect: 0 0 800 1000
18:58:57     INFO - REFTEST INFO | Saved log: Updating canvas for invalidation
18:58:57     INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for MozAfterPaint
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for MozAfterPaint
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for MozAfterPaint
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://localhost:49961/1536605633990/6/encoder.html?img=size-6x6.png&mime=image/png
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] Rect: 0 0 800 1000
18:58:57     INFO - REFTEST INFO | Saved log: Updating canvas for invalidation
18:58:57     INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://localhost:49961/1536605633990/6/encoder.html?img=size-6x6.png&mime=image/png
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] Rect: 0 0 800 1000
18:58:57     INFO - REFTEST INFO | Saved log: Updating canvas for invalidation
18:58:57     INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for MozAfterPaint
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://localhost:49961/1536605633990/6/encoder.html?img=size-6x6.png&mime=image/png
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] Webrender enabled, sending update whole canvas for invalidation
18:58:57     INFO - REFTEST INFO | Saved log: Updating entire canvas for invalidation
18:58:57     INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: dispatching MozReftestInvalidate
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_SPELL_CHECKS
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_APZ_FLUSH
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: done requesting APZ flush
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_APZ_FLUSH
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: apz-repaints-flushed fired
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FINISH
18:58:57     INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for MozAfterPaint
18:58:57     INFO - REFTEST TEST-END | http://localhost:49866/1536605585261/14/size-6x6.png == http://localhost:49866/1536605585261/14/encoder.html?img=size-6x6.png&mime=image/png
(Reporter)

Updated

6 months ago
Duplicate of this bug: 1139859
(Reporter)

Updated

6 months ago
Duplicate of this bug: 1489078
(Reporter)

Updated

6 months ago
Duplicate of this bug: 1489281
(Reporter)

Updated

6 months ago
Duplicate of this bug: 1489326
(Reporter)

Updated

6 months ago
Duplicate of this bug: 1489348
(Reporter)

Updated

6 months ago
Duplicate of this bug: 1489404
(Reporter)

Updated

6 months ago
Duplicate of this bug: 1489429
(Reporter)

Updated

6 months ago
Duplicate of this bug: 1489609
(Reporter)

Updated

6 months ago
Duplicate of this bug: 1489627
(Reporter)

Updated

6 months ago
Duplicate of this bug: 1489717
(Reporter)

Updated

6 months ago
Duplicate of this bug: 1489723
(Reporter)

Updated

6 months ago
Duplicate of this bug: 1489755
(Reporter)

Updated

6 months ago
Duplicate of this bug: 1489767
(Reporter)

Updated

6 months ago
Duplicate of this bug: 1360871
Priority: -- → P5
(Assignee)

Comment 15

6 months ago
Most of the duped bugs seem to be in layout.
Component: ImageLib → Layout
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Keywords: intermittent-failure
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
I guess this started from bug 1445570.
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Actually, these appear to be 100% webrender.
Component: Layout → Graphics: WebRender
Comment hidden (Intermittent Failures Robot)
FYI mattwoodrow, this started on sep 06 (the instances prior to sep 10 are in some of the bugs duped to this one) and is likely a regression from bug 1445570 as noted above - since this is pretty high frequency it would be good to look into it if you can spare some cycles.
Flags: needinfo?(matt.woodrow)
Any chance you can get this in pernosco roc? Thank you!
Flags: needinfo?(matt.woodrow) → needinfo?(roc)
I'm on it!
Flags: needinfo?(roc)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
:mattwoodrow, have you had a chance to work on this?  I see the pernosco link, hopefully that helps.
Flags: needinfo?(matt.woodrow)
Timothy is going to have a look at the recording, and we hope to have this fixed within the next week.
Assignee: nobody → tnikkel
Flags: needinfo?(matt.woodrow)
See Also: → bug 1489327
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Duplicate of this bug: 1489712
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Duplicate of this bug: 1497617
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
There are 166 failures in the last 7 days.
Recent failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=206010425&repo=autoland&lineNumber=56991
tnikkel: Hi, Do you have any updates on this? Thank you!
Flags: needinfo?(tnikkel)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
This bug has failed 106 times in the last 7 days. It failes on Windows10-64 QR and Linux64 QR on opt and debug build types.

Log:
https://treeherder.mozilla.org/logviewer.html#?job_id=207711440&repo=autoland&lineNumber=26489

mreavy: Can you please take a look at this bug?
Flags: needinfo?(mreavy)
(Assignee)

Comment 64

5 months ago
(In reply to Eliza Balazs [:ebalazs_] from comment #56)
> There are 166 failures in the last 7 days.
> Recent failure log:
> https://treeherder.mozilla.org/logviewer.
> html#?job_id=206010425&repo=autoland&lineNumber=56991
> tnikkel: Hi, Do you have any updates on this? Thank you!

Sorry for not replying right away (I had some pto). I've been working on this. No diagnosis yet. Will continue working on this today.
Flags: needinfo?(tnikkel)
Flags: needinfo?(mreavy)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
(Assignee)

Comment 70

5 months ago
(In reply to Robert O'Callahan (:roc) (email my personal email if necessary) from comment #38)
> https://pernos.co/debug/o5VpfK-_nRkIYczet1bTCA/index.html

The link seems to have expired. Any chance we could get another one?
Flags: needinfo?(roc)
Fixed things so that link works again.
Flags: needinfo?(roc)
Comment hidden (Intermittent Failures Robot)
(Assignee)

Comment 73

5 months ago
So far in my debugging it looks like we send an empty transaction to the parent, the parent decides that nothing changed, so does not do a composite nor send DidComposite to the child, but it also doesn't revoke the transaction. So we'll need a way for the parent to send a revoke transaction to the child.
Great investigation! WebRenderBridgeParent always tries to reply DidComposite. But since async scene building. Something might not work as expected.
Comment hidden (Intermittent Failures Robot)
(In reply to Sotaro Ikeda [:sotaro] from comment #74)
> Great investigation! WebRenderBridgeParent always tries to reply
> DidComposite. But since async scene building. Something might not work as
> expected.

WebRenderBridgeParent::RecvEmptyTransaction() triggers DidComposite by calling WebRenderBridgeParent::ScheduleGenerateFrame() if it is necessary. Because the RecvEmptyTransaction() does not always trigger WebRender rendering.

ScheduleGenerateFrame() triggers sending generate frame message to WebRender at WebRenderBridgeParent::MaybeGenerateFrame(). Even when WebRender skips actual rendering, RenderThread::UpdateAndRender() gets PipelineInfo from WebRender renderer and epoch is notified to WebRenderBridgeParent. And related DidComposite is handled. But since async scene building, it seems not work well.

Since async scene building, normal webrender transaction is sent via scene builder thread. And the transaction is handled as async way. But webrender transaction with generate frame does not use scene builder thread. Therefore, there could be a case that webrender transaction of RecvEmptyTransaction() is handled after the generate frame message.

There could be a case that webrender transaction of RecvEmptyTransaction() does nothing except updating epoch. In this case, webrender scene builder thread does not trigger the ScheduleGenerateFrame().

If generate frame message comes first and webrender transaction of RecvEmptyTransaction() does nothing except updating epoch. The epoch is not notified to WebRenderBridgeParent as PipelineInfo.
One possible fix is triggering generate frame after flushing scene builder thread.
Comment hidden (obsolete)
Intermittent of "waiting for MozAfterPaint" became less often with latest m-c. I wonder if Bug 1428558 is related.
Comment hidden (Intermittent Failures Robot)
With latest m-c, I did not saw "waiting for MozAfterPaint" on Windows QR, but I saw it on Linux QR Debug.
Comment hidden (Intermittent Failures Robot)
(Assignee)

Comment 87

4 months ago
(In reply to Sotaro Ikeda [:sotaro] from comment #76)
> There could be a case that webrender transaction of RecvEmptyTransaction()
> does nothing except updating epoch. In this case, webrender scene builder
> thread does not trigger the ScheduleGenerateFrame().
> 
> If generate frame message comes first and webrender transaction of
> RecvEmptyTransaction() does nothing except updating epoch. The epoch is not
> notified to WebRenderBridgeParent as PipelineInfo.

This seems to be whats happening. The sequence of events is:

RecvEmptyTransaction increments epoch 205 -> 206 and sends that to scenebuilder thread
MaybeGenerateFrame
RendererThread::UpdateAndRender starts
scenebuilder thread updates scene epoch to 206
render backend thread updates frame epoch to 206
RendererThread::UpdateAndRender completes, and sends a NotifyDidRender for epoch 205


Do we want to ScheduleGenerateFrame on the scenebuilder thread if the epoch is updated? Or would that cause too much overhead?
Whiteboard: [stockwell disable-recommended]
(In reply to Timothy Nikkel (:tnikkel) from comment #87)
> 
> RecvEmptyTransaction increments epoch 205 -> 206 and sends that to
> scenebuilder thread
> MaybeGenerateFrame
> RendererThread::UpdateAndRender starts
> scenebuilder thread updates scene epoch to 206
> render backend thread updates frame epoch to 206
> RendererThread::UpdateAndRender completes, and sends a NotifyDidRender for
> epoch 205
> 
> 
> Do we want to ScheduleGenerateFrame on the scenebuilder thread if the epoch
> is updated? Or would that cause too much overhead?

Yes, we want to ScheduleGenerateFrame if the epoch is updated. Then it seems better not to update epoch if TransactionBuilder does not have ResourceUpdates. Then WebRenderBridgeParent::RecvEmptyTransaction() does not need to call ScheduleGenerateFrame(). But if the RecvEmptyTransaction() did not call ScheduleGenerateFrame(), it caused talos regression. Then we need to keep ScheduleGenerateFrame() calling in the RecvEmptyTransaction() for now.
Flags: needinfo?(sotaro.ikeda.g)
I am going to update the patch.
(In reply to Sotaro Ikeda [:sotaro] from comment #88)
> Then WebRenderBridgeParent::RecvEmptyTransaction() does not need to call ScheduleGenerateFrame().

If TransactionBuilder has ResourceUpdates, ScheduleGenerateFrame will trigger ScheduleGenerateFrame via SceneBuilder by calling 
hooks.post_resource_update(). But if the RecvEmptyTransaction() did not call ScheduleGenerateFrame(), it caused talos regression. Then we need to keep ScheduleGenerateFrame() calling in the RecvEmptyTransaction() for now.
(In reply to Sotaro Ikeda [:sotaro] from comment #90)
> If TransactionBuilder has ResourceUpdates, ScheduleGenerateFrame will
> trigger ScheduleGenerateFrame via SceneBuilder by calling 
> hooks.post_resource_update()

Correction:
 If TransactionBuilder has ResourceUpdates, ScheduleGenerateFrame is triggered via SceneBuilder by calling  hooks.post_resource_update().
Comment hidden (obsolete)
Comment hidden (obsolete)
Attachment #9026020 - Flags: review?(matt.woodrow)
Comment hidden (Intermittent Failures Robot)
Comment on attachment 9026020 [details] [diff] [review]
path - Rollback WrEpoch if TransactionBuilder does not have ResourceUpdates in RecvEmptyTransaction()

Review of attachment 9026020 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/layers/wr/WebRenderBridgeParent.cpp
@@ +1126,5 @@
>                             /* aUseForTelemetry */scheduleComposite);
>  
>    if (scheduleComposite) {
> +    // This is actually not necessary, since ScheduleGenerateFrame() is triggered
> +    // via SceneBuilder thread. But if we remove it, it causes talos regression.

This worries me a bit. Which talos test regresses? Are you sure that we're not compositing the old content while scene building is in progress, and the talos test thinks we're done before we actually are? The regression might be 'real' in that case.
Attachment #9026020 - Flags: review?(matt.woodrow) → review+
(In reply to Matt Woodrow (:mattwoodrow) from comment #98)
> 
> This worries me a bit. Which talos test regresses?

I am going to check again with latest m-c.

> Are you sure that we're not compositing the old content while scene building is in progress, and the
> talos test thinks we're done before we actually are?

This does not happen, if there is resource update, WrEpoch is also updated. The updated WrEpoch is delivered via new webrender frame. And NotifyPipelineRendered() is handled after the frame rendering.
Comment hidden (obsolete)
Attachment #9027430 - Flags: review+

Comment 106

4 months ago
Pushed by sikeda@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3214fd9390a0
Rollback WrEpoch if TransactionBuilder does not have ResourceUpdates in RecvEmptyTransaction() r=mattwoodrow
Comment hidden (Intermittent Failures Robot)

Comment 108

4 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/3214fd9390a0
Status: NEW → RESOLVED
Last Resolved: 4 months ago
status-firefox65: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
(In reply to Andreea Pavel [:apavel] from comment #109)
> This is still occurring:
> https://treeherder.mozilla.org/#/
> jobs?repo=autoland&revision=9b21db074305040e2058811d24f7dbc95eb4adbf&selected
> Job=214655636
> 
> Sotaro can you take a look?

Yes. It seems to be caused by a different cause than Comment 87.

One possibility is that hooks.post_resource_update() was called, after sending SceneBuilderResult::Transaction message. But SceneBuilderResult::Transaction was not handled promptly.
Flags: needinfo?(sotaro.ikeda.g)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Andreea Pavel [:apavel] from comment #109)
> This is still occurring:
> https://treeherder.mozilla.org/#/
> jobs?repo=autoland&revision=9b21db074305040e2058811d24f7dbc95eb4adbf&selected
> Job=214655636
> 
> Sotaro can you take a look?

Oh, I did not check the failure happened at "Windows 10 x64 debug". Then it should not related to WebRender. :hiro advised me about it in IRC.

Then this should be handled as another bug(non webrender).
Status: REOPENED → RESOLVED
Last Resolved: 4 months ago4 months ago
Resolution: --- → FIXED
:apavel, Comment 109 happened for non-WebRender case. Then it is different than this bug. Can you create a new bug for it?
Flags: needinfo?(apavel)
I reopened bug 1469037.
Flags: needinfo?(apavel)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
(In reply to Andreea Pavel [:apavel] from comment #115)
> 
> failure log:
> https://treeherder.mozilla.org/logviewer.html#/
> jobs?job_id=218129208&repo=mozilla-release&lineNumber=19406
> 
> Should I file a different bug?

Yes, can you file a new bug? Thanks!
Flags: needinfo?(sotaro.ikeda.g)
Bug filed, thank you.
See Also: → bug 1516314
Comment hidden (Intermittent Failures Robot)

Updated

2 months ago
See Also: → bug 1523833
You need to log in before you can comment on or make changes to this bug.