opendiary.com - brainjar menus not sent, server-side

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: jon, Unassigned)

Tracking

Details

(Whiteboard: [tool] [deny] [proprietary-js], URL)

(Reporter)

Description

17 years ago
In IE/Netscape 4, the site has menus at the top of the page which allow yu to
navigate around the site. These menus are not display in any version of mozilla.
I have tried changing my user-agent string, to mimic IE6/5 and Netscape 4 but to
no avail. Not sure what the site is doing wrong?
(Reporter)

Comment 1

17 years ago
On 9th June 2002 I sent this to information@opendiaryplus.com (which is the
recommended address for information and website suggestions

Hi,

As a user of the Mozilla web browser and a regular reader of Open Diary
I'm a bit disappointed that one of the sites I view so regularly doesn't
work completely in the new, fully standard compliant Mozilla. Although
I can navigate around the site, none of the pull-down menus which are
visible in Netscape 4 and IE 6 are shown in Mozilla.

Since Mozilla has just been officially released (see
http://www.mozilla.org) and Netscape 7 (now in beta testing) is based on
it, I suspect that the number of users unable to see the menus properly
is going to grow rapidly.

Do you have any plans to fix this? I know I certainly would be more
inclined to ship my diary from Free Open Diary to Open Diary if this
were the case.

If you want more information on fixes for NS7 (and Mozilla) maybe you could
try:
http://devedge.netscape.com/evangelism/
or:
http://www.mozilla.org/docs/web-developer/

(I've filed a "bug report" into the 'incompatible website' section of 
Bugzila - the Mozilla problem database:
http://bugzilla.mozilla.org/show_bug.cgi?id=149019 and
will post your reply there so hopefully you shouldn't get too bombarded
with people asking you the same question).

Thanks in advance for any info,

Jon Levell
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Contact addresses are problem@opendiaryplus.com and information@opendiaryplus.com

Site uses http://www.opendiary.com/navcond.js (2001 version of BrainJar
dhtmllib) which does not support DOM and should be updated to a more recent version.

If your userAgent contains Netscape, Gecko, or Opera (possibly others as well),
OpenDiary serves different HTML that does not include the dynamic menu.
Blocks: 116172
OS: Linux → All
Hardware: PC → All
Summary: opendiary.com - Site menus do not appear → opendiary.com - brainjar menus not sent, server-side
Whiteboard: [tool] [deny] [proprietary-js]

Comment 3

15 years ago
-> other
Assignee: momoi → other
Component: The Americas → Other
QA Contact: jonrubin → other
seems to be fixed
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.