Closed Bug 1490288 Opened 3 years ago Closed 3 years ago

Crash in <name omitted> | mozilla::layers::InputQueue::ConfirmDragBlock

Categories

(Core :: Panning and Zooming, defect)

Unspecified
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1457603
Tracking Status
firefox63 --- unaffected
firefox64 --- fixed

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-4491c398-ee37-45f7-a5d9-bd0bd0180911.
=============================================================

Seen while looking at nightly crash data - 5 Mac crashes so far which started using 20180908100402: https://bit.ly/2CHaEbK

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=409f3966645a651c8cb8d6d1e2f3fa995b69c739&tochange=4df1ba9c741f1cb6661d9f205ad0fedf91d31925

Top 10 frames of crashing thread:

0 XUL <name omitted> gfx/layers/apz/src/InputBlockState.cpp:72
1 XUL mozilla::layers::InputQueue::ConfirmDragBlock gfx/layers/apz/src/InputQueue.cpp:721
2 XUL mozilla::layers::APZCTreeManager::StartScrollbarDrag gfx/layers/apz/src/APZCTreeManager.cpp:793
3 XUL mozilla::detail::RunnableMethodImpl<RefPtr<mozilla::layers::APZCTreeManager>, void  xpcom/threads/nsThreadUtils.h:1178
4 XUL nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1161
5 XUL nsBaseAppShell::NativeEventCallback xpcom/threads/nsThreadUtils.cpp:461
6 XUL nsAppShell::ProcessGeckoEvents widget/cocoa/nsAppShell.mm:461
7 CoreFoundation __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ 
8 CoreFoundation __CFRunLoopDoSources0 
9 CoreFoundation __CFRunLoopRun 

=============================================================
One comment from a web developer "Firefox Nightly crashes when I change the responsive sizes"

14 Mac crashes/12 installs in the last 7 days and is the #3 top Mac crash on nightly. ni on :dbolter to try to find a triage owner for this crash.
Flags: needinfo?(dbolter)
(In reply to Marcia Knous [:marcia - needinfo? me] from comment #0)
> 0 XUL <name omitted> gfx/layers/apz/src/InputBlockState.cpp:72

Not sure why function name is omitted in the top stack frame, but based on the line number this is the same diagnostic assert firing as in bug 1457603.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(dbolter)
Resolution: --- → DUPLICATE
Duplicate of bug: 1457603
It would be very helpful if people running into this would post STR in bug 1457603 (it's not clear to me what "change the responsive sizes" means).
You need to log in before you can comment on or make changes to this bug.