Bug 1490344 (gtktitlebardefault)

[Linux/Gtk] Enable hidden system titlebar by default

RESOLVED FIXED in Firefox 66

Status

()

enhancement
P3
normal
RESOLVED FIXED
10 months ago
3 months ago

People

(Reporter: stransky, Assigned: stransky)

Tracking

(Depends on 2 bugs, Blocks 1 bug, {feature})

Trunk
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 66+, firefox64 wontfix, firefox65 wontfix, firefox66 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

10 months ago
We may hide system titlebar by default at least on some well tested and recent enough platforms (Gnome derivates and Gtk+ > 3.20).
Assignee

Comment 1

6 months ago
This patch implements -moz-gtk-csd-hide-titlebar-by-default media query
to check if the system titlebar should be disabled by default on Linux systems
(it's already disabled on Window/Mac).

It also removes explicit definition of browser.tabs.drawInTitlebar preference on Linux.
When browser.tabs.drawInTitlebar is missing the -moz-gtk-csd-hide-titlebar-by-default
is used to obtain the titlebar state. When browser.tabs.drawInTitlebar is set
in about:config or by Customize menu, the user peference is used instead of the default.

It also fixes a -moz-gtk-csd-available media query,
it was always true regardless the actual system setting.
Assignee

Updated

6 months ago
Assignee: nobody → stransky
Assignee

Updated

5 months ago
Keywords: checkin-needed

Comment 4

5 months ago

Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aa442da7cfd8
[Linux/Gtk] Enable hidden system titlebar by default on Gnome, r=dao

Keywords: checkin-needed
Assignee

Comment 7

5 months ago

Should be fixed now, Thanks.

Flags: needinfo?(stransky)
Keywords: checkin-needed

Comment 8

5 months ago

Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cb3ca443d8c3
[Linux/Gtk] Enable hidden system titlebar by default on Gnome, r=dao

Keywords: checkin-needed

Comment 9

5 months ago
bugherder
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Depends on: 1521010
Depends on: 1521012

Release Note Request (optional, but appreciated)
[Why is this notable]: User facing change
[Affects Firefox for Android]: No, Linux only
[Suggested wording]: System titlebar is hidden by default to match Gnome guideline (I invented the last one)
[Links (documentation, blog post, etc)]:

relnote-firefox: --- → ?
No longer depends on: 1521010
Depends on: 1519606

I went with this wording for Nightly notes:
On Linux the Title Bar is now merged with the Tab Bar by default. This new behavior can be modified via the Customize… item in the main menu.

After this change, whenever I start Firefox, the right-click dropdown menu and the autoscroll wheel appear about a titlebar's height below and to the right of the cursor position. It corrects itself once resize the window.

Bug 1521175 describes a regression from this change.

Assignee

Updated

4 months ago
Alias: gtktitlebardefault
Assignee

Updated

4 months ago
Depends on: 1527837
Assignee

Updated

4 months ago
Depends on: 1525850
Assignee

Updated

4 months ago
Depends on: 1524861
Assignee

Updated

4 months ago
Depends on: 1523560
Assignee

Updated

4 months ago
Depends on: 1522774
Assignee

Updated

4 months ago
Depends on: 1497066
Assignee

Updated

4 months ago
Depends on: 1529713
Assignee

Comment 14

4 months ago

Bug 1529713 needs to be backported to FF66 or this bug should be reverted for FF66 due to regressions listed here.

Assignee

Updated

4 months ago
Depends on: 1530252
Assignee

Updated

4 months ago
Depends on: 1530625

Noted for 66 as "System title bar is hidden by default to match Gnome guideline for Linux users"

You need to log in before you can comment on or make changes to this bug.