minimize to system tray icon/icon menu

VERIFIED DUPLICATE of bug 208923

Status

enhancement
VERIFIED DUPLICATE of bug 208923
10 months ago
4 months ago

People

(Reporter: zhawk83, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

The original bug was closed for reasons that are not true (a 8 years old comment).
MS Notifications: https://docs.microsoft.com/en-us/windows/desktop/uxguide/mess-notif
"In this example, users are notified when a new e-mail message is received."

Another MS Source: https://docs.microsoft.com/en-us/windows/desktop/uxguide/winenv-notification
Outlook is a common example that is used in the notification area (SysTray).

Further this is not just a Windows request but also a Linux request. Linux users do want this feature too. (Only GNOME seems to have issues with SysTray).

You can see a discussion here https://github.com/foudfou/FireTray/issues/238
Most users are Linux users.




+++ This bug was initially created as a clone of Bug #208923 +++

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030609
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030609

Thunderbird should adopt the icon tray... but better than mozilla has/did.

Use it similar to how AIM or MSN use it, allowing for easy access to common
functions like "Check Mail", "Open Mail Window", "Compose Mail", etc.

It would be nicer to minimize the mail window to the system tray, rather than
the task bar.  Saves space and looks nicer.  Most people like their mail client
open all day... so it saves for those people.

Secondly, it could show how many messages are in the inbox by right clicking on
the icon...

"Inbox (5)" perhaps?

Something similar to how Mail.app has that menu when open in the doc. (BTW the
feature on the Mac side would be good).

Would be nice and convient for all


Since It's going to get a nice overhaul so it looks pretty... and is easier to
use... why not make it the perfect mail client?

Reproducible: Always

Steps to Reproduce:
I won't be surprised if this is closed as WONTFIX like Bug 208923, but at least it gives an opportunity to raise the question:

If "minimize to tray" is unacceptable for one reason or another, what about offering the option of changing the behavior of the "close" button so it will minimize instead (requiring either a right-click menu on the taskbar or a "Hamburger/Exit" to actually close TB). I can't really count the times I closed TB by mistake and only realized it hours later, missing important/urgent emails in the meantime.
What you are suggesting is an ugly hack partially emulating the behavior of "minimize to tray". "minimize to tray" exists in order to do that and it does it well.

Back to "minimize/close to tray" itself.
I'd like to point out that despite their agenda to phase out tray icon, Evolution, Gnome's own mail client, still supports system tray.
System tray is far from dead ! Old xembed specification has even been replaced by the new, shiny and more standardized Status Notifier Item specification.
https://www.freedesktop.org/wiki/Specifications/StatusNotifierItem/
http://blog.martin-graesslin.com/blog/2014/03/system-tray-in-plasma-next/
https://blog.martin-graesslin.com/blog/2014/06/where-are-my-systray-icons/
I do realize how annoying it is to not have this feature in Thunderbird for so long. After all, I think I was one of the people who put their vote on the original bug/feature request (did you even know you can actually cast votes on bugs in Bugzilla?).

But opening a duplicate bug when the first one is WONTFIX'ed is really not the way to go. Bugs can be reopened (although not everyone can do that), and they can be commented and/or voted on even after they're closed. If you want to present additional arguments, you should do that on the original bug instead of creating a new one. Although realistically, nowadays this feature is certainly less important than it was 16 years ago when the original ticket was opened, and Thunderbird has much less people working on it that back then, so I wouldn't get my hopes up high. A third-party app might be the only viable solution by now.
Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 208923
P.S. I'm not a Mozilla employee, and the view presented above is just my personal opinion.
Hey, the original bugs has not only been marked WONTFIX but also closed for comments. Therefore the discussion needs to happens somewhere else.

I think that even having a confirm to close dialog would be helpful to avoid unwished closing the email app regardless of the availability of "minimize to tray" functionality.

I also think that arguments given for WONTFIX have not convinced many people and it is sad that no discussion is allowed there.
Ah, indeed, comments were closed. In that case it might be best to find the Thunderbird discussion forum/group (wherever that is at the moment) and start a thread there, or join an existing one. Or to try convincing Magnus to reopen comments on that bug via IRC (although I suppose most of arguments have already been brought up in the bug in those 16 years).

Regarding confirm-to-close, it's a separate feature request, distinct from minimize to tray. You may want to search Bugzilla to see if that has been requested already and subscribe to the bug if it has, or create a new bug if not. Who knows, perhaps it would even be implemented quickly and easily! :)
"Although realistically, nowadays this feature is certainly less important than it was 16 years ago when the original ticket was opened"
Why ? Did you stop having Thunderbird opened all day long ? Have you found a way to have it opened without wasting your taskbar space ?
The renewed interest in this feature comes from deprecating XUL (which is already completely dead in Firefox).  During those 16 years, we had several extensions which implemented minimize to tray plus new mail count.  Making these extensions work with TB60 was tricky but it seems that some folks managed (Firetray has a working pull request).  Too bad, if XUL goes away completely as it's likely to, it will be impossible to reimplement this functionality unless suddenly webexts grow the needed APIs.

Thus, we need _some_ way -- be it extensions or core.  Comparing to similar mail clients (Outlook, Evolution) it would be natural to do so in the core.

Both Microsoft and Gnome tried to reinvent their systems' UI, and both backpedaled (Microsoft nearly completely, Gnome only slightly).  And all other Linux environments (XFCE, KDE, LXDE, Mate, ...) never deprecated systray and don't intend to.
Does the development team currently think that this feature is no longer desired or they've got some sort of replacement for the system tray icon?

If the team believes that it's not desired any more, shall we open a poll somewhere to collect users' opinions on it?

If the team has got a replacement for it, then what is the replacement exactly? In Bug 208923, it was mentioned that the replacement could be "notifications". But imho, indeed using pop-ups from the system tray icon (e.g. https://i.imgur.com/KYjP6Fp.jpg) to notify users of new emails is somewhat obsolete however another non-negligible function that system tray icons can provide is to avoid closing the program by accident and keep it always running in the background while saving some space in the task bar. Of course other features e.g. badges to show the number of unread emails are nice to have as well.

I can somehow see the point of using only notifications so that even if TB is closed there can still be a running lightweight daemon to send users notifications when new emails arrive (like how email clients behave on phones). I'm not a UX expert so I wouldn't say whether this is really also suitable for desktops or not, but I reckon unless all DEs coerce all applications to behave in this macOS-like way, which is something I can't see that's gonna happen, implementing this feature wouldn't make TB "modern" but actually "inconsistent" instead. TB has to work with the heterogeneity among different desktop environments since it's not mainly designed for any particular DE like Evolution or Kmail. Using both notifications and a system tray icon should be the right (and actually an easier) way to go I guess.
I have been using Thunderbird as my main mail client for personal email for about 10 years and on my work email for about 4 years (converted from Outlook).

On my work email (running W10) I've updated to 60 and then reverted back to 52 because of this issue. On my personal email (Fedora 28 Cinnamon) I've tried to stick with 60, but it's a pain, I will probably revert to 52 very soon.

I want my email client to sit on the system task bar hidden away so that it doesn't distract me too much. Then I can alt tab through my active windows and have pop up notifications when a new mail arrives.

This is one of the few issues that may push me back to Outlook for my work mail, which would be really depressing as I've just got to the stage of dropping Windows on my work laptops.
I totally agree with you. And I do not understand why the original ticket's discussion has been just closed so that we can exchange our thoughts only the duplicate tickets with likely no impact on the developer decisions at all.
A point not raised yet is Lightning (Calender). It has now become part of the standard TB installation. Using a calander app without notifications is kind of useless. Yet TB needs to run to get notifications. As Philipp Kewisch is now part Thunderbird team (at least last I've heard) it would be nice to hear his opinion on this.
Flags: needinfo?(philipp)
Please read https://bugzilla.mozilla.org/page.cgi?id=etiquette.html, then continue the discussion on the support-thunderbird mailing list: https://lists.mozilla.org/listinfo/support-thunderbird.

See e.g. the recent thread "TB 60 - Any news about firetray alternative?":https://groups.google.com/d/msg/mozilla.support.thunderbird/miSuA107c4s/4UrqSh8KAwAJ.
Status: RESOLVED → VERIFIED
This isn't a discussion between users, this is a bug report about a missing (essential, in our opinion) feature of Thunderbird, feature which is available in "all" the competing products.
So far, we still don't know why Thunderbird devs are so hostile to this feature and how they expect us to use the product. Are we supposed to keep the client opened in the taskbar ? Is the team really thinking that it is a good idea ?

As said in the previous comments
`Given Microsoft is recommending *against* doing this nowadays` relies on outdated (8 years old) info.
`and on linux this isn't really a thing` is a wrong assumption.
This native feature becomes essential since XUL is getting phased out and we can't have it through webextensions.

Why is "minimize to tray/new mail count" such a detrimental feature to Thunderbird ?
Adam Borowski and frederick888 both gave very good points. Can theses be addressed ?
(In reply to Yamashita Ren from comment #14)
> As said in the previous comments
> `Given Microsoft is recommending *against* doing this nowadays` relies on
> outdated (8 years old) info.

It's still the current recommendation from Microsoft. Here's an updated version of the documentation I originally linked, last updated in May 2018: https://docs.microsoft.com/en-us/windows/desktop/uxguide/winenv-notification
(In reply to Jim Porter (:squib) from comment #15)
> (In reply to Yamashita Ren from comment #14)
> > As said in the previous comments
> > `Given Microsoft is recommending *against* doing this nowadays` relies on
> > outdated (8 years old) info.
> 
> It's still the current recommendation from Microsoft. Here's an updated
> version of the documentation I originally linked, last updated in May 2018:
> https://docs.microsoft.com/en-us/windows/desktop/uxguide/winenv-notification

> Does your program need to display a notification? If so, you must use a notification area icon.
Yes Thunderbird displays notifications. New mail notifications.

>>Is the icon displayed temporarily to show a change of status? If so, a notification area icon may be appropriate, depending upon >>the >following factors:
>>
>>    Is the status useful and relevant? That is, are users likely to monitor the icon and change their behavior as a result of this >>information? If not, either don't display the status, or put it in a log file.
Users will open Thunderbird when they see a "new mail notification".

https://docs.microsoft.com/en-us/windows/desktop/uxguide/winenv-notification#usage-patterns
Outlook is given as an example of a good use of the notification area in the "Minimized single-instance application" usage.
Now, it seems that since Windows 7, Microsoft wants you to use taskbar buttons instead... Using Windows gives me headaches so I will not comment on this recommendation.

However, Linux DE standard isn't using "taskbar buttons" (does they even exist ?) but notification area, see comment 2.
If Thunderbird team cares about us, they should come up with a solution. As frederick888 pointed out in comment 9, notification area seems the best solution but, maybe, we are lacking some insight and there is a better one available. If so, please enlighten us.
A notification is not enough.  It is visible for a few seconds, then goes away.  If you were away, not looking at the screen, focused on something else, etc -- you won't know you have new mail.  On the other hand, the behaviour of TB+Firetray and most other mail clients is fine: a notification briefly appears (with information about the new mail's subject) then goes away, but the tray icon persists, and instead of an envelope now shows a prominent number.

Even if there's currently 0 new mails, the tray icon shouldn't disappear: it's an important thing to know you have the mail client running (so it watches for new mail) or not.  Less importantly, it's good if the interface to bring up the client works consistently regardless if there's an unread piece of mail or not.

There's also no "Linux DE standard".  While GNOME tries to force its ideas, the rest of the world disagrees.  That's fine, no one's forced to use minimize-to-tray.  The technical interface changed from xembed but that's an implementation detail.
(In reply to Yamashita Ren from comment #16)
> > Does your program need to display a notification? If so, you must use a notification area icon.
> Yes Thunderbird displays notifications. New mail notifications.

That's not what the quoted text means. It means: if you want to display a Windows Notification (the little bubble in 7 and earlier), you need to create an icon in the notification area first.
(In reply to Yamashita Ren from comment #14)
> So far, we still don't know why Thunderbird devs are so hostile to this
> feature and how they expect us to use the product. Are we supposed to keep
> the client opened in the taskbar ? Is the team really thinking that it is a
> good idea ?

I think the reason for so-called hostility is simply the lack of manpower in the Thunderbird team. The underlying platform is changing at an incredible pace, and the few Thunderbird developers barely have time to fix breakages that occur, let alone add new features. Plus, they likely have full-time jobs too, which means Thunderbird only gets their free time (as far as I know, Thunderbird has no paid developers anymore).

It's a tough situation, but it has been like that for quite a few years already. Which is why if you are a developer and a loyal Thunderbird user, the best thing to see your so desired feature added might be to just roll your sleeves up and implement it yourself, then propose it as a patch.
> A notification is not enough.  It is visible for a few seconds, then goes away.

This may or may not be the case. For example, at least in KDE Plasma, if you "pin" an application in the taskbar, even if the application is closed, it can still carry out background jobs and show status/progress via the taskbar icon. For example, if you've pinned Plasma's file manager Dolphin, you can then close Dolphin after telling it to do some time-consuming operations, and it'll show a badge on the icon (https://i.imgur.com/rcjbFkl.png). At the same time, the system notification jumps in to help as well to show users real-time progress (https://i.imgur.com/1iAjtWm.png) and provide a notification pop-up when the job's done.

BUT, my point is:

1. To achieve such a level of user experience, a great amount of effort would be needed to deeply integrate all, or even only popular DEs
2. Unlike Dolphin and email clients on smartphones, which can delegate their work to OSs to some extent, TB would actually always be a standalone application on its own. I would doubt whether users would appreciate the idea of having TB running in the background without any special indication
3. There are lightweight DEs which may not provide APIs for badges and etc. On the other hand, system tray icon is well-established and widely adopted

> Which is why if you are a developer and a loyal Thunderbird user, the best thing to see your so desired feature added might be to just roll your sleeves up and implement it yourself, then propose it as a patch.

But why would they close bug 208923 then? If it's an issue of the lack of manpower they could simply mark it as "confirmed" and explain the reason why it gets parked. Isn't it the case now that even if someone does the heavy-lifting and sends the team a patch, they would reject it anyway in favour of some kind of "more modern" approach?
You could ask Magnus for clarification on whether or not such patch would be accepted. If I remember it correctly, the 'WONTFIX' status means that the team will not be fixing the issue, but it doesn't necessarily mean that a good patch for it would not be accepted.
Flags: needinfo?(mkmelin+mozilla)
I would also like to add that this functionality seem to be impossible to implement using WebExtensions. I have spent three days trying, and I see no way to intercept close/minimize events from a new type WebExtensions-based plugin. Notably the observer service registration, as documented here: https://developer.mozilla.org/en-US/docs/Mozilla/Tech/XPCOM/Reference/Interface/nsIObserverService fails due to missing Components.Services. This seem only to be possible from a native plugin.
If only people could stop commenting on the old bug, the bug with closed comments...

@:aceman There is no systray icon if you don't use the (out of date and soon legacy) firetray extension.
What you are proposing is "hiding" Thunderbird in another virtual desktop. But if you hide Thunderbird in another desktop, how will you know that there are news mails you didn't read ?
Flags: needinfo?(acelists)
For new mail indication, there is bug 1482674.
Whether the icon is there or not, it does not indicate new mail. At least on Linux.
Yes, maybe some extension fixed both problems.

Did anybody actually see why the Firetray extension does not work anymore? Did the author just abandon it and not update it? Or was a needed interface removed from the platform? If the former, we can fix it.
Flags: needinfo?(acelists)
> Did anybody actually see why the Firetray extension does not work anymore?
Sure they did. 
https://foudil.fr/blog/209/the-web-is-not-the-platform/
https://github.com/foudfou/FireTray/issues/238#issuecomment-419638232
Hmmmm... native messaging might be an option then. You'd have to use an extra installer to get your systray support, but at least it seems doable.
Native messaging would indeed work for new mail notifications. But it is possible to do this even without native messaging. I'm testing a standalone tool right now.
Hello, I have released a new standalone system tray new mail notification for Thunderbird. Please check it out here: https://github.com/gyunaev/birdtray - it uses Thunderbird email search database directly, and does not require extensions. Thus it will work even when Thunderbird will drop ctypes support. No minimizing to tray yet, only new email notifications in tray.

(In reply to Rimas Kudelis from comment #21)
WONTFIX basically means a patch would not be accepted.

Re calendar needing notifications: this bug is not about notifications but about system tray integration.

Flags: needinfo?(philipp)
Flags: needinfo?(mkmelin+mozilla)
You need to log in before you can comment on or make changes to this bug.